Bug 1247551 - forgotten inodes are not being signed
forgotten inodes are not being signed
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: bitrot (Show other bugs)
3.7.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Raghavendra Bhat
bugs@gluster.org
:
Depends On: 1245981
Blocks: 1245165
  Show dependency treegraph
 
Reported: 2015-07-28 06:00 EDT by Raghavendra Bhat
Modified: 2015-12-01 11:45 EST (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1245981
Environment:
Last Closed: 2015-09-09 05:38:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raghavendra Bhat 2015-07-28 06:00:53 EDT
+++ This bug was initially created as a clone of Bug #1245981 +++

Description of problem:

If a object gets modified, then bit-rot-stub sends a notification to BitD to sign the object. BitD waits for sometime before signing the object so that if any modification happens within that time interval, it need not sign multiple times. And once the object is signed, its inode context is changed to indicate that, the inode is now in its default state.

But if the inode gets forgotten after sending the sign notification to BitD, but before getting sign request, then when the sign request comes, the inode context says inode is in default state (instead of modified state) and does not sign the object.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Anand Avati on 2015-07-24 05:15:45 EDT ---

REVIEW: http://review.gluster.org/11729 (features/bit-rot-stub: handle REOPEN_WAIT on forgotten inodes) posted (#2) for review on master by Raghavendra Bhat (raghavendra@redhat.com)

--- Additional comment from Anand Avati on 2015-07-27 02:22:13 EDT ---

REVIEW: http://review.gluster.org/11729 (features/bit-rot-stub: handle REOPEN_WAIT on forgotten inodes) posted (#3) for review on master by Venky Shankar (vshankar@redhat.com)

--- Additional comment from Anand Avati on 2015-07-27 04:33:13 EDT ---

REVIEW: http://review.gluster.org/11729 (features/bit-rot-stub: handle REOPEN_WAIT on forgotten inodes) posted (#4) for review on master by Raghavendra Bhat (raghavendra@redhat.com)
Comment 1 Anand Avati 2015-07-28 06:04:30 EDT
REVIEW: http://review.gluster.org/11773 (features/bit-rot-stub: handle REOPEN_WAIT on forgotten inodes                        Backport of http://review.gluster.org/11729) posted (#1) for review on release-3.7 by Raghavendra Bhat (raghavendra@redhat.com)
Comment 2 Anand Avati 2015-08-12 01:02:48 EDT
REVIEW: http://review.gluster.org/11773 (features/bit-rot-stub: handle REOPEN_WAIT on forgotten inodes                        Backport of http://review.gluster.org/11729) posted (#2) for review on release-3.7 by Venky Shankar (vshankar@redhat.com)
Comment 3 Anand Avati 2015-08-12 08:42:29 EDT
REVIEW: http://review.gluster.org/11773 (features/bit-rot-stub: handle REOPEN_WAIT on forgotten inodes                        Backport of http://review.gluster.org/11729) posted (#3) for review on release-3.7 by Raghavendra Bhat (raghavendra@redhat.com)
Comment 4 Anand Avati 2015-08-12 23:40:55 EDT
COMMIT: http://review.gluster.org/11773 committed in release-3.7 by Venky Shankar (vshankar@redhat.com) 
------
commit d636c0b1cdf7e8897abbd734b2651045fb9ed113
Author: Raghavendra Bhat <raghavendra@redhat.com>
Date:   Tue Jul 21 15:13:28 2015 +0530

    features/bit-rot-stub: handle REOPEN_WAIT on forgotten inodes
                           Backport of http://review.gluster.org/11729
    
    Change-Id: I4d0143e72afdc9bd2cd2c4df7a33a6ecc07328f2
    BUG: 1247551
    Signed-off-by: Raghavendra Bhat <raghavendra@redhat.com>
    Reviewed-on: http://review.gluster.org/11773
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
Comment 5 Kaushal 2015-09-09 05:38:40 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.