Bug 1247202 - Revamp the RHN page backend
Revamp the RHN page backend
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.5.0
Unspecified Unspecified
high Severity high
: ovirt-3.6.0-rc3
: 3.6.0
Assigned To: Ryan Barry
wanghui
: CodeChange
: 1167212 (view as bug list)
Depends On:
Blocks: 1046447 1046448
  Show dependency treegraph
 
Reported: 2015-07-27 10:38 EDT by Fabian Deutsch
Modified: 2016-03-09 09:33 EST (History)
10 users (show)

See Also:
Fixed In Version: ovirt-node-3.3.0-0.18.20151022git82dc52c.el7ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 09:33:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 40242 master MERGED Clean up rhn_page Never
oVirt gerrit 40376 master MERGED Refactor rhn_model Never

  None (edit)
Description Fabian Deutsch 2015-07-27 10:38:27 EDT
Description of problem:
Currently the RHN page backend is quite hard to maintain. To make it easier to maintain and address a couple of bugs we should revamp it and add some structure.

The involved changes do not add any feature and are not visible to the user, but the involved flows should be tested thoroughly by QE.
Comment 1 Doron Fediuck 2015-07-27 10:54:59 EDT
Testing impact (what to test)-
basic sanity and regression only for this page.
Comment 2 Ryan Barry 2015-07-27 14:07:32 EDT
*** Bug 1167212 has been marked as a duplicate of this bug. ***
Comment 3 Ryan Barry 2015-07-27 14:08:06 EDT
Note: there is no change to the TUI, just logic cleanup behind the scenes for RHN Page.

I've tested this in the following scenarios:

subscription-manager in the default config
subscription-manager with an unauthenticated proxy
subscription-manager with an authenticated proxy

satellite5 in the default config
satellite5 with an unauthenticated proxy
satellite5 with an authenticated proxy
satellite5 in all the above scenarios with an activation key

satellite6 in the default config
satellite6 with an unauthenticated proxy
satellite6 with an authenticated proxy
satellite6 in all the above scenarios with an activation key

I haven't tested:

autoinstallation, but that code wasn't touched at all (except to add a message about why it fails if username and activationkey are set at the same time), and the interface to the model wasn't changed, so I'd expect that to work

As a bonus, setting a proxy now also retrieves the certificate through the proxy, which doesn't appear to have been done in the old codebase
Comment 4 Ryan Barry 2015-07-27 15:41:50 EDT
I've also tested this against:

sam in the default config
sam with an unauthenticated proxy
sam with an authenticated proxy

But I'd like clarification on the requirements of SAM with an activation key. The old codebase requires that an organization be set with an activation key, which I've reproduced in the new codebase, but I don't know if SAM requires this or not (it does not seem to require an organization in general, as satellite6 does).

Currently we have:

RHN/default subscription-manager:
username/password

Satellite5:
username/password
activationkey

Satellite6:
username/password+organization
activationkey+organization

(since there is not an additional box for satellite 6 vs satellite 5, the requirement for an organization is impossible to enforce from the TUI, though it can be enforced from the model)

SAM:
username/password
activationkey? activationkey+organization? This is what I'd like clarification on
Comment 5 Ryan Barry 2015-07-27 15:54:38 EDT
I just tested this -- SAM happily registers without an organization set.

I've moved enforcement of organization checking to the model for satellite 6 only.
Comment 6 wanghui 2015-11-27 04:53:55 EST
According to comment#3, the new code works in rhev-hypervisor7-7.2-20151112.1.el7ev(ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch) now. I can verify this issue due to the code works now.

For more RHN detail issues, we will track by open new detail bugs. Such as bug#1283826, bug#1280217, bug#1280215.
Comment 8 errata-xmlrpc 2016-03-09 09:33:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html

Note You need to log in before you can comment on or make changes to this bug.