Bug 1247282 - RFE: DNF displaying local .rpm files for tab completion
RFE: DNF displaying local .rpm files for tab completion
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
: 1248795 1273735 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-27 13:32 EDT by Andrew Wippler
Modified: 2016-02-22 09:10 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-22 09:10:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Wippler 2015-07-27 13:32:28 EDT
Description of problem: when installing a local rpm (such as teamviewer) tab completion does not list local rpm.

Version-Release number of selected component (if applicable): 
dnf - 1.0.1
bash-completion.noarch - 1:2.1-7.20150513git1950590.fc22

How reproducible:

Steps to Reproduce:
1. download teamviewer and cd to the directory
2. `dnf install team<tab><tab>` 

Actual results:
[awippler@localhost Downloads] $ dnf install team<tab><tab>
teamd-devel.i686    teamd.i686          teamgit.x86_64
teamd-devel.x86_64  teamd.x86_64    

Expected results:
[awippler@localhost Downloads] $ dnf install team<tab><tab>
teamd-devel.i686    teamd.i686          teamgit.x86_64
teamd-devel.x86_64  teamd.x86_64        teamviewer_10.0.41499.i686.rpm

Additional info:
`dnf install teamv<tab>` expands correctly
Comment 1 Honza Silhan 2015-08-11 07:38:53 EDT
Igor, have you seen this issue? Would it be possible to fix this, please?
Comment 2 Honza Silhan 2015-08-11 08:11:45 EDT
*** Bug 1248795 has been marked as a duplicate of this bug. ***
Comment 3 Honza Silhan 2015-10-26 08:30:59 EDT
*** Bug 1273735 has been marked as a duplicate of this bug. ***
Comment 4 Andrew Wippler 2016-02-06 01:24:45 EST
I stumbled across a work-around: by prepending the path, it auto-completes.

[awippler@localhost Downloads] $ dnf install ./t<tab>
turns into:
[awippler@localhost Downloads] $ dnf install ./teamviewer_10.0.41499.i686.rpm

dnf installs the local file like normal with the path prepended. Is this the intended behavior?
Comment 5 Peter Dukan 2016-02-06 04:05:44 EST
If so, then a bit longer description is needed, and maybe a reference to "yum localinstall" will be useful also.
From the manual: "Each <spec> can be ... a path to the local rpm package ..."
Comment 6 Honza Silhan 2016-02-22 09:10:20 EST
Andrew, this is intended. I am reconsidering this RFE and it really does not make a sense. If you want to autocomplete local file add relative / absolute path prefix.

Note You need to log in before you can comment on or make changes to this bug.