Bug 124784 - FC2 install doesn't detect CS4237B sound chip
FC2 install doesn't detect CS4237B sound chip
Status: CLOSED DUPLICATE of bug 115885
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2004-05-29 20:33 EDT by Brian Kendig
Modified: 2014-03-16 22:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:03:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Brian Kendig 2004-05-29 20:33:21 EDT
I installed Fedora Core 2 on a Dell Latitude CPi D266XT laptop, and it did not detect the 
sound card (a Crystal CS4237B chip on the motherboard's ISA bus) nor provide me any way 
to configure the chip via GUI. It also placed nothing sound-related into '/etc/

The "Soundcard Detection" program, when run, displays a dialog saying "No soundcards 
were detected." then exits.

'lspci -v' shows nothing about the sound card, of course, because it's ISA. I had gotten the 
sound to work under SuSE 9.0 by putting these lines into '/etc/modprobe.conf':

alias snd-card-0 snd-cs4236
alias sound-slot-0 snd-card-0
options snd-cs4236 port=0x530 irq=5 dma1=1 dma2=0 mpu_port=0x330 mpu_irq=7 
cport=0x210 fm_port=0x388 isapnp=0

(So far I haven't gotten it to work under FC2 at all, but that's not an issue for this bug 

I understand that the Soundcard Detection program does not handle ISA cards, but it 
should say so, and the FC2 installer should be able to detect this card.

This issue may be related to bug 88103.
Comment 1 Bill Nottingham 2004-06-01 01:05:14 EDT
The installer does not (and will not) have ISA detection logic; it
just has the same logic as system-config-soundcard.

If it's ISAPnP, the failure is known; marking as a duplicate.

If it's just plain ISA, it's not supported for automatic configuration.

*** This bug has been marked as a duplicate of 115885 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:03:52 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.