Bug 1247907 - Cannot enable display 1 when it was disabled in previous session
Cannot enable display 1 when it was disabled in previous session
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: spice-gtk (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.2
Assigned To: Pavel Grunt
SPICE QE bug list
:
Depends On:
Blocks: 1247920 1247927
  Show dependency treegraph
 
Reported: 2015-07-29 04:25 EDT by Pavel Grunt
Modified: 2015-11-19 02:39 EST (History)
10 users (show)

See Also:
Fixed In Version: spice-gtk-0.26-5.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1247920 1247927 (view as bug list)
Environment:
Last Closed: 2015-11-19 02:39:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 91489 None None None Never

  None (edit)
Description Pavel Grunt 2015-07-29 04:25:19 EDT
Description of problem:
It is not possible to enable the display 1 of the multimonitor Windows virtual machine, when the display was disabled in the previous session, because the checkbox to enable display 1 is missing from the View->Displays menu.

Version-Release number of selected component (if applicable):
virt-viewer-2.0-4.el7.x86_64

guest: Windows 7, spice guest tools 0.100

How reproducible:
100%

Steps to Reproduce:
1. connect using remote-viewer to a win7 vm having 2 qxl devices
2. enable display 2 (View->Displays->Display 2)
3. disable display 1 (View->Displays->Display 1)
4. close remote-viewer
5. connect again
6. check View->Displays menu

Actual results:
It is not possible to enable the display 1, because the checkbox for "Display 1" is missing from the View->Displays menu

Expected results:
The menu contains "Display 1"

Additional info:
The display can be enabled using the "Screen resolution" applet.
In virt-viewer 1.0 the menu contains the checkbox for display 1
Comment 3 zhoujunqin 2015-07-30 02:44:09 EDT
I can reproduce this issue with package:
virt-viewer-2.0-5.el7.x86_64
libvirt-1.2.17-2.el7.x86_64

Steps:
1. connect using remote-viewer to a win7 vm having 2 qxl devices
# virsh dumpxml win7-qcow2

    <channel type='spicevmc'>
      <target type='virtio' name='com.redhat.spice.0' state='connected'/>
      <alias name='channel1'/>
      <address type='virtio-serial' controller='0' bus='0' port='2'/>
    </channel>
...
    <graphics type='spice' port='5900' autoport='yes' listen='127.0.0.1'>
      <listen type='address' address='127.0.0.1'/>
    </graphics>
...
    <video>
      <model type='qxl' ram='65536' vram='65536' vgamem='16384' heads='1'/>
      <alias name='video0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
    </video>
    <video>
      <model type='qxl' ram='65536' vram='65536' vgamem='16384' heads='1'/>
      <alias name='video1'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x09' function='0x0'/>
    </video>

# remote-viewer spice://127.0.0.1:5900

2. enable display 2 (View->Displays->Display 2)
3. disable display 1 (View->Displays->Display 1)
4. close remote-viewer
5. connect again
6. check View->Displays menu

Result: After step6, there is only "Display 2" listed, the checkbox for "Display 1" is missing from the View->Displays menu.
Comment 4 Pavel Grunt 2015-08-03 05:29:00 EDT
Reproducible in:
virt-viewer-2.0-5.el7.x86_64
spice-gtk3-0.26-4.el7.x86_64

Fixed in spice-gtk upstream http://cgit.freedesktop.org/spice/spice-gtk/commit/?id=45d013913710110efd19f86fd2e54d38adc1a8d4
Comment 11 errata-xmlrpc 2015-11-19 02:39:24 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2211.html

Note You need to log in before you can comment on or make changes to this bug.