Bug 1247920 - Cannot enable display 1 when it was disabled in previous session
Cannot enable display 1 when it was disabled in previous session
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 6.8
Assigned To: Pavel Grunt
SPICE QE bug list
:
Depends On: 1247907 1247927
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-29 05:01 EDT by Pavel Grunt
Modified: 2016-05-10 17:16 EDT (History)
12 users (show)

See Also:
Fixed In Version: spice-gtk-0.26-5.el6
Doc Type: Bug Fix
Doc Text:
Cause: Windows guest can have disabled display on the display channel #0. Consequence: The disabled display (display channel #0) will not be listed in virt-viewer's "View->Displays" menu. Fix: Notify about the existence of monitor for all display channels. Result: All the displays can be enabled/disabled by virt-viewer's "View->Displays" menu.
Story Points: ---
Clone Of: 1247907
Environment:
Last Closed: 2016-05-10 17:16:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 91489 None None None Never

  None (edit)
Description Pavel Grunt 2015-07-29 05:01:12 EDT
+++ This bug was initially created as a clone of Bug #1247907 +++

Description of problem:
It is not possible to enable the display 1 of the multimonitor Windows virtual machine, when the display was disabled in the previous session, because the checkbox to enable display 1 is missing from the View->Displays menu.

Version-Release number of selected component (if applicable):
virt-viewer-2.0-7.el6.x86_64

guest: Windows 7, spice guest tools 0.100

How reproducible:
100%

Steps to Reproduce:
1. connect using remote-viewer to a win7 vm having 2 qxl devices
2. enable display 2 (View->Displays->Display 2)
3. disable display 1 (View->Displays->Display 1)
4. close remote-viewer
5. connect again
6. check View->Displays menu

Actual results:
It is not possible to enable the display 1, because the checkbox for "Display 1" is missing from the View->Displays menu

Expected results:
The menu contains "Display 1"

Additional info:
The display can be enabled using the "Screen resolution" applet.
In virt-viewer 1.0 the menu contains the checkbox for display 1

--- Additional comment from Pavel Grunt on 2015-07-29 04:27:06 EDT ---

Patch posted: https://www.redhat.com/archives/virt-tools-list/2015-July/msg00128.html

--- Additional comment from RHEL Product and Program Management on 2015-07-29 04:35:27 EDT ---

Since this bug report was entered in bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 6 errata-xmlrpc 2016-05-10 17:16:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0832.html

Note You need to log in before you can comment on or make changes to this bug.