Bug 1247927 - Cannot enable display 1 when it was disabled in previous session
Cannot enable display 1 when it was disabled in previous session
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity unspecified
: ovirt-3.6.0-rc3
: 3.6.0
Assigned To: Default Assignee for SPICE Bugs
SPICE QE bug list
:
Depends On: 1247907
Blocks: 1247920
  Show dependency treegraph
 
Reported: 2015-07-29 05:16 EDT by Pavel Grunt
Modified: 2016-03-09 15:11 EST (History)
16 users (show)

See Also:
Fixed In Version: mingw-spice-gtk-0.26-8.el7ev mingw-virt-viewer-2.0-6.el7ev rhevm-spice-client-3.6-4
Doc Type: Bug Fix
Doc Text:
Previously, when the first display on a Windows guest was disabled, it could not be enabled in a new session, because virt-viewer did not check events on the first display channel. With this fix, virt-viewer checks for events in all display channels. It is now possible to disable a Windows guest's first display in one session, and enable it in a different session through the View menu in virt-viewer.
Story Points: ---
Clone Of: 1247907
Environment:
Last Closed: 2016-03-09 15:11:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Spice
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 91489 None None None Never

  None (edit)
Description Pavel Grunt 2015-07-29 05:16:23 EDT
+++ This bug was initially created as a clone of Bug #1247907 +++

Description of problem:
It is not possible to enable the display 1 of the multimonitor Windows virtual machine, when the display was disabled in the previous session, because the checkbox to enable display 1 is missing from the View->Displays menu.

Version-Release number of selected component (if applicable):
mingw-virt-viewer-2.0-3.el7ev

guest: Windows 7, spice guest tools 0.100

How reproducible:
100%

Steps to Reproduce:
1. connect using remote-viewer to a win7 vm having 2 qxl devices
2. enable display 2 (View->Displays->Display 2)
3. disable display 1 (View->Displays->Display 1)
4. close remote-viewer
5. connect again
6. check View->Displays menu

Actual results:
It is not possible to enable the display 1, because the checkbox for "Display 1" is missing from the View->Displays menu

Expected results:
The menu contains "Display 1"

Additional info:
The display can be enabled using the "Screen resolution" applet.
In virt-viewer 1.0 the menu contains the checkbox for display 1

--- Additional comment from Pavel Grunt on 2015-07-29 04:27:06 EDT ---

Patch posted: https://www.redhat.com/archives/virt-tools-list/2015-July/msg00128.html

--- Additional comment from RHEL Product and Program Management on 2015-07-29 04:35:27 EDT ---

Since this bug report was entered in bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 1 Fabiano Fidêncio 2015-10-19 04:45:54 EDT
This is the patch that ended up fixing the problem upstream:
http://cgit.freedesktop.org/spice/spice-gtk/commit/?id=45d013913710110efd19f86fd2e54d38adc1a8d4
Comment 4 Dayle Parker 2016-02-29 19:39:24 EST
If this bug requires doc text for errata release, please provide draft text in the doc text field in the following format:

 Cause:
 Consequence:
 Fix:
 Result:
Comment 5 Tomas Pelka 2016-03-01 04:27:17 EST
(In reply to Dayle Parker from comment #4)
> If this bug requires doc text for errata release, please provide draft text
> in the doc text field in the following format:
> 
>  Cause:
>  Consequence:
>  Fix:
>  Result:

I'm sorry Dayle, we as QE are not responsible for filling doc text.
Comment 7 errata-xmlrpc 2016-03-09 15:11:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0377.html

Note You need to log in before you can comment on or make changes to this bug.