This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1247968 - [ko_KR] [Admin portal] Text alignment needs to be corrected on 'New Cluster' -> 'Fencing Policy'
[ko_KR] [Admin portal] Text alignment needs to be corrected on 'New Cluster' ...
Status: CLOSED DUPLICATE of bug 1255263
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.5.4
All Linux
unspecified Severity medium
: ---
: 3.6.0
Assigned To: Alexander Wels
Pavel Stehlik
infra
: i18n
: 1247974 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-29 07:05 EDT by Bhushan Barve
Modified: 2016-02-10 14:27 EST (History)
10 users (show)

See Also:
Fixed In Version: 3.6.0-4_alpha3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-25 14:14:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
guide me page text alignment (78.25 KB, image/png)
2015-07-29 07:05 EDT, Bhushan Barve
no flags Details
Add Cluster - Fencing Policy - English vs. Korean (49.75 KB, image/png)
2015-07-30 08:52 EDT, Einav Cohen
no flags Details
screen-shot: New Cluster - Fencing Policy - English vs Korean - updated [3.5] (58.38 KB, image/png)
2015-07-30 14:29 EDT, Einav Cohen
no flags Details
screen-shot: New Cluster - Fencing Policy - Korean - [3.6] (29.38 KB, image/png)
2015-07-30 14:30 EDT, Einav Cohen
no flags Details
Help icon and Threshold broken into two lines (31.00 KB, image/png)
2015-08-19 03:46 EDT, Lijun Li
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45272 master MERGED webadmin: cluster fencing policy layout Never
oVirt gerrit 45459 ovirt-engine-3.6 MERGED webadmin: cluster fencing policy layout Never

  None (edit)
Description Bhushan Barve 2015-07-29 07:05:20 EDT
Description of problem: The text alignment on Data centers-->Guide Me-->Add another cluster-->Fencing policies pane needs to be corrected. Currently it looks distorted a bit. Please refer attached screenshot.


Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager 버전: 3.5.4-1.2.el6ev

How reproducible:
always

Steps to Reproduce:
1. login to RHEVM with ko_KR locale.
2. Go to Data centers-->Guide Me-->Add another cluster-->Fencing policies
3. Observe the text alignment

Actual results:
The text alignment looks distorted.

Expected results:
The text alignment should be proper.

Additional info:
Comment 1 Bhushan Barve 2015-07-29 07:05:58 EDT
Created attachment 1057303 [details]
guide me page text alignment
Comment 2 Einav Cohen 2015-07-30 08:52:18 EDT
Created attachment 1057664 [details]
Add Cluster - Fencing Policy - English vs. Korean
Comment 3 Einav Cohen 2015-07-30 08:54:02 EDT
due to the large font size on the BZ reporter's browser (see attachment 1057660 [details]), the layout pictured is not "accurate" - but there is still a problem, even with the default browser/OS font-size - see attachment 1057664 [details].
Comment 4 Einav Cohen 2015-07-30 08:55:40 EDT
*** Bug 1247974 has been marked as a duplicate of this bug. ***
Comment 5 Einav Cohen 2015-07-30 08:58:37 EDT
please note that the New Cluster dialog is reachable from multiple locations: 

- Data centers--> Guide Me --> Add another cluster

- Clusters --> New

it's the exact same dialog, that's why bug 1247974 was closed as duplicate, but feel free to verify the BZ, once fixed, from both reachable scenarios.
Comment 6 Alexander Wels 2015-07-30 13:59:58 EDT
Einav can you re-test but this time clear your cache first, it appears you have a bunch of old branding css in there (the RH icon, and your ? icons are not where they are supposed to be).
Comment 7 Einav Cohen 2015-07-30 14:29:29 EDT
Created attachment 1057804 [details]
screen-shot: New Cluster - Fencing Policy - English vs Korean - updated [3.5]
Comment 8 Einav Cohen 2015-07-30 14:30:05 EDT
Created attachment 1057807 [details]
screen-shot: New Cluster - Fencing Policy - Korean - [3.6]
Comment 9 Einav Cohen 2015-07-30 14:33:36 EDT
(In reply to Alexander Wels from comment #6)
> Einav can you re-test but this time clear your cache first, it appears you
> have a bunch of old branding css in there (the RH icon, and your ? icons are
> not where they are supposed to be).

cleared cash; result appears to be the same: see attachment 1057804 [details]. 
need to keep in mind that this is 3.5, not 3.6. 

indeed, on 3.6, the layout seems a bit different: see attachment 1057807 [details] (it happens to be oVirt, not RHEV, but shouldn't make much of a difference IIUC). 

since this is flagged for 3.6 (too late to fix for 3.5), and it is already fixed in 3.6, moving to ON_QA.
Comment 10 Alexander Wels 2015-07-30 14:37:24 EDT
If the 3.5 picture is the result of 3.5 rhev, then we have an issue there because the branding is all wrong (icon in left corner).

For 3.6 I redid that particular tab to be patternfly based and thus fixed the layout issues. It will still go to the next line if the text is much longer than what it is now.
Comment 11 Lijun Li 2015-08-19 03:45:17 EDT
Help icon and Threshold broken into two lines.
Please see attached screen-shot.
Comment 12 Lijun Li 2015-08-19 03:46:46 EDT
Created attachment 1064643 [details]
Help icon and Threshold broken into two lines
Comment 13 Einav Cohen 2015-08-25 14:14:15 EDT
both bug 1255263 and this BZ are about the exact same issue in the exact same dialog - note that the New Cluster dialog is reachable via several ways (Data-Center Guide-Me, Clusters main tab -> New).

*** This bug has been marked as a duplicate of bug 1255263 ***

Note You need to log in before you can comment on or make changes to this bug.