Bug 1249895 - [SetupNetworks] - Impossible to drag and attach some networks to Interfaces via SN if i have a multiple networks in the list
[SetupNetworks] - Impossible to drag and attach some networks to Interfaces v...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
---
x86_64 Linux
high Severity high (vote)
: ovirt-3.6.3
: ---
Assigned To: Scott Dickerson
Michael Burman
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-04 01:46 EDT by Michael Burman
Modified: 2016-02-18 06:21 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
If i have multiple networks in the Setup Networks dialog and i'm trying to drag and attach the lower networks in the list and i'm scrolling down with the mouse, i don't see the Interfaces of the server any more and i can't assign the lower networks to host. This was fixed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:21:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
ylavi: blocker-
mgoldboi: planning_ack+
sdickers: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 51731 master MERGED webadmin: auto-scroll SetupNetworks interfaces list during drag-and-drop 2016-01-18 10:38 EST
oVirt gerrit 52390 ovirt-engine-3.6 MERGED webadmin: auto-scroll SetupNetworks interfaces list during drag-and-drop 2016-01-19 03:02 EST
oVirt gerrit 53389 master MERGED webadmin: Add a scroll panel to SetupNetworks networks list 2016-02-15 10:08 EST
oVirt gerrit 53390 ovirt-engine-3.6 MERGED webadmin: Add a scroll panel to SetupNetworks networks list 2016-02-15 14:25 EST
oVirt gerrit 53392 ovirt-engine-3.6.3 MERGED webadmin: Add a scroll panel to SetupNetworks networks list 2016-02-15 14:27 EST

  None (edit)
Description Michael Burman 2015-08-04 01:46:37 EDT
Description of problem:
[SetupNetworks] - Impossible to drag and attach some networks to Interfaces via SN if i have a multiple networks in the list.

If i have multiple networks in the Setup Networks dialog and i'm trying to drag and attach the lower networks in the list and i'm scrolling down with the mouse, i don't see the Interfaces of the server any more and i can't assign the lower networks to host. 

- Scrolling is not part of the setup networks dialog boundaries like on 3.5z, it is now extending the list below, but the physical interfaces are stay above when scrolling down.   

Version-Release number of selected component (if applicable):
3.6.0-0.0.master.20150730085151.git25ae1b5.el6

How reproducible:
100

Steps to Reproduce:
1. Create more then 10 networks
2. Open Setup Networks dialog and try to attach the lower networks from the networks list in the dialog(scroll down with mouse)


Actual results:
Impossible to attach the lower networks to host

Expected results:
Scrolling should part and inside the setup networks dialog boundaries, like on 3.5.z. Should see the host Interfaces when scrolling down.
Comment 1 Einav Cohen 2015-08-18 09:33:47 EDT
after talking with Alona: dragging and attaching to lower networks/NICs on the list is impossible due to the tool-tip that is rendered beneath the dragged object, hiding the NICs/networks in that space, thus making it impossible to have those NICs/networks as the drag-and-drop "target". 

@Greg - can we find a solution for this problem (I think the simplest one is the one that Alona came up with - hiding the tool-tip of a certain item upon dragging it)?
Comment 2 Greg Sheremeta 2015-08-18 09:37:01 EDT
Yep, it's arguably a bug in tooltips -- we hide tooltips on click (mousedown + mouseup), and should instead hide on mousedown.
Comment 3 Red Hat Bugzilla Rules Engine 2015-09-22 03:43:47 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 4 Yaniv Kaul 2015-10-07 10:09:20 EDT
Greg, any news on this bug?
Comment 5 Greg Sheremeta 2015-10-07 10:28:08 EDT
Haven't gotten down to this one yet. Would you like me to re-prioritize?
Comment 6 Einav Cohen 2015-10-07 10:33:45 EDT
no need to re-prioritize right now, as this is targeted for ovirt-3.6.3 - so there is still some time. 

[BTW, this was automatically flagged as a blocker since it has the Regression keyword - see comment #3]

ATM, there's no reason to not be able to complete this in time for ovirt-3.6.3, we will re-evaluate later on, if necessary.
Comment 7 Red Hat Bugzilla Rules Engine 2015-10-19 06:57:58 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 8 Yaniv Lavi 2015-10-29 08:25:17 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 9 Scott Dickerson 2015-11-20 16:05:55 EST
While this bug is on the SetupNetworks panel, it is not specifically related to the drag-and-drop tooltip problem on BZ 1249900 and BZ 1272857.  It is an issue with scrolling the NIC panel while performing a drag-and-drop of the NIC or Network elements.
Comment 10 Scott Dickerson 2016-01-14 11:02:11 EST
NOTE: Webkit browsers (chrome, safari) auto-scrolls content during drag and drop operations by default.  Firefox does not follow that behavior.  I'll track down an install of IE and see what its default behavior is as well.

The patch for this BZ will work in all three browsers regardless of the browser's default behavior.
Comment 11 Michael Burman 2016-02-03 01:07:48 EST
Tested on - 3.6.3-0.1.el6 
This bug is half fixed, because the original report of multiple networks on the right wasn't fixed, only the drag-and-drop scrolling problem in case there are more nics on the list then can be seen at once.
Comment 12 Red Hat Bugzilla Rules Engine 2016-02-03 01:07:50 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 13 Scott Dickerson 2016-02-15 11:41:23 EST
Second set of patches for this bug adds a scroll list for the network list on the right side of the popup box.  The popup contents will not scroll, even if there are more then 10 NICs or Networks.  

Now, any network can be scrolled into view and be dragged and dropped on any NIC.
Comment 14 Michael Burman 2016-02-17 08:59:07 EST
Verified on - 3.6.3.2-0.1.el6

Note You need to log in before you can comment on or make changes to this bug.