Bug 1249900 - [Setup Networks] - Improve the drag and drop Interfaces in SN dialog window when trying to create bond/s
[Setup Networks] - Improve the drag and drop Interfaces in SN dialog window w...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
---
x86_64 Linux
high Severity medium (vote)
: ovirt-3.6.1
: 3.6.1.1
Assigned To: Scott Dickerson
Michael Burman
ux
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-04 01:59 EDT by Michael Burman
Modified: 2016-02-10 14:22 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 07:19:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑3.6.z?
ylavi: planning_ack?
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48567 master MERGED webadmin: fix tooltip behavior in Setup Networks Never
oVirt gerrit 48873 ovirt-engine-3.6 MERGED webadmin: fix tooltip behavior in Setup Networks Never
oVirt gerrit 48874 ovirt-engine-3.6.1 MERGED webadmin: fix tooltip behavior in Setup Networks Never

  None (edit)
Description Michael Burman 2015-08-04 01:59:36 EDT
Description of problem:
[Setup Networks] - Improve the drag and drop Interfaces in SN dialog window when trying to create bond/s.

When trying to create bond/s via Setup Networks in UI by dragging NICs on top of each other, it's not working smooth all the time, you need to be very accurate. 
- For example, if trying to drag higher NIC to one below him, usually i will fail with the drag and drop and bond will not be created, i will need to find the exact point/spot and few more attempts in order to create this bond with success.   

- When dragging lower NIC to one above him, usually i will succeed with the drag and drop on the first try and bond will be created with success.

Version-Release number of selected component (if applicable):
3.6.0-0.0.master.20150730085151.git25ae1b5.el6

How reproducible:
70-80%

Steps to Reproduce:
1. Open Setup Networks dialog and try to create bond from 2 slaves by dragging and dropping higher NIC to one below him

Actual results:
Usually will fail with drag and drop on the first and second attempt

Expected results:
Drag and drop Interfaces on top of each other via Setup Networks should be more smooth and should succeed on first try.
Comment 1 Alona Kaplan 2015-08-12 09:36:05 EDT
I think the tooltip of the top nic covers the bottom nic, and it is what causes the issue.
Comment 2 Einav Cohen 2015-09-17 09:50:19 EDT
(In reply to Alona Kaplan from comment #1)
> I think the tooltip of the top nic covers the bottom nic, and it is what
> causes the issue.

if that's the case, then this one is probably highly related to bug 1249895.
Comment 3 Red Hat Bugzilla Rules Engine 2015-10-19 07:03:36 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 4 Yaniv Lavi 2015-10-29 08:25:37 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 5 Scott Dickerson 2015-11-13 17:00:58 EST
On the Setup Host Networks dialog, the tooltip on the draggable "Interface" and "Assigned Logical Networks" elements do indeed block the drop targets of the interfaces below the source element.  The tooltip should disappear when the dragging starts for the best user experience.

Until a fix is finalized, there is a work around.  The drop target is actually the entire row containing the interface and assigned logical network.  Drag the interface to anywhere on the target row (even directly an assigned logical network element) that is not covered by the tooltip and you'll be able to drop it there, initiating the dialog to create a new bond or update an existing bond.

Is there a specific browser or browser version that is more problematic?

Bug 1272857 is almost the same at this bug.  This bug deals specifically with bonding interfaces (left column of Setup Host Networks).  BZ 1272857 deals specifically with reassigning the logical networks (right column of Setup Host Networks).
Comment 6 Einav Cohen 2015-11-18 10:26:19 EST
Scott: BZ is flagged/targeted for ovirt 3.6, however I don't see that the patch has been backported to the ovirt-engine-3.6 branch - let's backport the patch to the following branches: 
- ovirt-engine-3.6
- ovirt-engine-3.6.1 , if exists (I updated the Target Milestone from ovirt-3.6.3 to ovirt-3.6.1). 

Thanks.
Comment 7 Scott Dickerson 2015-11-20 17:13:56 EST
gerrit patch 48873 backports to ovirt-engine-3.6
gerrit patch 48874 backports to ovirt-engine-3.6.1
Comment 8 Red Hat Bugzilla Rules Engine 2015-11-26 23:39:59 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 9 Michael Burman 2015-11-29 02:28:53 EST
Hi Scott, 

I'm testing this bug and it's much better now on  3.6.1-0.2.el6, the bonds creation is much smoother, but, on 60-80% of the time i'm failing to create bond when dragging higher NIC to one/s below him, because the NIC's tooltip preventing me from. 
I believe this should be improved more, Scott, is this possible? can we improve this? 

Thanks,
Comment 10 Michael Burman 2015-11-29 09:44:54 EST
Please add a target release to this report, maybe we testing the wrong build and the fix is not in. 
If the target release is 3.6.1, this bug should be failedQA. 

Thanks,
Comment 11 Einav Cohen 2015-11-30 16:48:58 EST
(In reply to Michael Burman from comment #10)
> Please add a target release to this report, maybe we testing the wrong build
> and the fix is not in. 
> If the target release is 3.6.1, this bug should be failedQA. 
> 
> Thanks,

Michael, 
It seems that the fix hasn't made it into the latest 3.6.1 build (3.6.0-22), however it should make it into tomorrow's build, which is also a 3.6.1 build AFAIK. 
So I am setting the Target Release of this BZ as '3.6.1', however *please do NOT move this BZ to failedQA*. 
This BZ should move to ON_QA once tomorrow's build is released, then verified.
Comment 12 Michael Burman 2015-12-01 00:37:16 EST
Hi Einav,

ACK)
Will be tested (and verified) once we have the new build.
Thanks for your response.
Comment 13 Sandro Bonazzola 2015-12-01 10:07:23 EST
This bug is referenced in git log for ovirt-engine-3.6.1.1.
Please set target release to 3.6.1.1 accordingly unless additional patches are needed.
Comment 14 Einav Cohen 2015-12-01 11:14:16 EST
(In reply to Sandro Bonazzola from comment #13)
> This bug is referenced in git log for ovirt-engine-3.6.1.1.
> Please set target release to 3.6.1.1 accordingly unless additional patches
> are needed.

Michael, my apologies - based on the above, TR for this BZ should be 3.6.1.1 and not 3.6.1 as I mentioned in my previous comment. 
Same goes for Bug 1272857. 
Thanks.
Comment 15 Michael Burman 2015-12-03 02:40:37 EST
Verified on - 3.6.1.1-0.1.el6
Comment 16 Sandro Bonazzola 2015-12-16 07:19:13 EST
According to verification status and target milestone this issue should be fixed in oVirt 3.6.1. Closing current release.

Note You need to log in before you can comment on or make changes to this bug.