Bug 1272857 - [Setup Networks] UI - Network's tooltip preventing from dragging the network and attaching it to the NIC/s below(if it's already attached to a NIC)
[Setup Networks] UI - Network's tooltip preventing from dragging the network ...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.0
x86_64 Linux
high Severity urgent (vote)
: ovirt-3.6.1
: 3.6.1.1
Assigned To: Scott Dickerson
Ori Ben Sasson
ux
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-19 01:55 EDT by Michael Burman
Modified: 2016-02-10 14:22 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 07:24:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: blocker+
mgoldboi: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48567 master MERGED webadmin: fix tooltip behavior in Setup Networks Never
oVirt gerrit 48873 ovirt-engine-3.6 MERGED webadmin: fix tooltip behavior in Setup Networks Never
oVirt gerrit 48874 ovirt-engine-3.6.1 MERGED webadmin: fix tooltip behavior in Setup Networks Never

  None (edit)
Description Michael Burman 2015-10-19 01:55:33 EDT
Description of problem:
[Setup Networks] UI - Network's tooltip preventing from dragging the network and attaching it to the NIC below.

It is not possible to drag and attach network from one NIC to the one below it in the Setup Networks dialog, because the network tooltip is shown once touching/hoovering the network and it prevents from attaching the network on the NIC/s below.


Version-Release number of selected component (if applicable):
rhevm-3.6.0.1-0.1.el6

How reproducible:
90-100

Steps to Reproduce:
1. Attach network to first or second NIC on host via Setup Networks
2. Try to drag and attach this network to the NIC/s below in the Setup Networks dialog


Actual results:
It's not possible to drag and attach the networks to the NIC/s below(if it's already attached to upper NIC), because the network's tooltip is shown once touching/hoovering the network.

Expected results:
Should be able to drag and attach network to all NICs on server. Network's tooltip shouldn't prevent me from doing so.
Comment 1 Einav Cohen 2015-10-19 08:54:34 EDT
related to and/or duplicate of bug 1249900 and/or bug 1249895.
Comment 2 Yaniv Lavi 2015-10-29 08:45:36 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 3 Greg Sheremeta 2015-11-13 14:50:00 EST
Scott and I reproduced on master.

Scott may have a workaround while he works on a fix. Scott -- can you update?
Comment 4 Scott Dickerson 2015-11-13 16:48:30 EST
On the Setup Host Networks dialog, the tooltip on the draggable "Interface" and "Assigned Logical Networks" elements do indeed block the drop targets of the interfaces below the source element.  The tooltip should disappear when the dragging starts for the best user experience.

Until a fix is finalized, there is a work around.  The drop target is actually the entire row containing the interface and assigned logical network.  Drag the logical network to anywhere on the target row (even directly on the nic/bond element) that is not covered by the tooltip and you'll be able to drop it there, reassigning the logical network to a new nic/bond.

Is there a specific browser or browser version that is more problematic?
Comment 5 Scott Dickerson 2015-11-13 16:53:00 EST
Bug 1249900 is almost the same at this bug.  This bug deals specifically with reassigning the logical networks (right column of Setup Host Networks).  BZ 1249900 deals specifically with bonding interfaces (left column of Setup Host Networks).
Comment 6 Einav Cohen 2015-11-18 10:27:19 EST
Scott, please see bug 1249900, comment #6. thanks.
Comment 7 Scott Dickerson 2015-11-20 17:14:52 EST
gerrit patch 48873 backports to ovirt-engine-3.6
gerrit patch 48874 backports to ovirt-engine-3.6.1
Comment 8 Red Hat Bugzilla Rules Engine 2015-11-26 23:40:17 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 9 Michael Burman 2015-11-29 09:42:39 EST
Hi Scott, 

Please add a target release to this report, so we can be sure we testing the right qa build. 
As it looks on 3.6.1-0.2.el6, this bug is still relevant and in most of 60-95% of the time, the network's tooltip is preventing from drag and attach the network to lower NIC/s (if it's already attached to NIC) .

Thanks,
Comment 10 Einav Cohen 2015-11-30 16:51:26 EST
(In reply to Michael Burman from comment #9)
> Hi Scott, 
> 
> Please add a target release to this report, so we can be sure we testing the
> right qa build. 
> As it looks on 3.6.1-0.2.el6, this bug is still relevant and in most of
> 60-95% of the time, the network's tooltip is preventing from drag and attach
> the network to lower NIC/s (if it's already attached to NIC) .
> 
> Thanks,

Michael, 
It seems that the fix hasn't made it into the latest 3.6.1 build (3.6.0-22), however it should make it into tomorrow's build, which is also a 3.6.1 build AFAIK. 
So I am setting the Target Release of this BZ as '3.6.1' (please do NOT move this BZ to failedQA or anything like that).
This BZ should move to ON_QA once tomorrow's build is released, then verified.
Comment 11 Michael Burman 2015-12-01 00:35:38 EST
Hi Einav,

ACK)
Will be tested (and verified) once we have the new build.
Thanks for your response.
Comment 12 Sandro Bonazzola 2015-12-01 10:07:41 EST
This bug is referenced in git log for ovirt-engine-3.6.1.1.
Please set target release to 3.6.1.1 accordingly unless additional patches are needed.
Comment 13 Ori Ben Sasson 2015-12-03 02:36:43 EST
Verified on 3.6.1.1-0.1.el6
Comment 14 Sandro Bonazzola 2015-12-16 07:24:28 EST
According to verification status and target milestone this issue should be fixed in oVirt 3.6.1. Closing current release.

Note You need to log in before you can comment on or make changes to this bug.