Bug 1250158 - Duplicate subscriptions shown in Activation key
Summary: Duplicate subscriptions shown in Activation key
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Activation Keys
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Walden Raines
QA Contact: Corey Welton
Russell Dickenson
URL:
Whiteboard: Verified in Upstream
Depends On:
Blocks: sat61-release-notes
TreeView+ depends on / blocked
 
Reported: 2015-08-04 15:42 UTC by sthirugn@redhat.com
Modified: 2019-09-25 20:50 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:17:14 UTC
Target Upstream Version:


Attachments (Terms of Use)
Before adding subscription (90.07 KB, image/png)
2015-08-04 15:43 UTC, sthirugn@redhat.com
no flags Details
After adding subscription (85.63 KB, image/png)
2015-08-04 15:43 UTC, sthirugn@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1250716 None None None Never
Red Hat Bugzilla 1252150 None None None Never
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Internal Links: 1250716 1252150

Description sthirugn@redhat.com 2015-08-04 15:42:33 UTC
Description of problem:
Duplicate subscriptions shown in Activation key

Version-Release number of selected component (if applicable):
Sat 6.1 GA Snap 15

How reproducible:
Always

Steps to Reproduce:
1. Navigate to Content -> Activation Keys
2. Create an activation key
3. Make sure to have more than one subscription
4. Add a subscription to the newly created activation key by selecting the Activation key -> Subscriptions -> Add Tab -> Select the subscription - Click 'Add Selected'

Actual results:
Selected subscription is added to the activation key but the unselected subscription is suddenly showing a duplicate entry (screenshot attached)

Expected results:
No duplicate subscription entry shown

Additional info:

Comment 1 sthirugn@redhat.com 2015-08-04 15:43:22 UTC
Created attachment 1059141 [details]
Before adding subscription

Comment 2 sthirugn@redhat.com 2015-08-04 15:43:45 UTC
Created attachment 1059142 [details]
After adding subscription

Comment 5 Brad Buckingham 2015-08-10 17:01:32 UTC
Hi Suresh,  when the behavior above occurs, is the user able to add that second subscription to the activation key?  (The one that is showing the duplicates.)

Comment 6 sthirugn@redhat.com 2015-08-10 20:20:40 UTC
(In reply to Brad Buckingham from comment #5)
> Hi Suresh,  when the behavior above occurs, is the user able to add that
> second subscription to the activation key?  (The one that is showing the
> duplicates.)

Yes, user is able to add the second subscription

Comment 8 Christine Fouant 2015-08-24 15:28:13 UTC
*** Bug 1230430 has been marked as a duplicate of this bug. ***

Comment 15 Walden Raines 2015-09-15 14:27:42 UTC
Moving to POST since this is working in master and was most likely fixed by the following PRs:

https://github.com/Katello/katello/pull/5305
https://github.com/Katello/bastion/pull/69

Comment 16 Tazim Kolhar 2015-11-17 12:36:24 UTC
VERIFIED:
# rpm -qa  | grep foreman
hp-dl360g7-01.lab.eng.brq.redhat.com-foreman-proxy-1.0-1.noarch
foreman-release-1.11.0-0.develop.201511161350git860ef06.el7.noarch
foreman-vmware-1.11.0-0.develop.201511161350git860ef06.el7.noarch
foreman-debug-1.11.0-0.develop.201511161350git860ef06.el7.noarch
foreman-libvirt-1.11.0-0.develop.201511161350git860ef06.el7.noarch
foreman-selinux-1.11.0-0.develop.201510071426git6234447.el7.noarch
tfm-rubygem-foreman_hooks-0.3.9-1.el7.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.8-1.el7.noarch
tfm-rubygem-foreman_gutterball-0.0.1-3.el7.noarch
foreman-postgresql-1.11.0-0.develop.201511161350git860ef06.el7.noarch
hp-dl360g7-01.lab.eng.brq.redhat.com-foreman-proxy-client-1.0-1.noarch
tfm-rubygem-foreman_discovery-4.1.2-1.fm1_11.el7.noarch
foreman-1.11.0-0.develop.201511161350git860ef06.el7.noarch
foreman-ovirt-1.11.0-0.develop.201511161350git860ef06.el7.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-3.el7.noarch
foreman-proxy-1.11.0-0.develop.201511161424gitf24be74.el7.noarch
foreman-compute-1.11.0-0.develop.201511161350git860ef06.el7.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.3-4.el7.noarch
hp-dl360g7-01.lab.eng.brq.redhat.com-foreman-client-1.0-1.noarch
tfm-rubygem-foreman_bootdisk-6.0.0-2.fm1_10.el7.noarch
tfm-rubygem-hammer_cli_foreman-0.4.0-1.201511111650gitdda13df.el7.noarch
foreman-gce-1.11.0-0.develop.201511161350git860ef06.el7.noarch
foreman-release-scl-1-1.el7.x86_64
tfm-rubygem-foreman_docker-1.4.1-2.fm1_10.el7.noarch
tfm-rubygem-foreman-tasks-0.7.6-1.fm1_10.el7.noarch

steps:
1. Navigate to Content -> Activation Keys
2. Create an activation key
3. Make sure to have more than one subscription
4. Add a subscription to the newly created activation key by selecting the Activation key -> Subscriptions -> Add Tab -> Select the subscription - Click 'Add Selected'

No duplicate subscription entry shown

Comment 20 errata-xmlrpc 2016-07-27 09:17:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.