Bug 1230430 - Composite Content View creation shows duplicated entries
Summary: Composite Content View creation shows duplicated entries
Keywords:
Status: CLOSED DUPLICATE of bug 1250716
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Christine Fouant
QA Contact: Katello QA List
Russell Dickenson
URL:
Whiteboard:
Depends On:
Blocks: sat61-release-notes
TreeView+ depends on / blocked
 
Reported: 2015-06-10 22:01 UTC by Og Maciel
Modified: 2017-02-23 19:56 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-24 15:28:13 UTC


Attachments (Terms of Use)
Screenshot showing duplicated entries (466.30 KB, image/png)
2015-06-10 22:01 UTC, Og Maciel
no flags Details

Description Og Maciel 2015-06-10 22:01:29 UTC
Created attachment 1037434 [details]
Screenshot showing duplicated entries

Description of problem:

Noticed that when adding published content views to a composite content view, there were duplicate entries listed as available for me to add, including the composite content view itself

Version-Release number of selected component (if applicable):

* Satellite 6.1 SNAP 8 Compose 1 on RHEL 7.1

How reproducible:


Steps to Reproduce:
1. Created 4 content views with content (RH repos and custom repos) and published them
2. Created a composite content view and added content views to it
3.

Actual results:

I saw duplicated entries for every published content view available **including** the composite content view itself (interestingly enough the only one that was not duplicated in the UI)


Expected results:


Additional info:

Even though there were duplicated entries available, I was able to successfully create my composite content view by selecting one of each different content view

Comment 1 Og Maciel 2015-06-10 22:07:50 UTC
Walden also pointed out the message at the top stating that one needs to first publish content views in order to add them. Since all listed entries there are published (with the exception of the Default Organization View and the composite content view itself, which is probably a bug too?), I wonder if this message is needed?

Comment 3 David O'Brien 2015-08-20 01:48:34 UTC
If this is definitely rel note material can someone provide suitable doc text?

thanks

Comment 4 Christine Fouant 2015-08-24 15:28:13 UTC
This was fixed by a newer BZ, but here is my input for the doc text:

There is a known issue when adding content views to a composite view where content views are being shown multiple times. This is being fixed, but a current workaround would be to simply select any one of each content view you wish to add to the composite view.

*** This bug has been marked as a duplicate of bug 1250158 ***

Comment 5 Christine Fouant 2015-08-24 15:46:10 UTC

*** This bug has been marked as a duplicate of bug 1250716 ***


Note You need to log in before you can comment on or make changes to this bug.