Bug 1251003 - Message reporting no password is empty
Message reporting no password is empty
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
---
Unspecified Unspecified
high Severity high (vote)
: ovirt-3.6.1
: 3.6.1
Assigned To: Greg Sheremeta
Lukas Svaty
ux
:
: 1253234 1270289 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 08:03 EDT by jniederm
Modified: 2016-02-10 14:22 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 07:18:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑3.6.z?
ylavi: planning_ack?
ecohen: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
empty password (252.88 KB, image/png)
2015-08-06 08:03 EDT, jniederm
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47053 master MERGED userportal, webadmin: fixed login form validation Never
oVirt gerrit 47106 ovirt-engine-3.6 MERGED userportal, webadmin: fixed login form validation Never

  None (edit)
Description jniederm 2015-08-06 08:03:30 EDT
Created attachment 1059867 [details]
empty password

Description of problem:
If no password is provided in webadmin signing dialog, weird error message is displayed

Version-Release number of selected component (if applicable):
post 3.6 master, commit 7714abd 

How reproducible:
100%

Steps to Reproduce:
1. Load webadmin login screen
2. Enter username 'admin', password '' (nothing), 'internal'
3. Click login

Actual results:
see screenshot

Expected results:
message reporting that no password was entered or just border of password input field gets red.
Comment 1 Einav Cohen 2015-08-17 08:39:35 EDT
*** Bug 1253234 has been marked as a duplicate of this bug. ***
Comment 2 Einav Cohen 2015-08-20 08:21:18 EDT
raising priority, as this was reported 3 times already, we need to fix it ASAP.
Comment 3 Einav Cohen 2015-10-11 16:57:48 EDT
*** Bug 1270289 has been marked as a duplicate of this bug. ***
Comment 4 Red Hat Bugzilla Rules Engine 2015-10-20 09:55:59 EDT
Fixed bug tickets must have version flags set prior to fixing them. Please set the correct version flags and move the bugs back to the previous status after this is corrected.
Comment 5 Red Hat Bugzilla Rules Engine 2015-10-20 09:55:59 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 6 Yaniv Lavi (Dary) 2015-10-29 08:26:34 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 7 Lukas Svaty 2015-11-26 07:23:52 EST
With "Please fill in all fields." verified in rhevm-webadmin-portal-3.6.1-0.2.el6.noarch.
Comment 8 Sandro Bonazzola 2015-12-16 07:18:42 EST
According to verification status and target milestone this issue should be fixed in oVirt 3.6.1. Closing current release.

Note You need to log in before you can comment on or make changes to this bug.