Bug 125133 - KDSKBENT: Invalid argument upon starting bash from tty
KDSKBENT: Invalid argument upon starting bash from tty
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
: 130471 131009 134028 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-02 19:06 EDT by Scott Sloan
Modified: 2015-01-04 17:06 EST (History)
30 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 02:08:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of '/bin/dumpkeys' (30.00 KB, text/plain)
2004-06-21 21:42 EDT, Erik Parker
no flags Details
strace -fo /tmp/bash.strace bash (462.81 KB, text/plain)
2004-09-17 11:49 EDT, James Laska
no flags Details

  None (edit)
Description Scott Sloan 2004-06-02 19:06:58 EDT
Description of problem:

KDSKBENT: Invalid argument
failed to bind key 255 to value 1188


Version-Release number of selected component (if applicable):
Happens in both

2.6.6-1.403
2.6.6-1.397

Expected results:

No Error Message
Comment 1 John Fleming 2004-06-02 22:02:00 EDT
This only happens at the console loging.  It does not appear if I ssh 
in from a remote location.  Could it be related to the keyboard in 
use?
Comment 2 Scott Sloan 2004-06-02 22:53:42 EDT
I don't think this has anything to do with the keyboard because I get
these while the kernel is loading and doing it's kernel thing. 
Comment 3 Scott Sloan 2004-06-02 23:18:37 EDT
" don't think this has anything to do with the keyboard"  I meant it
being in use at the time. It's clearly a keyboard related error. 

keycode 255 maps normally to nothing, atleast I think so.

Could somehow selinux messing this up? I know it's enabled on system,
what about yours?  

Comment 4 Kapoios Kanenas 2004-06-03 20:26:34 EDT
I have a usb keyboard and this message appears when I switch off USB
legacy support in the BIOS.
Comment 5 John Fleming 2004-06-03 20:52:59 EDT
I'm using a PS/2 keyboard from Dell.  I'll check my BIOS settings 
tomorrow (different location).  John
Comment 6 Scott Sloan 2004-06-14 13:55:00 EDT
I no longer get this, do you John?


Comment 7 John Fleming 2004-06-14 18:29:18 EDT
No, but I have to admit I switched to another distro.  ;-)
I was still getting the error before I switched.  If you're not still 
getting it, what's changed??
Comment 8 Scott Sloan 2004-06-14 23:50:53 EDT
I'm guessing it was fixed in some other package. Oh well.. Good luck
with your new distro. I'm closing this bug
Comment 9 Erik Parker 2004-06-21 21:42:06 EDT
Created attachment 101320 [details]
Output of '/bin/dumpkeys'
Comment 10 Erik Parker 2004-06-21 21:43:19 EDT
I get the same error on a fresh install (Very first console login) on 
FC2.

It's a standard Dell PowerEdge 1750 (Brand new out of the box). With 
mine, I get:

'KDSKBENT: Invalid argument
failed to bind key 255 to value 2626'

Looks like the kernel makes reference to it 
in /drivers/char/vt_ioctl.c, /drivers/s390/char/keyboard.c, /security/
selinux/hooks.c

It's actually stemming from the following command running in the bash 
profile:

unicode_start latarcyrheb-sun16

in that script the offending line is 'dumpkeys | loadkeys --unicode'

I've submitted the dumpkeys output that pipes into loadkeys that is 
causing the error on my system.
(Attachement ID 101320)
Comment 11 Erik Parker 2004-06-21 22:41:46 EDT
Fyi, after adding all current updates.. the problem went away. I'm
guessing due to the updated kernel.

With the new kernel, the output of 'dumpkeys' changes, and loadkeys
won't complain.

The single line that is no longer found in the dumpkeys output is:

altgr control keycode 255 = 0x0a42
Comment 12 P Jones 2004-07-04 09:07:36 EDT
Just want to add that on a fresh install of FC2 with all available
updates to date, which includes kernel 2.6.6-1.435.2.3, I get the
KDSKBENT error. If I boot with the original kernel and the kernel just
previous to the current one, I don't get the error.
Comment 13 Kamataat 2004-07-06 19:01:24 EDT
Since installing the kernel version 2.6.6-1.435.2.3 of FC2, I have
gotten te KDSKBENT error also. It doesn't appear when I use my
previous kernel from the GRUB boot menu.
Comment 14 Sami Teemu Pesonen 2004-07-13 12:43:25 EDT
Yes I can see this same bug also (KDSKBENT error message during
console login). I think this bug should be reopened (I don't have
rights to do so, hopefully somebody else has.

My kernel version: 2.6.6-1.435.2.3 (with all updates 13.7.2004)
Comment 15 Sami Teemu Pesonen 2004-07-13 12:45:16 EDT
My error message is little different though:
KDSKBENT: Invalid argument
failed to bind key 255 to value 3247

What additional information do you need to get this fixed?
Comment 16 Erik Parker 2004-07-13 12:53:24 EDT
As a temporary fix, you might be able to run 'unicode_stop'

But I have /no/ idea what effects that might have in the short term (I
see no long term effects).

I don't have an FC2 box to test on right now, but I suspect since the
issue is in the unicode_start script where it calls dumpkeys, that if
you run unicode_stop it might get around it temporarily.

Update all of your packages, etc.. it went away for me. The
alternative is to edit /bin/unicode_start  and comment out 'dumpkeys |
loadkeys --unicode'..  but i also have no idea what effects that might
have..i suspect nothing bad.

Comment 17 Scott Sloan 2004-07-13 14:07:05 EDT
Apparently, many others are having problems with this. So I'm
re-opening it. 
Comment 18 Jacek Piskozub 2004-07-17 05:16:57 EDT
In my case it is 

KDSKBENT: Invalid argument
failed to bind key 255 to value 2498

Fully updated FC2 with Polish keyboard settings.
Comment 19 Luc Lalonde 2004-07-21 11:37:36 EDT
 2.6.6-1.435.2.3  is also giving the same error:

KDSKBENT: Invalid argument
failed to bind key 255 to value 2439
Comment 20 Dawid Gajownik 2004-08-04 04:26:58 EDT
I have the same problem with kernel 2.6.7-1.494.2.2

KDSKBENT: Invalid argument
failed to bind key 255 to value 1273

It is weird, because I didn't have this message with kernels from
http://people.redhat.com/arjanv/2.6/RPMS.kernel/ (for example with
2.6.7-1.492, 2.6.7-1.499 and 2.6.7-1.501) :/
Comment 21 Need Real Name 2004-08-20 14:30:10 EDT
problem just appeared for me with latest kernel 2.6.8-1.521

KDSKBENT: Invalid argument
failed to bind key 255 to value 720
Comment 22 Jacek Piskozub 2004-08-24 05:29:21 EDT
Bug 130471 is evidently a dupe of this one.
Comment 23 JY XU 2004-08-31 02:08:11 EDT
Useful information (hopefully):

I just got the error two days' ago but now solved (at least the error
message went away). Before I got the error and after it went away, I
did not change anything about the system, and my box is Fedora Core 2
with all updates.

What I did to solve the error is absolutely non-technical -- I just
unplugged my keyboard (PS/2) and re-plug it in. Unbelievable?!

Because as I said, I never got the error message before, iy was only
the day before yesterday I unplug my keyboard and mouse to test
another computer, and put them back in when the test was done, then I
got the error message on console login. I googled the error message
and found this page.

The whole history of my problem made me think that it might be because
I did not plug the keyboard properly. Then I unplugged it and
replugged it in firmly...reboot...problem gone!

Additionaly information, I did `dumpkeys` thing and found the 255
keycode was always there but had different binding values before and
after the error message disappeared.

My running kernel is 2.6.8-1.521.

Hope this helps

JY
Comment 24 Patrick De Maziere 2004-08-31 16:31:47 EDT
I'm running kernel 2.6.8-1.521 and got the problem only recently
(while keyboard and mouse are very well attached):

Some history: I got a dual boot computer (Win2K & RH9 as uptodate as
possible ;-)). Running fine all the time, until I decided to take a
look at FC2 to verify if a change from RH9 to FC2 was worth the whole
port of user files. For this purpose I installed FC2 as third OS 
besides Win2K & RH9, (and made it as up2date as possible), after which
I ran in the well-known dual boot problem of FC2
(http://www.redhat.com/archives/fedora-devel-list/2004-May/msg00908.html)
I corrected my partition tables according to the method mentioned in
that mailing and got a working "triple boot" machine. BUT, now I got
that KDSKBENT error as well when logging in on the console window (not
on a X11 terminal).

Unfortunately I cannot offer a solution, but maybe that my experience
might help trigger the bug ....

UltraKnorrie
Comment 25 Jonathan Allen 2004-09-06 10:03:50 EDT
I too have kernel 2.6.8-1.521 and have had this problem consistently
since loading FC2 and bringing it 'up2date' as of this morning
(6Sep04).  The message occurs when initially logging in on a console
tty session, and when executing commands such as 'make' from inside 'vi'.
Comment 26 James Laska 2004-09-17 11:46:14 EDT
Observed now with rawhide-20040916 (kernel-2.6.8-1.541, bash-3.0-11,
util-linux-2.12a-6).  This only occurs when logging in on a physical
console (tty[0-9]), or running bash from a physical console (root on
non-root).

flatline login: root
Password:
Last login: Fri Sep 17 11:33:44 on tty1
You have new mail.
KDSKBENT: Invalid argument
failed to bind key 255 to value 2783

[root@flatline ~]# bash
KDSKBENT: Invalid argument
failed to bind key 255 to value 2783

attaching bash.strace output ...
Comment 27 James Laska 2004-09-17 11:49:39 EDT
Created attachment 103953 [details]
strace -fo /tmp/bash.strace bash
Comment 28 James Laska 2004-09-17 12:03:09 EDT
Additional Comments:

I have been running with the 541 kernel for some time now (since it's
delivery to rawhide-latest).  I did not observe the problem until this
morning after a yum update (and a reboot) that included the following
packages:

gnome-libs-devel-1.4.1.2.90-43                Fri 17 Sep 2004 08:00:35
AM EDT
xorg-x11-tools-6.8.0-4                        Fri 17 Sep 2004 08:00:32
AM EDT
qt-devel-3.3.3-5                              Fri 17 Sep 2004 08:00:25
AM EDT
gtk2-devel-2.4.9-8                            Fri 17 Sep 2004 07:59:57
AM EDT
ImageMagick-6.0.7.1-3                         Fri 17 Sep 2004 07:59:48
AM EDT
arts-1.3.0-4                                  Fri 17 Sep 2004 07:59:44
AM EDT
xorg-x11-6.8.0-4                              Fri 17 Sep 2004 07:59:38
AM EDT
xorg-x11-xfs-6.8.0-4                          Fri 17 Sep 2004 07:59:22
AM EDT
xorg-x11-xauth-6.8.0-4                        Fri 17 Sep 2004 07:59:21
AM EDT
xorg-x11-Mesa-libGLU-6.8.0-4                  Fri 17 Sep 2004 07:59:20
AM EDT
xorg-x11-deprecated-libs-6.8.0-4              Fri 17 Sep 2004 07:59:20
AM EDT
gnome-libs-1.4.1.2.90-43                      Fri 17 Sep 2004 07:59:17
AM EDT
gtk2-2.4.9-8                                  Fri 17 Sep 2004 07:59:08
AM EDT
xorg-x11-font-utils-6.8.0-4                   Fri 17 Sep 2004 07:59:04
AM EDT
xorg-x11-devel-6.8.0-4                        Fri 17 Sep 2004 07:58:57
AM EDT
qt-3.3.3-5                                    Fri 17 Sep 2004 07:58:41
AM EDT
xorg-x11-Mesa-libGL-6.8.0-4                   Fri 17 Sep 2004 07:58:40
AM EDT
xorg-x11-libs-6.8.0-4                         Fri 17 Sep 2004 07:58:35
AM EDT
system-logviewer-0.9.8-1                      Fri 17 Sep 2004 07:58:31
AM EDT
desktop-backgrounds-basic-2.0-23              Fri 17 Sep 2004 07:58:29
AM EDT
selinux-policy-strict-1.17.16-2               Fri 17 Sep 2004 07:58:27
AM EDT
anaconda-runtime-10.0.2-4                     Fri 17 Sep 2004 07:58:26
AM EDT
xorg-x11-deprecated-libs-devel-6.8.0-4        Fri 17 Sep 2004 07:58:25
AM EDT
desktop-backgrounds-extra-2.0-23              Fri 17 Sep 2004 07:58:22
AM EDT
system-config-users-1.2.18-1                  Fri 17 Sep 2004 07:58:17
AM EDT
umb-scheme-3.2-35                             Fri 17 Sep 2004 07:58:13
AM EDT
jwhois-3.2.2-6                                Fri 17 Sep 2004 07:58:11
AM EDT
usbutils-0.11-6.1                             Fri 17 Sep 2004 07:58:08
AM EDT
zlib-devel-1.2.1.2-1                          Fri 17 Sep 2004 07:58:07
AM EDT
nscd-2.3.3-53                                 Fri 17 Sep 2004 07:58:07
AM EDT
libselinux-devel-1.17.12-1                    Fri 17 Sep 2004 07:58:06
AM EDT
pam-devel-0.77-56                             Fri 17 Sep 2004 07:58:03
AM EDT
selinux-policy-targeted-sources-1.17.16-2     Fri 17 Sep 2004 07:57:58
AM EDT
udev-030-26                                   Fri 17 Sep 2004 07:57:54
AM EDT
glibc-devel-2.3.3-53                          Fri 17 Sep 2004 07:57:51
AM EDT
net-snmp-5.1.2-6                              Fri 17 Sep 2004 07:57:45
AM EDT
authconfig-gtk-4.6.4-3                        Fri 17 Sep 2004 07:57:44
AM EDT
up2date-gnome-4.3.38-1.1                      Fri 17 Sep 2004 07:57:43
AM EDT
system-config-packages-1.2.16-2               Fri 17 Sep 2004 07:57:38
AM EDT
gnome-speech-0.3.5-2                          Fri 17 Sep 2004 07:57:36
AM EDT
festival-1.4.2-25                             Fri 17 Sep 2004 07:57:24
AM EDT
desktop-file-utils-0.8-2                      Fri 17 Sep 2004 07:57:16
AM EDT
up2date-4.3.38-1.1                            Fri 17 Sep 2004 07:57:13
AM EDT
authconfig-4.6.4-3                            Fri 17 Sep 2004 07:57:07
AM EDT
samba-3.0.7-3                                 Fri 17 Sep 2004 07:57:01
AM EDT
net-snmp-libs-5.1.2-6                         Fri 17 Sep 2004 07:56:53
AM EDT
glibc-headers-2.3.3-53                        Fri 17 Sep 2004 07:56:49
AM EDT
MAKEDEV-3.13-1                                Fri 17 Sep 2004 07:56:46
AM EDT
policycoreutils-1.17.5-2                      Fri 17 Sep 2004 07:56:45
AM EDT
samba-client-3.0.7-3                          Fri 17 Sep 2004 07:56:42
AM EDT
compat-db-4.1.25-5                            Fri 17 Sep 2004 07:56:40
AM EDT
samba-common-3.0.7-3                          Fri 17 Sep 2004 07:56:35
AM EDT
pam-0.77-56                                   Fri 17 Sep 2004 07:56:27
AM EDT
zlib-1.2.1.2-1                                Fri 17 Sep 2004 07:56:24
AM EDT
libselinux-1.17.12-1                          Fri 17 Sep 2004 07:56:24
AM EDT
glibc-2.3.3-53                                Fri 17 Sep 2004 07:55:56
AM EDT
glibc-common-2.3.3-53                         Fri 17 Sep 2004 07:54:52
AM EDT
selinux-policy-targeted-1.17.16-2             Fri 17 Sep 2004 07:54:18
AM EDT
hwdata-0.131-1                                Fri 17 Sep 2004 07:54:16
AM EDT
Comment 29 William Temple 2004-09-24 13:15:50 EDT
Happens to me only when IPTABLES is active
Comment 30 Bill Nottingham 2004-09-28 21:58:11 EDT
*** Bug 134028 has been marked as a duplicate of this bug. ***
Comment 31 Jay Turner 2004-10-05 01:38:08 EDT
*** Bug 130471 has been marked as a duplicate of this bug. ***
Comment 32 Jay Turner 2004-10-05 02:07:20 EDT
Just as a note, I haven't been getting this error, then booted my
laptop up this morning and suddenly started getting it (no changes to
the package profile.)  I tried rebooting my laptop again and am no
longer getting the error.  Off to see if /var/log/messages holds any
clues.
Comment 33 Florian La Roche 2004-10-17 03:46:10 EDT
This happened for me also yesterday after doing a "yum update" to
FC devel. (Machine was only a few days old FC devel install, so no
bigger update over all.)
After a reboot message doesn't show up anymore.
Comment 34 Alan Cox 2004-10-17 09:08:15 EDT
Current update set fixed it for me too
Comment 35 Alan Cox 2004-10-21 19:48:20 EDT
Its come back again 8(
Comment 36 Luc Lalonde 2004-10-25 11:08:34 EDT
This problem comes back with 2.6.9-1.640smp for me during bootup:

KDSKBENT: Invalid argument
failed to bind key 255 to value 1541

However, after the machines boots, I don't have problems with console...
Comment 37 Bill Nottingham 2004-10-27 11:56:32 EDT
*** Bug 131009 has been marked as a duplicate of this bug. ***
Comment 38 Josi Romildo Malaquias 2004-11-12 05:16:08 EST
I am getting this error messages at console login with a fresh install
of Fedora Core 3.
Comment 39 Justin Findlay 2004-11-16 13:59:43 EST
New FC3 install, fully updated.  This error prevents me from starting X.

# telinit 5
...stuff...
/*keyboard error happens rapidly 10 times*/
KDSKBENT: Invalid argument
failed to bind key 255 to value 1080
INIT: Id "x" respawning too fast: disabled for 5 minutes

Perhaps that's a different bug.
Comment 40 Justin Findlay 2004-11-16 14:18:26 EST
Yup, duh, that's a different problem.  I always get the keyboard error
when logging in (though not over ssh) not just when spawning xdm. 
Commenting out 'dumpkeys | loadkeys --unicode' in /bin/unicode_start
seems to eliminate the error.
Comment 41 Jacek Piskozub 2004-11-16 14:22:39 EST
Justin, I believe you are wrong. Your xorg.conf is misconfigured or
you did not install Nvidia driver for the new kernel that was
installed by fc3. Etc., etc.

The symptoms simply show that X cannot start. The KDSKBENT error
message is just displayed every time X tries to start because of an
unrelated but this page is actually about. I've seen the same before
installing Nvidia driver after fc3 upgrade but the reason was
_certainly_ not this bug.
Comment 42 Luc Lalonde 2004-11-29 13:19:29 EST
This is still a problem with:

2.6.9-1.681_FC3smp
Comment 43 Alan Cox 2004-11-29 13:24:38 EST
I see this too although X is quite happy in my case.
Comment 44 Bernd Bartmann 2004-12-06 06:14:26 EST
Same here with 2.6.9-1.681_FC3 on a fully up2date FC3. I get:

KDSKBENT: Invalid argument
failed to bind key 255 to value 1856
Comment 45 Mark Polo 2004-12-07 04:44:34 EST
I have the same on kernel 2.6.9-1.681_FC3, fully updated via apt-get
(yum doesn't play nice with my proxy at the moment...)
Comment 46 Serge 2004-12-14 12:26:05 EST
Running FC3, 2.6.9-1.681_FC3smp all latest updates on an Asus P5P800.
If I set "Onboard IDE Operate mode" to "compatible" I get this bug. If
I set it to "enhanced" this bug disappears but then I get 
irq 5: nobody cared! (screaming interrupt?) 
irq 5: Please try booting with acpi=off and repor
t a bug
 [<021076ba>] __report_bad_irq+0x3a/0x77
 [<02107931>] note_interrupt+0xea/0x115
 [<02107b6f>] do_IRQ+0xd5/0x130kernel: handlers:
 [<0222f29f>] (ide_intr+0x0/0x11e)
 Disabling IRQ #5
Running in compatible mode seems better as no interrupts are disabled.
If more information is required please advise.

Comment 47 Davide Bolcioni 2004-12-30 06:35:20 EST
Also happened to me after updating a fresh install of FC3. In my case,
the offending output from dumpkeys is

keycode 255 = nul
        altgr   control keycode 255 = 0x0685
        shift   alt     keycode 255 = U+9dac

and specifically the 0x0685 value (which I suspect is some kind of
Unicode character, although not the Euro symbol).
Comment 48 Mattia Verga 2005-01-06 11:46:31 EST
I've just started to have this error message.
KDSKBENT: invalid argument
failed to bind key 255 to value 3133
It appears during startup, at login and even during shutdown.
I thought was related to SeLinux (it started give me the error after
the last update) but disabling selinux doesn't solve the problem.
I don't know if this could be related, but I also noticed a big
slowdown of page loading under Firefox. It's not due to connection:
downloading of files goes at maximum speed. Only page loading is
slowed down and this is started at the same time of KDSKBENT error....
Comment 49 Mattia Verga 2005-01-06 12:16:46 EST
Sorry, after some testing I found slow page loading was due to DNS
problems...
But also the error relative to KDSKBENT has disappeared! I've only
booted my Pc with firewall and selinux disabled (doing
'system-config-securitylevel') and the error was still there, then I
re-enabled firewall and selinux and rebooted... works. (???)
Comment 50 Chris Ricker 2005-01-27 08:22:12 EST
for me, this didn't appear until I upgraded to 2.6.10-1.753_FC3, which
causes it on one of my laptops (Dell Latitude D600)
Comment 51 Philip Allen 2005-02-04 16:34:36 EST
I have started getting it today with 2.6.9-1.724_FC3, which I 
installed a week ago.  I don't know why it has suddenly started doing 
this. 
Comment 52 Juha 2005-02-07 15:06:48 EST
FC3, 2.6.10-1.760_FC3 #1 Wed Feb 2 00:14:23 EST 2005 i686 i686 i386 GNU/Linux

I get following error on console login:

"KDSKBENT: Invalid argument
failed to bind key 255 to value 3304"



Comment 53 Eddie 2005-03-24 11:29:10 EST
FC3, 2.6.10-1.737_FC3smp, just started doing it after I turned off an ide
controller in the bios upon reboot:

KDSKBENT: Invalid argument
failed to bind key 255 to value 2003
Comment 54 John DeDourek 2005-04-06 16:19:38 EDT
Quick summary:  strongly suspect kernel memory corruption at the last entry
of the keymap table.  See below for details.

Happened to me on an IBM Thinkpad T42 running Fedora Core 2, reasonably updated
to April 4 2005, but with "tainted" Madwifi driver for wireless.  The exact
situation is that the "KDSKBENT: Invalid argument" occurred this morning on
boot, and
on starting terminals.  But after several boots, the problem disappeared. 
Following up on comment #10, I presumed that the script line "dumpkeys |
loadkeys --unicode" is attempting to modify the characteristics of the keyboard
map by reading the current map ("dumpkeys") and then writing the map as read
under the unicode option ("loadkeys --unicode).  I further presume that the
error message is being written by "loadkeys" because of an improper mapping of
key "255".  I note that my exact message was "failed to bind key 255 to value
1912".  I was able to save the output of dumpkeys both while the error was
present and again after the error disappeared.  A diff of these two files shows:

diff dumpkeyserr.txt dumpkeysok.txt
668c668
<       altgr   control keycode 255 = 0x0778
---
>       altgr   control keycode 255 = VoidSymbol

Kernel is 2.6.10-1.771_FC2  ("tainted" by madwifi BSD branch wireless driver)

Updates applied yesterday, though I don't think that they are relevant to
the problem were:
telnet-0.17-28.FC2.1
ImageMagick-6.2.0.7-2.fc2
gdk-pixbuf-0.22.0-12.fc2
gtk2-2.4.14-2.fc2
gtk2-devel-2.4.14-2.fc2

Further debugging info is probably not useful, given that this is a "tainted"
kernel.  

I am not knowledgeable about the keymap mapping system.  However,
my first guess, based on programming experience, is that the in-kernel
keymap is being corrupted in the last entry ("255") by a random bug due
to some type of kernel memory corruption.  This then causes the "dumpkeys |
loadkeys" sequence to fail.  

The next step would be to confirm that the others having the trouble are
running untainted kernels, or alternatively, that they are running the
madwifi driver (thus pointing in that direction).  

An expert might also peruse the keymap code in the kernel and make sure that 
we don't have one of the poverbial "off by one errors" in the table allocation size.
Comment 55 John DeDourek 2005-04-07 07:45:19 EDT
Also: the bug could actually be in dumpkeys rather than the kernel.  Occurred to
me on sober overnight reflection!  It might be an off by one error either in
dumpkeys or in the API it uses to obtain the keymap, causing some garbage in the
last entry (255) in the table that it may construct in its process workspace.
Comment 56 Dick Helwig 2005-04-29 16:28:30 EDT
After about a week on 2.6.11-1.14_FC3 (yum current as of then) this error 
showed up on a power up boot and has stayed over many reboots.  KDSKBENT: 
Invalid argument failed to bind key 255 to value 753.  

Also at same time dns name lookup has hard failed.  All conf files look 
proper.  nscd even cleared. I can ping any ip address, but namelookup fails.
Comment 57 mohammed f khan 2005-05-18 10:10:43 EDT
I am seeting this on RHEL4 Gold kernel ver 2.6.9-5.ELsmp as well. 

The message is: 
KDSKBENT: Invalid argument 
failed to bind key 255 to value 2029
Comment 58 Lew Palm 2005-06-09 11:02:22 EDT
Since then I changed from IS0-8859-1 to UTF-8, my _GENTOO_ System showed the
same bug: 
me@home # dumpkeys | loadkeys --unicode
KDSKBENT: Invalid argument
failed to bind key 255 to value 2047
Funny, eh? I have the gentoo-sources-2.6.11-r10 kernel.
I only wanted to point at that: You see, a superior system like gentoo has also
the same problems like RH. ];->
dumpkeys says (amongst others)
altgr   control keycode 255 = 0x07ff
You know, 2047 = 0x07ff means the highest possible Unicode 2-byte-Code and is
the unicode sequence "DF BF". That's ok, nothing horrible. That's nothing to nag
about for loadkeys. Ditto your values, because they are all <  2048.
The problem seems to set "altgr   control keycode 255" to something different to
"VoidSymbol". 
So let's set it to "VoidSymbol"! 
I added a line to my /usr/share/keymaps/i386/include/linux-with-alt-and-altgr.inc:
control altgr keycode 255 = VoidSymbol
And told the machine to load the new keymap:
loadkeys de-latin1
The problem vanished to nowhere.
It should be possible (or better?) to add this line to your
/usr/share/keymaps/yoursystem/yourkeyboard/yourkeymap.

Astonishingly there was nothing like
control altgr keycode 255 = 2047
in /usr/share/keymaps/*/*/* !
There was no setting for keycode 255. So I think dumpkeys is the evildoer. It
decides without asking anybody to set "control altgr keycode 255" to ... somethings.
If I would have enough time, I would throw a glance at dumpkeys sourcecode.
But maybe you have.
Comment 59 Dave Jones 2005-10-05 19:55:01 EDT
Has anyone seen this on any of the recent kernels ? There was a keymap handling
bug not so long ago involving an incorrect buffer size that could maybe explain
this. All current trees should have that fixed.
Comment 60 P Jones 2005-10-05 21:02:01 EDT
I haven't seen this bug in a long time. I can't say exactly when I stopped
noticing it. I'm on FC4 now, and I don't believe I've ever run into it on FC4.
Comment 61 Dan Pritts 2005-10-17 22:43:11 EDT
I just had the problem on a CentOS 4 (RHEL4 rebuild) system running
2.6.9-11.ELcustom (my kernel build added v4l, various filesystems, and optimized
for the via C3 (pre-nehemiah) core).  

This happened at the system console, a few seconds after logging in as root,
immediately after boot.  

no more keyboard input was accepted.  i presumed the system had crashed and
power-cycled it.  
Comment 62 jordan hargrave 2006-09-13 16:04:56 EDT
Seeing this on RHEL4 gold
Comment 63 Dave Jones 2006-09-14 01:14:20 EDT
RHEL bugs belong in a separate bug report.


Note You need to log in before you can comment on or make changes to this bug.