This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1251864 - Incorrect CPE Name in /etc/os-release
Incorrect CPE Name in /etc/os-release
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.5.4
Unspecified Unspecified
high Severity medium
: ovirt-3.6.0-rc3
: 3.6.0
Assigned To: Fabian Deutsch
Ying Cui
: ZStream
: 1251936 (view as bug list)
Depends On:
Blocks: 1273073
  Show dependency treegraph
 
Reported: 2015-08-10 03:37 EDT by Ying Cui
Modified: 2016-03-09 09:35 EST (History)
5 users (show)

See Also:
Fixed In Version: ovirt-node-3.3.0-0.10.20150928gite7ee3f1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1273073 (view as bug list)
Environment:
Last Closed: 2016-03-09 09:35:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45797 None NEW recipe: Also update the CPE in os-release Never
oVirt gerrit 46043 None MERGED Move initramfs regeneration until after grub is installed Never
oVirt gerrit 46103 ovirt-3.6 MERGED recipe: Also update the CPE in os-release Never
oVirt gerrit 47162 ovirt-3.5 MERGED recipe: Also update the CPE in os-release Never

  None (edit)
Description Ying Cui 2015-08-10 03:37:22 EDT
split the bug from https://bugzilla.redhat.com/show_bug.cgi?id=1248942#c3

Tested on build rhev-hypervisor-7-7.1-20150804.0.
the CPE_NAME display the RHEL CPE name, NOT RHEV-H CPE, hostnamectl will return incorrect CPE name in RHEV-H.

# cat /etc/rhev-hypervisor-release 
Red Hat Enterprise Virtualization Hypervisor release 7.1 (20150804.0.el7ev)


# cat /etc/system-release-cpe 
cpe:/o:redhat:enterprise_linux:7:update1:hypervisor

# hostnamectl 
   Static hostname: n/a
Transient hostname: localhost
         Icon name: computer-desktop
           Chassis: desktop
        Machine ID: 58cca1ceed28468fb4034bf84f7ed14d
           Boot ID: e59d79a5bb824dbc9c85d0963fa35c72
  Operating System: Red Hat Enterprise Virtualization Hypervisor 7.1
       CPE OS Name: cpe:/o:redhat:enterprise_linux:7.1:GA:server
            Kernel: Linux 3.10.0-229.11.1.el7.x86_64
      Architecture: x86_64

# cat /etc/os-release 
NAME="Red Hat Enterprise Linux Server"
VERSION="7.1 (Maipo)"
ID="rhel"
ID_LIKE="fedora"
VERSION_ID="7.1"
PRETTY_NAME="Red Hat Enterprise Virtualization Hypervisor 7.1"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:redhat:enterprise_linux:7.1:GA:server"
HOME_URL="https://www.redhat.com/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"

REDHAT_BUGZILLA_PRODUCT="Red Hat Enterprise Virtualization Hypervisor 7.1"
REDHAT_BUGZILLA_PRODUCT_VERSION=7.1
REDHAT_SUPPORT_PRODUCT="Red Hat Enterprise Linux"
REDHAT_SUPPORT_PRODUCT_VERSION="7.1"

Expected result
Correct CPE string in /etc/os-release in RHEV-H 7.1
Comment 2 Fabian Deutsch 2015-09-17 10:37:56 EDT
*** Bug 1251936 has been marked as a duplicate of this bug. ***
Comment 5 Ying Cui 2015-11-06 01:28:46 EST
# cat /etc/redhat-release 
Red Hat Enterprise Virtualization Hypervisor release 7.2 (20151104.0.el7ev)

# cat /etc/system-release-cpe 
cpe:/o:redhat:enterprise_linux:7:update2:hypervisor

# hostnamectl 
   Static hostname: dhcp-9-205.nay.redhat.com
         Icon name: computer-desktop
           Chassis: desktop
        Machine ID: e8dc07ed14ff4f21bce8668d4bf957e1
           Boot ID: d1103a3ad1f14a3b92373d43b44b24a5
  Operating System: Red Hat Enterprise Virtualization Hypervisor 7.2
       CPE OS Name: cpe:/o:redhat:enterprise_linux:7:update2:hypervisor
            Kernel: Linux 3.10.0-327.el7.x86_64
      Architecture: x86-64

# cat /etc/os-release 
NAME="Red Hat Enterprise Linux Workstation"
VERSION="7.2 (Maipo)"
ID="rhel"
ID_LIKE="fedora"
VERSION_ID="7.2"
PRETTY_NAME="Red Hat Enterprise Virtualization Hypervisor 7.2"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:redhat:enterprise_linux:7:update2:hypervisor"
HOME_URL="https://www.redhat.com/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"

REDHAT_BUGZILLA_PRODUCT="Red Hat Enterprise Virtualization Hypervisor 7.2"
REDHAT_BUGZILLA_PRODUCT_VERSION=7.2
REDHAT_SUPPORT_PRODUCT="Red Hat Enterprise Linux"
REDHAT_SUPPORT_PRODUCT_VERSION="7.2"


Result:
Correct CPE string in /etc/os-release in RHEV-H 7.2 for 3.6.0
Comment 7 errata-xmlrpc 2016-03-09 09:35:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html

Note You need to log in before you can comment on or make changes to this bug.