Bug 1252426 - (migration_improvements) [RFE] Migration improvements (convergence, bandwidth utilization)
[RFE] Migration improvements (convergence, bandwidth utilization)
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: RFEs (Show other bugs)
---
Unspecified Unspecified
urgent Severity high (vote)
: ovirt-4.0.0-beta
: 4.0.0
Assigned To: Tomas Jelinek
Israel Pinto
http://www.ovirt.org/Features/Migrati...
: FutureFeature
: 596062 1034871 1034893 1043809 1059886 1227967 1275476 1349530 (view as bug list)
Depends On: 1255474 1289285 1322529 1323952 1339521
Blocks: 1247237 596062 657086 1004101 1222516 1248119 1266158 1277255 1354343 1355961 1374760
  Show dependency treegraph
 
Reported: 2015-08-11 07:50 EDT by Michal Skrivanek
Modified: 2016-12-01 05:36 EST (History)
25 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Reason: Result: * Tab 'Resilience policy' in Cluster dialogs was renamed to 'Migration'. The content of the tab remains part of 'Migration' dialog.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-04 09:27:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
mavital: testing_plan_complete?
mgoldboi: planning_ack+
michal.skrivanek: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 49253 master MERGED core: support for convergence schedule 2016-05-02 03:21 EDT
oVirt gerrit 53313 master MERGED webadmin: Cluster > Resilience Policy renamed to Migration 2016-02-22 08:23 EST
oVirt gerrit 53929 master MERGED core: Cluster migration bandwidth - backend part 2016-03-03 03:09 EST
oVirt gerrit 54304 master MERGED core: Default for Cluster#migrationBandwidthLimitType 2016-03-03 09:57 EST
oVirt gerrit 54321 master MERGED webadmin: Cluster migration bandwidth - frontend part 2016-04-12 07:23 EDT
oVirt gerrit 54886 master MERGED core: Migration bandwidth columns added to stored procedures 2016-03-20 05:20 EDT
oVirt gerrit 54887 master MERGED core: ClusterDaoImpl parameterSource fix 2016-03-30 03:56 EDT
oVirt gerrit 54888 master MERGED core: MigrationPoliciesSupported config value added 2016-04-06 08:31 EDT
oVirt gerrit 55083 master MERGED core: Migration bandwidth columns added to clusters_sp.sql 2016-04-04 03:49 EDT
oVirt gerrit 55410 master MERGED core: Obtaining migration bandwidth 2016-04-13 03:20 EDT
oVirt gerrit 55840 master MERGED core: Migration max bandwidth 2016-05-02 11:05 EDT
oVirt gerrit 55976 master MERGED migration: added logging of more detailed stats 2016-04-19 06:07 EDT
oVirt gerrit 56153 master MERGED frontend: added support to override migration policies 2016-05-06 15:54 EDT
oVirt gerrit 56215 master MERGED core: added support to override migration policies 2016-05-06 13:54 EDT
oVirt gerrit 56631 master MERGED restapi: added migration policy ID to cluster and VmBase 2016-05-18 04:09 EDT
oVirt gerrit 56700 master NEW core: added remaining params to migration policies 2016-05-09 09:54 EDT
oVirt gerrit 56844 master MERGED core: Fix of active_migration_network_interface view 2016-05-02 09:56 EDT
oVirt gerrit 57397 master MERGED restapi: added the setting of the migration bandwidth to cluster 2016-05-18 04:09 EDT

  None (edit)
Description Michal Skrivanek 2015-08-11 07:50:06 EDT
several issues with migration has been identified based on users feedback
The core algorithm dealing with migration is getting outdated (new qemu options, VMs are in general larger), this bug is tracking refactoring of the core migration functionality in vdsm and engine
Comment 1 Michal Skrivanek 2015-08-11 07:50:45 EDT
*** Bug 1034871 has been marked as a duplicate of this bug. ***
Comment 2 Michal Skrivanek 2015-08-11 07:50:56 EDT
*** Bug 1043809 has been marked as a duplicate of this bug. ***
Comment 3 Tomas Jelinek 2015-08-13 05:59:46 EDT
*** Bug 1034893 has been marked as a duplicate of this bug. ***
Comment 4 Michal Skrivanek 2015-08-20 18:20:58 EDT
adding bug 1255474 for management communication resilience in overload conditions
Comment 5 Michal Skrivanek 2015-09-04 05:31:43 EDT
*** Bug 1059886 has been marked as a duplicate of this bug. ***
Comment 6 Michal Skrivanek 2015-09-17 03:43:16 EDT
*** Bug 1227967 has been marked as a duplicate of this bug. ***
Comment 7 Red Hat Bugzilla Rules Engine 2015-10-19 06:50:08 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 8 Michal Skrivanek 2015-11-06 05:41:27 EST
see https://access.redhat.com/solutions/744423 for more details about tuning migration until this RFE is implemented
Comment 10 Michal Skrivanek 2016-01-29 07:36:24 EST
*** Bug 1275476 has been marked as a duplicate of this bug. ***
Comment 11 Sandro Bonazzola 2016-05-02 05:52:45 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 12 Andrei Stepanov 2016-06-24 04:48:46 EDT
*** Bug 1349530 has been marked as a duplicate of this bug. ***
Comment 14 Michal Skrivanek 2016-07-19 05:08:53 EDT
*** Bug 596062 has been marked as a duplicate of this bug. ***
Comment 15 Israel Pinto 2016-08-03 07:22:59 EDT
Verify with:
Engine version: 4.0.2.3-0.1.el7ev
Host:
OS Version:RHEL - 7.2 - 9.el7_2.1
Kernel Version:3.10.0 - 327.22.2.el7.x86_64
KVM Version:2.3.0 - 31.el7_2.20
LIBVIRT Version:libvirt-1.2.17-13.el7_2.5
VDSM Version:vdsm-4.18.5.1-1.el7ev
SPICE Version:0.12.4 - 15.el7_2.1

Test cases: 
Functional testing:
1. Regression: Sanity testing to verify migration works properly.  

2. Web Admin: Verify the all action from RHEVM/Ovirt UI are performed as expected.

3. API: Check REST API, verify that configuration and actions are done properly via API.

4. Guest hook: Test new guest hooks, before and after migration.

5. Define custom policies / changing existed policies

System integration:

Test migration behavior integration with other RHEVM features. 

like: QoS, host/s maintenance...

Performance testing - work-loads testing:

Test migration under different types on memory load. In those test cases we will use pig load tool



(see polarion test plan) 

Results : PASS

Note You need to log in before you can comment on or make changes to this bug.