Bug 1252762 - [RFE][virt-v2v] When no virt-v2v exists in the Host, it could be great if an audit log will suggest that the user might need to install virt-v2v on the Host
[RFE][virt-v2v] When no virt-v2v exists in the Host, it could be great if an ...
Status: CLOSED DUPLICATE of bug 1250376
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
3.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: bugs@ovirt.org
Pavel Stehlik
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-12 04:35 EDT by Maor
Modified: 2015-08-13 10:43 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-13 10:43:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maor 2015-08-12 04:35:24 EDT
Description of problem:
When no virt-v2v exists in the Host, it could be great if an audit log will suggest that the user might need to install virt-v2v on the Host.

Currently there is such log at the VDSM log, showing:
OSError: [Errno 2] No such file or directory: virt-v2v

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Try to import a VM using virt-v2v and use a Host which does not has virt-v2v installed
2. 
3.

Actual results:
Import fails
VDSM log show: OSError: [Errno 2] No such file or directory: virt-v2v

Expected results:
Until virt-v2v will be dependent on VDSM, if a message/audit log suggesting the  user, one should install virt-v2v, it could be great.

Additional info:
Comment 1 Allon Mureinik 2015-08-12 06:15:07 EDT
This IMHO isn't an RFE, it's a bug.
VDSM can report the presence of v2v in the getCaps() verb, and the engine could grey out the the relevant button with a tooltip prompting the admin to install v2v.
(a similar solution was implemented to detect gluster support, see bug 1183318)
Comment 2 Omer Frenkel 2015-08-13 10:43:02 EDT
it was decided that vdsm will depend on v2v, so this shouldnt happen.
please see bug 1250376

*** This bug has been marked as a duplicate of bug 1250376 ***

Note You need to log in before you can comment on or make changes to this bug.