Bug 1252796 - Switch to Hosted Engine TUI menu so slowly due to failed to connect to broker
Switch to Hosted Engine TUI menu so slowly due to failed to connect to broker
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-ha (Show other bugs)
3.5.4
Unspecified Unspecified
high Severity urgent
: ovirt-3.5.7
: 3.5.7
Assigned To: Martin Sivák
Nikolai Sednev
sla
: ZStream
Depends On: 1172511 1275371
Blocks: 1222282 1250199
  Show dependency treegraph
 
Reported: 2015-08-12 05:14 EDT by Fabian Deutsch
Modified: 2016-01-27 08:59 EST (History)
26 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1172511
Environment:
Last Closed: 2016-01-27 08:59:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
juwu: needinfo-


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 36194 master MERGED HAClient: allow overriding broker connection parameters Never
oVirt gerrit 45267 ovirt-hosted-engine-ha-1.2 MERGED HAClient: allow overriding broker connection parameters Never

  None (edit)
Comment 1 Ying Cui 2015-08-19 05:48:32 EDT
This bug is cloned from 1172511, node side need to some change as well.
From QE view, we have to request to escalate this bug, because any action to interrupt VM(vm setup failed, terminate quit...) will cause RHEV-H TUI _so_ slowly, switch TUI menu need about 1~2mins for each, unacceptable. And once this issue happen, TUI almost like crash, can do nothing. Thanks.
Comment 2 Douglas Schilling Landgraf 2015-08-19 12:55:23 EDT
Hi Ying,

(In reply to Ying Cui from comment #1)
> This bug is cloned from 1172511, node side need to some change as well.
> From QE view, we have to request to escalate this bug, because any action to
> interrupt VM(vm setup failed, terminate quit...) will cause RHEV-H TUI _so_
> slowly, switch TUI menu need about 1~2mins for each, unacceptable. And once
> this issue happen, TUI almost like crash, can do nothing. Thanks.

I see in the original bug that it conatins a patch for ovirt-hosted-engine-ha. Could you please clarify the "node side need to some change as well"? Do we have any patch pending in ovirt-node? 

@Martin, I have noticed that the original bugzilla has the patch https://gerrit.ovirt.org/#/c/36194/ which has been merged at Aug 12th 2015. As soon this patch get backported to 3.5, will be required any additional patch from node side?


Thanks!
Comment 3 Ryan Barry 2015-08-19 13:20:26 EDT
(In reply to Douglas Schilling Landgraf from comment #2)
> I see in the original bug that it conatins a patch for
> ovirt-hosted-engine-ha. Could you please clarify the "node side need to some
> change as well"? Do we have any patch pending in ovirt-node? 
> 

I haven't written one, and I don't think anyone else has, either, so I'm guessing that there is not.

> @Martin, I have noticed that the original bugzilla has the patch
> https://gerrit.ovirt.org/#/c/36194/ which has been merged at Aug 12th 2015.
> As soon this patch get backported to 3.5, will be required any additional
> patch from node side?
> 
> 
> Thanks!

Since we use the Client, which is now defaulting to "retries=1, wait=0", I think Martin may have done us a favor here, and we don't need a patch, but I'll wait to see...
Comment 4 Douglas Schilling Landgraf 2015-08-19 23:08:18 EDT
(In reply to Ryan Barry from comment #3)
> (In reply to Douglas Schilling Landgraf from comment #2)
> > I see in the original bug that it conatins a patch for
> > ovirt-hosted-engine-ha. Could you please clarify the "node side need to some
> > change as well"? Do we have any patch pending in ovirt-node? 
> > 
> 
> I haven't written one, and I don't think anyone else has, either, so I'm
> guessing that there is not.
> 
> > @Martin, I have noticed that the original bugzilla has the patch
> > https://gerrit.ovirt.org/#/c/36194/ which has been merged at Aug 12th 2015.
> > As soon this patch get backported to 3.5, will be required any additional
> > patch from node side?
> > 
> > 
> > Thanks!
> 
> Since we use the Client, which is now defaulting to "retries=1, wait=0", I
> think Martin may have done us a favor here, and we don't need a patch, but
> I'll wait to see...

Agreed, as we talked, no need change in ovirt-node, moving the bug to ovirt-hosted-engine-ha. @Martin, please let use know if you need any assistance from the ovirt-node site.

Thanks!
Comment 5 Yaniv Lavi (Dary) 2015-08-20 08:28:13 EDT
Is this patch safe to be included in 3.5.4?
How risky is it?
Comment 6 Martin Sivák 2015-08-24 10:45:57 EDT
There should be no risk here. At least from the HE perspective. I can't speak for the node guys though.
Comment 7 Douglas Schilling Landgraf 2015-08-24 11:56:47 EDT
(In reply to Martin Sivák from comment #6)
> There should be no risk here. At least from the HE perspective. I can't
> speak for the node guys though.

From node side, should have no risk too. Martin, please let me know when you guys have a new build so I can trigger an unsiged build for testing.

Thanks!
Comment 10 Julie 2015-10-21 18:18:08 EDT
If this bug requires doc text for errata release, please provide draft text in the doc text field in the following format:

Cause:
Consequence:
Fix:
Result:

The documentation team will review, edit, and approve the text.

If this bug does not require doc text, please set the 'requires_doc_text' flag to -.
Comment 13 Nikolai Sednev 2015-10-26 13:12:04 EDT
Failed to deploy the HE on Red Hat Enterprise Virtualization Hypervisor release 7.1 (20151015.0.el7ev) over iSCSI because of failure in configuring the management bridge on host during deployment of the HE, bridge was not created and connectivity was lost to the host.
After restarting the host manually, bridge was created, but FQDN of the host became "localhost" instead of originally received from the DHCP.

This bug depends on 1275371.
Comment 15 Dan Kenigsberg 2015-11-05 09:10:49 EST
the "localhost" issue is tracked in bug 1232338.
Comment 19 Fabian Deutsch 2016-01-27 07:54:23 EST
Nikolai, is this bug still present on RHEV-H for 3.5.z?
Comment 21 Ying Cui 2016-01-27 08:58:37 EST
This bug was cloned more than one time, so the bug can be closed as current release. 
There was closed z-stream Bug 1222282 - Switch to Hosted Engine TUI menu so slowly due to failed to connect to broker

Note You need to log in before you can comment on or make changes to this bug.