Bug 1253756 - [Fedora] Consume fix for "libvirt reports physical=0 for COW2 volumes on block storage"
[Fedora] Consume fix for "libvirt reports physical=0 for COW2 volumes on bloc...
Status: CLOSED NOTABUG
Product: vdsm
Classification: oVirt
Component: General (Show other bugs)
4.17.0
Unspecified Unspecified
high Severity high (vote)
: ovirt-3.6.2
: ---
Assigned To: Fred Rolland
Aharon Canan
storage
: Regression, Reopened
: 1255246 (view as bug list)
Depends On: 1253754
Blocks: 1419790 1419791
  Show dependency treegraph
 
Reported: 2015-08-14 11:31 EDT by Nir Soffer
Modified: 2017-04-17 20:22 EDT (History)
21 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1251008
: 1419790 1419791 (view as bug list)
Environment:
Last Closed: 2016-10-27 08:36:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑3.6.z?
rule-engine: blocker?
ylavi: planning_ack+
tnisan: devel_ack+
acanan: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 44834 master MERGED spec: Require newer libvirt version for el7 Never
oVirt gerrit 49444 None None None Never
oVirt gerrit 51295 master MERGED build: update libvirt dependency for fedora 2016-01-05 06:14 EST
oVirt gerrit 51369 ovirt-3.6 MERGED build: update libvirt dependency for fedora 2016-01-05 09:56 EST

  None (edit)
Comment 1 Nir Soffer 2015-08-14 11:34:13 EDT
Resolving this is needed to support Fedora 23. Fedora 22 is using older
libvirt version without this regression.
Comment 2 Nir Soffer 2015-08-14 11:38:57 EDT
But it may effect also Fedora 22 when using virt-preview repository.
Comment 3 Allon Mureinik 2015-08-20 05:12:40 EDT
*** Bug 1255246 has been marked as a duplicate of this bug. ***
Comment 4 Red Hat Bugzilla Rules Engine 2015-09-22 03:43:55 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 5 Red Hat Bugzilla Rules Engine 2015-10-19 06:51:30 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 6 Yaniv Lavi 2015-10-29 08:29:39 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 7 Tal Nisan 2015-12-01 03:07:56 EST
Nir, I don't think this bug should be on POST as the patch only fixes the problem on RHEL, can you please confirm?
Comment 8 Nir Soffer 2015-12-01 04:19:06 EST
(In reply to Tal Nisan from comment #7)
> Nir, I don't think this bug should be on POST as the patch only fixes the
> problem on RHEL, can you please confirm?

Yes, we need to require the Fedora 23 package fixing this. When I opened
this bug, it was not available.
Comment 9 Allon Mureinik 2015-12-23 10:18:52 EST
Removing the blocker flag. Even without this fix a used can always manually dnf update to get the libvirt package that solves the issue.
Comment 10 Aharon Canan 2016-01-17 06:44:12 EST
We are not verifying Fedora, 
On RHEL7.2 it looks ok

Verified (vdsm-4.17.17-0.el7ev.noarch)

[root@camel-vdsc ~]# rpm -q --requires vdsm |grep libvirt
libvirt-client
libvirt-daemon >= 1.2.17-9
libvirt-daemon-config-nwfilter
libvirt-daemon-driver-network
libvirt-daemon-driver-nwfilter
libvirt-daemon-driver-qemu
libvirt-lock-sanlock
libvirt-python >= 1.2.17-2
Comment 12 Red Hat Bugzilla Rules Engine 2016-10-20 20:58:04 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Note You need to log in before you can comment on or make changes to this bug.