Bug 1254077 - [abrt] firewalld: service.py:32:<module>:ImportError: cannot import name '_glib'
[abrt] firewalld: service.py:32:<module>:ImportError: cannot import name '_glib'
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: python-slip (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:00f77d6e5f7ab3719cc2e556e7b...
:
: 1253981 1254134 1254736 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 02:36 EDT by Jakub Filak
Modified: 2016-11-30 19:49 EST (History)
7 users (show)

See Also:
Fixed In Version: 0.6.3-1.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-26 00:33:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (7.64 KB, text/plain)
2015-08-17 02:36 EDT, Jakub Filak
no flags Details
File: environ (88 bytes, text/plain)
2015-08-17 02:36 EDT, Jakub Filak
no flags Details

  None (edit)
Description Jakub Filak 2015-08-17 02:36:15 EDT
Description of problem:
I updated my system (glibc-2.21.90-20.fc24 -> 2.22.90-2.fc24), rebooted and firewalld started crashing with this error.

Version-Release number of selected component:
firewalld-0.3.14.2-4.fc24

Additional info:
reporter:       libreport-2.6.2.2.g8c63.dirty
cmdline:        /usr/bin/python3 -Es /usr/sbin/firewalld --nofork --nopid
executable:     /usr/sbin/firewalld
kernel:         4.2.0-0.rc0.git1.1.fc23.x86_64
runlevel:       3 5
type:           Python3
uid:            0

Truncated backtrace:
#1 <module> in /usr/lib/python3.4/site-packages/slip/dbus/service.py:32
#2 <module> in /usr/lib/python3.4/site-packages/slip/dbus/__init__.py:8
#3 <module> in /usr/lib/python3.4/site-packages/firewall/server/server.py:38
#4 startup in /usr/sbin/firewalld:127
#5 main in /usr/sbin/firewalld:171
#6 <module> in /usr/sbin/firewalld:176
Comment 1 Jakub Filak 2015-08-17 02:36:18 EDT
Created attachment 1063641 [details]
File: backtrace
Comment 2 Jakub Filak 2015-08-17 02:36:20 EDT
Created attachment 1063642 [details]
File: environ
Comment 3 Jakub Filak 2015-08-17 03:05:21 EDT
Heh, "from .._wrappers import _glib as GLib" confused me a bit. The crash has root cause in python-slip package where the %{python3_sitelib}/slip/_wrappers/glib.py does not exist (the bug was probably introduced with the patch for bug #1202554).

I have opened upstream pull request https://github.com/nphilipp/python-slip/pull/1
Comment 4 Nils Philippsen 2015-08-17 04:59:15 EDT
fixed upstream:

commit fe36638e010eb12789de5ba30d0822b2261a6b64
Author:     Nils Philippsen <nils@redhat.com>
AuthorDate: Mon Aug 17 10:47:28 2015 +0200
Commit:     Nils Philippsen <nils@redhat.com>
CommitDate: Mon Aug 17 10:47:28 2015 +0200

    fix omissions from _gobject -> _glib migration
    
    amends commit 72541ae95eb8961584876320edd8e22d5ffa309d

commit e837efed64626203c3ec0721469ad7c233265e59
Author:     Jakub Filak <jfilak@redhat.com>
AuthorDate: Mon Aug 17 08:56:52 2015 +0200
Commit:     Nils Philippsen <nils@redhat.com>
CommitDate: Mon Aug 17 10:41:26 2015 +0200

    amend the migration from GObject to GLib
    
    This commit fixes bugzilla.redhat.com/1254077 partially
    The bug was introduced in commit 72541ae95eb8961584876320edd8e22d5ffa309d
    
    Signed-off-by: Jakub Filak <jfilak@redhat.com>
    Signed-off-by: Nils Philippsen <nils@redhat.com>
Comment 5 Fedora Update System 2015-08-17 05:51:22 EDT
python-slip-0.6.3-1.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/python-slip-0.6.3-1.fc23
Comment 6 Fedora Update System 2015-08-17 05:51:32 EDT
python-slip-0.6.3-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/python-slip-0.6.3-1.fc22
Comment 7 Fedora Update System 2015-08-17 05:52:46 EDT
python-slip-0.6.3-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/python-slip-0.6.3-1.fc21
Comment 8 Nils Philippsen 2015-08-17 08:01:41 EDT
*** Bug 1254134 has been marked as a duplicate of this bug. ***
Comment 9 Vít Ondruch 2015-08-18 14:35:48 EDT
*** Bug 1254736 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2015-08-19 04:04:31 EDT
Package python-slip-0.6.3-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-slip-0.6.3-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-13673/python-slip-0.6.3-1.fc21
then log in and leave karma (feedback).
Comment 11 Nils Philippsen 2015-08-21 05:34:47 EDT
*** Bug 1253981 has been marked as a duplicate of this bug. ***
Comment 12 Fedora Update System 2015-08-26 00:33:29 EDT
python-slip-0.6.3-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2015-09-04 01:19:35 EDT
python-slip-0.6.3-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2015-09-04 07:49:26 EDT
python-slip-0.6.3-1.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.