Bug 1255605 - Scrubber log should mark file corrupted message as Alert not as information
Scrubber log should mark file corrupted message as Alert not as information
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: bitrot (Show other bugs)
3.7.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
bugs@gluster.org
: Triaged
Depends On: 1238977 1240218
Blocks: 1240219
  Show dependency treegraph
 
Reported: 2015-08-21 02:30 EDT by Gaurav Kumar Garg
Modified: 2016-06-05 19:37 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1240218
Environment:
Last Closed: 2015-09-09 05:40:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2015-08-21 02:32:13 EDT
REVIEW: http://review.gluster.org/11974 (bitrot: Scrubber log should mark bad file as a ALERT in the scrubber log) posted (#1) for review on release-3.7 by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 2 Anand Avati 2015-08-21 05:39:28 EDT
COMMIT: http://review.gluster.org/11974 committed in release-3.7 by Raghavendra Bhat (raghavendra@redhat.com) 
------
commit 7322e6c5b405a754fea1e0eeddf8e66da1bdd326
Author: Gaurav Kumar Garg <garg.gaurav52@gmail.com>
Date:   Thu Aug 20 16:12:53 2015 +0530

    bitrot: Scrubber log should mark bad file as a ALERT in the scrubber log
    
    If bad file detected by scrubber then scrubber should log that bad
    file as a ALERT message in scrubber log.
    
    Change-Id: I410429e78fd3768655230ac028fa66f7fc24b938
    BUG: 1255605
    Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
    Reviewed-on: http://review.gluster.org/11965
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    (cherry picked from commit 6cb73b4fe798b7bf3aface0aac2a4e6c7c618c0e)
    Reviewed-on: http://review.gluster.org/11974
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 3 Kaushal 2015-09-09 05:40:21 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.