Bug 1256061 - {Not quite "Cosmetic"} All about R.E.S.C.U.E. - "liveinst --rescue" - repair environment
{Not quite "Cosmetic"} All about R.E.S.C.U.E. - "liveinst --rescue" - repair ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-23 13:32 EDT by poma
Modified: 2015-11-06 08:38 EST (History)
6 users (show)

See Also:
Fixed In Version: anaconda-24.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-28 12:10:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fedora 22 OK (163.49 KB, image/gif)
2015-08-23 13:34 EDT, poma
no flags Details
Fedora 23 BROKEN (60.88 KB, image/gif)
2015-08-23 13:35 EDT, poma
no flags Details
Rawhide BROKEN (61.80 KB, image/gif)
2015-08-23 13:36 EDT, poma
no flags Details
Rawhide BROKEN v24.0 (60.62 KB, image/gif)
2015-08-28 10:38 EDT, poma
no flags Details

  None (edit)
Description poma 2015-08-23 13:32:27 EDT
Currently this is broken in Fedora 23 and Rawhide.
Besides why is Ncurses support dropped, replaced with a simple text mode?

In contrast, see a Fedora 22 working example.

-- --

The RESCUE mode as one of the live install options - "Install to Hard Drive".
"Choose and lose" this option, to repair a problem with your installed Fedora system that prevents you from booting.

$ liveinst --help
usage: anaconda [-h] ... [--rescue]
                ...

Anaconda is the installation program used by Fedora,Red Hat Enterprise Linux and some other distributions.

optional arguments:
  -h, --help
        show this help message and exit
  ...
  --rescue
        Start the rescue environment instead of installation.

-- --

Why did not you explain to reporters - Anaconda' RESCUE mode do exist as one of the live install options?

- Fedora 24-26 Live Rescue
  https://bugzilla.redhat.com/show_bug.cgi?id=1228435

- can't login in rescue mode using live CD
  https://bugzilla.redhat.com/show_bug.cgi?id=1173544

- no rescue mode in menu
  https://bugzilla.redhat.com/show_bug.cgi?id=1176580

- Include a section on using the Live media for rescue
  https://bugzilla.redhat.com/show_bug.cgi?id=1086052

- add rescue boot option to liveCD
  https://bugzilla.redhat.com/show_bug.cgi?id=1003672
Comment 1 poma 2015-08-23 13:34:35 EDT
Created attachment 1066063 [details]
Fedora 22 OK
Comment 2 poma 2015-08-23 13:35:25 EDT
Created attachment 1066064 [details]
Fedora 23 BROKEN
Comment 3 poma 2015-08-23 13:36:04 EDT
Created attachment 1066065 [details]
Rawhide BROKEN
Comment 4 poma 2015-08-26 14:20:29 EDT
anaconda-24.0-1.fc24.x86_64 BROKEN
Comment 5 Samantha N. Bueno 2015-08-26 15:52:49 EDT
(In reply to poma from comment #0)
> Currently this is broken in Fedora 23 and Rawhide.
> Besides why is Ncurses support dropped, replaced with a simple text mode?

Because we have a newer, better text-based UI that we've been using for text-mode installs ever since F18. It was time to rewrite rescue mode to fit with this newer UI and drop the last remaining dependency on ncurses.

> In contrast, see a Fedora 22 working example.

GIFs do not help us to debug this; you need to attach logs from /tmp.
Comment 6 poma 2015-08-27 02:14:58 EDT
Also "classic" rescue is BROKEN
- boot.iso 'Fedora-rawhide-x86_64' - BROKEN
- Fedora-Server-netinst-x86_64-23_Alpha.iso 'Fedora-S-23_A-x86_64' - BROKEN
- Fedora-Workstation-netinst-x86_64-23_Alpha.iso 'Fedora-WS-23_A-x86_64' - BROKEN
Comment 7 poma 2015-08-27 02:24:31 EDT
(In reply to Samantha N. Bueno from comment #5)
> (In reply to poma from comment #0)
> > Currently this is broken in Fedora 23 and Rawhide.
> > Besides why is Ncurses support dropped, replaced with a simple text mode?
> 
> Because we have a newer, better text-based UI that we've been using for
> text-mode installs ever since F18. It was time to rewrite rescue mode to fit
> with this newer UI and drop the last remaining dependency on ncurses.
> 

Sure, here is seen how much is better.
You have managed to break RESCUE tutto completo.

> > In contrast, see a Fedora 22 working example.
> 
> GIFs do not help us to debug this; you need to attach logs from /tmp.

I need? Really?
Comment 8 David Shea 2015-08-27 07:51:18 EDT
(In reply to poma from comment #7)
> (In reply to Samantha N. Bueno from comment #5)
> > (In reply to poma from comment #0)
> > > Currently this is broken in Fedora 23 and Rawhide.
> > > Besides why is Ncurses support dropped, replaced with a simple text mode?
> > 
> > Because we have a newer, better text-based UI that we've been using for
> > text-mode installs ever since F18. It was time to rewrite rescue mode to fit
> > with this newer UI and drop the last remaining dependency on ncurses.
> > 
> 
> Sure, here is seen how much is better.
> You have managed to break RESCUE tutto completo.

Cosmetic changes are not causing your problems and your hostility is not helping your case.

> > > In contrast, see a Fedora 22 working example.
> > 
> > GIFs do not help us to debug this; you need to attach logs from /tmp.
> 
> I need? Really?

Yes! Really!
Comment 9 poma 2015-08-27 10:06:03 EDT
(In reply to David Shea from comment #8)
...
> ... and your hostility is not
...

David Shea, 
I hope you understand what you have written here, I expect from you a sincere apology for that.
Comment 10 poma 2015-08-27 10:08:08 EDT
Samantha N. Bueno,

Maybe you really do not comprehend the meritum here, and not only here.

If you are not able to show respect, how can you expect any help.
Remember, I'm here helping you, not the other way around.

Where and when vanished,
"Thank you for your time and care, we would be grateful if you can assist further, with providing ...".
Comment 11 Chris Lumens 2015-08-27 13:37:32 EDT
Rescue mode on live installations isn't a supported configuration.  If you're booting into the live environment, you have a full operating system of tools at your disposal to fix up whatever might be wrong.  Plus, you can even install more stuff from Fedora repos and use that to aid you too.  anaconda's rescue mode is designed to operate in more limited environments where you don't have the full power of the OS at your disposal.

I have pushed a patch to indicate this is unsupported in anaconda, and to minimally mention it in the --help output.
Comment 12 poma 2015-08-28 10:38:23 EDT
Created attachment 1068042 [details]
Rawhide BROKEN v24.0
Comment 13 Chris Lumens 2015-08-28 10:41:13 EDT
Updated the Fixed In Version field to reflect where this bug has been taken care of.  It doesn't really need to be reopened.
Comment 14 poma 2015-08-28 10:58:20 EDT
(In reply to Chris Lumens from comment #11)
> Rescue mode on live installations isn't a supported configuration.  If
> you're booting into the live environment, you have a full operating system
> of tools at your disposal to fix up whatever might be wrong.  Plus, you can
> even install more stuff from Fedora repos and use that to aid you too. 
> anaconda's rescue mode is designed to operate in more limited environments
> where you don't have the full power of the OS at your disposal.
> 
> I have pushed a patch to indicate this is unsupported in anaconda, and to
> minimally mention it in the --help output.

Chris Lumens,
man, are you trying to say - all this time you(Anaconda team) lied to the users!?

I still do not see a sincere apology from David Shea!
Comment 15 Chris Lumens 2015-08-28 11:03:17 EDT
This will be my final comment on this bug, and after that I will be blocking you so I don't have to read anything further.

No one has lied to you about anything.  We have never intended to support this configuration.  The fact that it worked at some point in the past, and even the fact that we may have fixed bugs in it from time to time, is not a statement that we intended to support this configuration.  We must necessarily limit what we support in order to actually get work done on the truly important parts of the installer.  Supporting duplicate effort like this is not an effective use of our time.  The live environment is a much more complete rescue mode than using the relatively limited rescue capabilities in anaconda.  Please use the system tools instead.
Comment 16 poma 2015-08-28 11:04:50 EDT
It will remain open until I see apology from you all.
Comment 17 poma 2015-08-28 11:10:34 EDT
You guys are really something, shame on you!
Comment 18 David Cantrell 2015-08-28 11:20:32 EDT
Fedora community participants are required to abide by the terms of the Fedora Code of Conduct:

https://getfedora.org/code-of-conduct

As explained, there is no work to complete regarding this report.
Comment 19 poma 2015-08-28 11:32:33 EDT
David Cantrell,

Fedora community participants must not lie!
Anaconda team must not lie!
Comment 20 poma 2015-08-28 11:34:55 EDT
It will remain open until I see apology from you all.
Comment 21 poma 2015-08-28 11:45:04 EDT
(In reply to Samantha N. Bueno from comment #5)
...
> GIFs do not help us to debug this; you need to attach logs from /tmp.

Samantha N. Bueno, do I still need logs? ;)
You see, I was right after all. :)
Comment 22 poma 2015-08-28 11:47:25 EDT
(In reply to poma from comment #21)
> (In reply to Samantha N. Bueno from comment #5)
> ...
> > GIFs do not help us to debug this; you need to attach logs from /tmp.
> 
> Samantha N. Bueno, do I still need logs? ;)
> You see, I was right after all. :)

Here you can shut down this bug report, when your colleagues do not have the courage to sincerely apologize.
Comment 23 poma 2015-08-28 11:50:08 EDT
David Cantrell, not you!
Samantha N. Bueno can only close!

Note You need to log in before you can comment on or make changes to this bug.