Bug 1256081 - Consume fix for "Multipath is not correctly identifying iscsi devices, and misconfiguring them"
Consume fix for "Multipath is not correctly identifying iscsi devices, and mi...
Status: CLOSED CURRENTRELEASE
Product: vdsm
Classification: oVirt
Component: General (Show other bugs)
4.17.0
Unspecified Unspecified
high Severity high (vote)
: ovirt-3.6.1
: 4.17.12
Assigned To: Nir Soffer
Aharon Canan
storage
:
Depends On: 1256074 1261141
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-23 17:05 EDT by Nir Soffer
Modified: 2016-03-10 10:16 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1255173
: 1273611 (view as bug list)
Environment:
Last Closed: 2016-01-13 09:40:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
ylavi: planning_ack+
rule-engine: devel_ack+
acanan: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45115 master MERGED multiapth: Require newer multiapth version Never
oVirt gerrit 47578 ovirt-3.6 MERGED multiapth: Require newer multiapth version Never
oVirt gerrit 47582 ovirt-3.5 MERGED multiapth: Require newer multiapth version Never
oVirt gerrit 47744 ovirt-3.5 MERGED spec: Unbreak build on rhel Never
oVirt gerrit 47763 ovirt-3.5 ABANDONED Restore: multiapth: Require newer multiapth version Never
oVirt gerrit 47764 ovirt-3.5 ABANDONED Restore: spec: Unbreak build on rhel Never
oVirt gerrit 47776 ovirt-3.5 MERGED multiapth: Require newer multiapth version Never
oVirt gerrit 47777 ovirt-3.5 MERGED spec: Unbreak build on rhel Never
oVirt gerrit 49461 None None None Never

  None (edit)
Description Nir Soffer 2015-08-23 17:05:46 EDT
+++ This bug was initially created as a clone of Bug #1255173 +++

Description of problem:

Multipath did not identify iscsi devices, so their session recovery_tmo
was not configured correctly. This cause too slow failover when path is
having trouble.

This issue was fixed in device-mapper-multipath-0.4.9-82.el7.
Vdsm should require this version when it is available.
Comment 1 Nir Soffer 2015-08-23 17:07:42 EDT
We hope to get a fix for Fedora 22 and 21.
Comment 2 Nir Soffer 2015-10-16 19:43:16 EDT
The fix is available in update-testing repo. We need to get someone to
test this fix.
Comment 3 Red Hat Bugzilla Rules Engine 2015-10-19 06:53:59 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 4 Nir Soffer 2015-10-20 15:13:51 EDT
Package for Fedora 21 is still missing, will open a separate bug for it
since we must consume the Fedora 22 package now.
Comment 5 Aharon Canan 2015-11-10 08:24:30 EST
The clone already verified by Elad and both has the same target.
I am not sure what this bug stands for, 

Please advice.
Comment 6 Nir Soffer 2015-11-10 08:28:22 EST
Tal, can you answer this? maybe the clone is using the wrong target release?
Comment 7 Tal Nisan 2015-11-15 05:17:11 EST
I don't know, you cloned it to begin with, what was the purpose of having another bug clone?
Comment 8 Allon Mureinik 2015-11-15 06:16:09 EST
I believe the point of this cloning was to have one BZ for RHEV and one for oVirt.

Moving to ON_QA.
Elad - based on your verification of bug 1255173, please either move this one to VERIFIED too, or perform any verification steps that may be missing from the oVirt BZ, if they exist.
Thanks!
Comment 9 Red Hat Bugzilla Rules Engine 2015-11-15 06:26:18 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 10 Elad 2015-11-15 09:47:02 EST
vdsm-4.17.11 is not available for us yet
Comment 11 Sandro Bonazzola 2015-11-24 11:34:56 EST
4.17.11 is in ovirt-3.6.1 milestone. moving.
Comment 12 Elad 2015-11-30 09:14:53 EST
Nir,

It seems that vdsm requires an older device-mapper-multipath than the one in the fix:

[root@green-vdsb ~]# rpm -q --requires vdsm-4.17.11-0.el7ev.noarch |grep device
device-mapper-multipath >= 0.4.9-77.el7_1.2

[root@green-vdsb ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.2 (Maipo)
Comment 13 Nir Soffer 2015-11-30 12:29:35 EST
(In reply to Elad from comment #12)
> Nir,
> 
> It seems that vdsm requires an older device-mapper-multipath than the one in
> the fix:
> 
> [root@green-vdsb ~]# rpm -q --requires vdsm-4.17.11-0.el7ev.noarch |grep
> device
> device-mapper-multipath >= 0.4.9-77.el7_1.2
> 
> [root@green-vdsb ~]# cat /etc/redhat-release 
> Red Hat Enterprise Linux Server release 7.2 (Maipo)

This fix was introduced before 7.2 was available, so we could not
require the 7.2 version.

We will require the 7.2 version in future version.
Comment 14 Aharon Canan 2015-12-01 04:03:07 EST
(In reply to Nir Soffer from comment #13)

> This fix was introduced before 7.2 was available, so we could not
> require the 7.2 version.
> 
> We will require the 7.2 version in future version.

As 3.6 will be released with 7.2 we need to verify on rhel 7.2, so if it wasn't fixed for 7.2, please move to on_qa once you have the fix for 7.2
Comment 15 Red Hat Bugzilla Rules Engine 2015-12-01 04:03:11 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 16 Red Hat Bugzilla Rules Engine 2015-12-01 15:55:29 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 17 Nir Soffer 2015-12-01 15:56:58 EST
The tested vdsm package requires the correct version of multipath for 
ovirt-3.6 when the bug was resolved, because rhel 7.2 was not available
at that time.

In the meantime, rhel 7.2 was released, and we require now the rhel 7.2
package for bug 1265204.
Comment 18 Aharon Canan 2015-12-29 08:09:40 EST
(In reply to Nir Soffer from comment #0)
> +++ This bug was initially created as a clone of Bug #1255173 +++
> 
> Description of problem:
> 
> Multipath did not identify iscsi devices, so their session recovery_tmo
> was not configured correctly. This cause too slow failover when path is
> having trouble.
> 
> This issue was fixed in device-mapper-multipath-0.4.9-82.el7.
> Vdsm should require this version when it is available.

[root@green-vdsc ~]# rpm -q --requires vdsm-4.17.14-0.el7ev.noarch |grep device
device-mapper-multipath >= 0.4.9-84.el7
Comment 19 Sandro Bonazzola 2016-01-13 09:40:26 EST
oVirt 3.6.1 has been released, closing current release

Note You need to log in before you can comment on or make changes to this bug.