Bug 1265204 - Consume fix for "multipathd: uevent trigger error"
Consume fix for "multipathd: uevent trigger error"
Status: CLOSED CURRENTRELEASE
Product: vdsm
Classification: oVirt
Component: General (Show other bugs)
4.17.5
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-3.6.1
: 4.17.12
Assigned To: Tal Nisan
Aharon Canan
storage
:
Depends On: 1259831 1271118
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-22 07:32 EDT by Nir Soffer
Modified: 2016-02-10 14:21 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-13 09:39:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: blocker+
ylavi: planning_ack+
amureini: devel_ack+
acanan: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 49113 master MERGED spec: Require newer multipath version Never
oVirt gerrit 49461 ovirt-3.6 MERGED spec: Require newer multipath version Never

  None (edit)
Description Nir Soffer 2015-09-22 07:32:42 EDT
Description of problem:

There is a race between udev and multiapth, fixed in bug 1259831
by adding retry logic to multipath.

Vdsm should consume this fix when it is available.

There are various issue reported with rhevh caused by this race:
bug 1263937, bug 1264317, bug 1264049

Yaniv: component should be packaging, but I'm not going to create two bugs,
one with packaging.deb and one with packaging.rpm.
Comment 1 Red Hat Bugzilla Rules Engine 2015-10-19 06:52:52 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Sandro Bonazzola 2015-10-26 08:46:12 EDT
this is an automated message. oVirt 3.6.0 RC3 has been released and GA is targeted to next week, Nov 4th 2015.
Please review this bug and if not a blocker, please postpone to a later release.
All bugs not postponed on GA release will be automatically re-targeted to

- 3.6.1 if severity >= high
- 4.0 if severity < high
Comment 3 Allon Mureinik 2015-11-23 08:54:55 EST
The underlying bug for RHEL 7.2 is released.
Please fix this ASAP.
Comment 4 Sandro Bonazzola 2015-12-01 10:25:41 EST
This bug is referenced in 4.17.12 git log and has target release unset.
Please check
Comment 5 Nir Soffer 2015-12-01 16:04:47 EST
This fix is available in 4.17.12, updating target release.
Comment 6 Nir Soffer 2015-12-01 16:08:43 EST
The fix for this bug is also needed for bug 1256081.
Comment 7 Tal Nisan 2015-12-29 08:23:38 EST
New versions required in the spec:

RHEL: 0.4.9-84.el7
Fedora 22: 0.4.9-73.fc22.2
Fedora 23: 0.4.9-80.fc23
Comment 8 Aharon Canan 2015-12-29 08:24:27 EST
[root@green-vdsc ~]# rpm -q --requires vdsm-4.17.14-0.el7ev.noarch |grep device
device-mapper-multipath >= 0.4.9-84.el7
Comment 9 Sandro Bonazzola 2016-01-13 09:39:38 EST
oVirt 3.6.1 has been released, closing current release

Note You need to log in before you can comment on or make changes to this bug.