Bug 125693 - Fedora Core CD not found during installation
Fedora Core CD not found during installation
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
: 125785 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-10 03:13 EDT by Eric B
Modified: 2015-01-04 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 01:33:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from: dmesg -s 128000 (8.68 KB, text/plain)
2004-06-15 18:29 EDT, Eric B
no flags Details

  None (edit)
Description Eric B 2004-06-10 03:13:33 EDT
I can reproduce this bug, see bug #124081

Machine is a HP Pavillion 6635, 1HD, 1 CDROM

I boot the installer for FC2, select English lang, and US keyboard.
Then I select Local CDRom.  Response is Fedora Core CD not found.

tty3:
trying to mount cd device hdc

tty4:
<4>hdc: command error: status=0x51 { DriveReady SeekComplete Error }
<4>hdc: command error: status=0x50
<4>end_request: I/O error, dev hdc, sector 64
<4>isofs_fill_super: bread failed, dev=hdc, iso_blknum=16, block=16


Additionally, I copied the CD sourfce RPM's to another machine and
installed via FTP.  Install via FTP worked fine, however when trying
to mount a CD, any CD, I get the above command errors on hdc.
Comment 1 Jeremy Katz 2004-06-14 11:42:29 EDT
*** Bug 125785 has been marked as a duplicate of this bug. ***
Comment 2 Eric B 2004-06-15 02:34:05 EDT
I have noticed today, while installing on different hardware, that
this install did not ask to verify the integrity of the installation
CDROMs.  Therefore, it appears that the Fedora core2 kernel is not
recognizing the HP CDROM hardware at all.
Comment 3 Dave Jones 2004-06-15 06:27:46 EDT
can you attach the dmesg -s 128000 of this box please ?
Comment 4 Eric B 2004-06-15 18:29:45 EDT
Created attachment 101178 [details]
output from: dmesg -s 128000
Comment 5 Dave Jones 2004-06-16 09:07:08 EDT
can you try disabling DMA on the CD drive with the hdc=noidedma boot
argument ?
Comment 6 Eric B 2004-06-16 14:51:04 EDT
I have tried the following kernel options

linux text hdc=noidedma
linux hdc=noidedma

The installer still does not ask to verify the install CDs and the
CDRom is not found when selecting install via CDRom.
Comment 7 Ben Smith 2004-07-22 17:20:09 EDT
I think I may be seeing this on some older hardware.  Can anybody report the output of 'hdparm -i /tmp/cdrom' from the console of the install, preferably with and without disabling dma as shown above?
Comment 8 Marc B. 2004-10-07 03:51:56 EDT
I have this problem as well.
Trying it with fc3-test2 however, so whatever the problem was, it's 
still there. Old machine (PIII). I've tried changing the CD from 
master to slave, from primary to secondary. Also tried BIOS-disabling 
DMA and 32-bit disk acces. Also tried the beforementioned linux 
hdc=noidedma. Tried as well linux hdparm -i /tmp/cdrom at the prompt, 
but I keep getting into the same place: anaconda won't find the CD 
it's booting from.
So, anything I can do to provide parameters, I will.
Problem behavior is exactly as Eric described. Just with the new 
version of the core.
Comment 9 Dave Jones 2005-04-16 01:33:12 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.