Bug 1257193 - protocol server : Pending - porting log messages to a new framework
protocol server : Pending - porting log messages to a new framework
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: logging (Show other bugs)
3.7.3
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Manikandan
:
Depends On: 1242269 1252808
Blocks: 1241957
  Show dependency treegraph
 
Reported: 2015-08-26 08:54 EDT by Manikandan
Modified: 2016-09-20 00:28 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1252808
Environment:
Last Closed: 2015-09-09 05:40:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manikandan 2015-08-26 08:54:44 EDT
+++ This bug was initially created as a clone of Bug #1252808 +++

+++ This bug was initially created as a clone of Bug #1242269 +++

Description of problem:
-----------------------
There are few instances of gf_log and gf_log_callingfn seen under protocol server component under the code base.
These needs to be ported in to new logging framework

Version-Release number of selected component (if applicable):
--------------------------------------------------------------
RHGS 3.1 Nightly build ( glusterfs-3.7.1-8.el6rhs )


Additional info:
----------------
Here are the instances of gf_log :
[satheesaran@dhcppc1 server]$ grep -r "gf_log " * -A1
src/server-rpc-fops.c:  gf_log (this->name, GF_LOG_INFO,
src/server-rpc-fops.c-         "%"PRId64": IPC%"PRId64" (%s) ==> (%s)",
--
src/server.c:  gf_log (this->name, GF_LOG_WARNING,
src/server.c-       "Received invalid upcall event(%d)",
--
src/server.c:  gf_log (this->name, GF_LOG_ERROR,
src/server.c-       "server_process_event_upcall failed");

Here are the instances of gf_log_callingfn:
[satheesaran@dhcppc1 server]$ grep -r "gf_log_callingfn " * -A1
src/server.c:                        gf_log_callingfn (THIS->name, GF_LOG_ERROR,
src/server.c-                                          "Failed to get iobuf");
--
src/server.c:                        gf_log_callingfn ("", GF_LOG_ERROR, "Failed to encode message");
src/server.c-                        req->rpc_err = GARBAGE_ARGS;
--
src/server.c:                gf_log_callingfn ("", GF_LOG_ERROR, "Reply submission failed");
src/server.c-                if (frame && client && !lk_heal) {
--
src/server.c:                        gf_log_callingfn ("", GF_LOG_ERROR,
src/server.c-                                          "Reply submission failed");
--
src/server.c:                gf_log_callingfn ("server", GF_LOG_WARNING,
src/server.c-                                  "Calling rpc_notify without initializing");
--
src/server.c:                gf_log_callingfn (this->name, GF_LOG_DEBUG, "conf == null!!!");
src/server.c-                goto out;

--- Additional comment from Anand Avati on 2015-08-13 07:02:38 EDT ---

REVIEW: http://review.gluster.org/11895 (protocol/server : porting missing gf_log's to gf_msg) posted (#3) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Anand Avati on 2015-08-17 07:07:32 EDT ---

REVIEW: http://review.gluster.org/11895 (protocol/server : porting missing gf_log's to gf_msg) posted (#4) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Anand Avati on 2015-08-20 03:01:36 EDT ---

REVIEW: http://review.gluster.org/11895 (protocol/server : porting missing gf_log's to gf_msg) posted (#6) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Anand Avati on 2015-08-24 03:29:45 EDT ---

REVIEW: http://review.gluster.org/11895 (protocol/server : porting missing gf_log's to gf_msg) posted (#7) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Anand Avati on 2015-08-26 07:11:13 EDT ---

REVIEW: http://review.gluster.org/11895 (protocol/server : porting missing gf_log's to gf_msg) posted (#8) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Anand Avati on 2015-08-26 08:08:27 EDT ---

COMMIT: http://review.gluster.org/11895 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit a26dbb38acdb2ec5fe16068caee189709faae76e
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Wed Aug 12 15:29:31 2015 +0530

    protocol/server : porting missing gf_log's to gf_msg
    
    Change-Id: I8818931fafea3c013551a5de23a9f77c81164841
    BUG: 1252808
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/11895
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 1 Anand Avati 2015-08-26 09:10:45 EDT
REVIEW: http://review.gluster.org/12018 (protocol/server : porting missing gf_log's to gf_msg) posted (#1) for review on release-3.7 by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 2 Anand Avati 2015-08-26 09:17:51 EDT
REVIEW: http://review.gluster.org/12018 (protocol/server : porting missing gf_log's to gf_msg) posted (#2) for review on release-3.7 by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 3 Anand Avati 2015-08-31 05:45:32 EDT
COMMIT: http://review.gluster.org/12018 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit 713f59cc197d86c5048e5cab2d3d3ae502634ed7
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Wed Aug 12 15:29:31 2015 +0530

    protocol/server : porting missing gf_log's to gf_msg
    
            Backport of http://review.gluster.org/#/c/11895/
    
    Cherry-picked form commit a26dbb38acdb2ec5fe16068caee189709faae76e
    > Change-Id: I8818931fafea3c013551a5de23a9f77c81164841
    > BUG: 1252808
    > Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    > Reviewed-on: http://review.gluster.org/11895
    > Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    
    Change-Id: I8818931fafea3c013551a5de23a9f77c81164841
    BUG: 1257193
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/12018
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 4 Kaushal 2015-09-09 05:40:44 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.