Bug 1257209 - With quota enabled, when files are created and deleted from mountpoint, error messages are seen in brick logs
With quota enabled, when files are created and deleted from mountpoint, error...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: quota (Show other bugs)
3.1
x86_64 Linux
unspecified Severity high
: ---
: RHGS 3.1.2
Assigned To: Vijaikumar Mallikarjuna
storage-qa-internal@redhat.com
: ZStream
Depends On: 1257694 1279331
Blocks: 1260783
  Show dependency treegraph
 
Reported: 2015-08-26 09:53 EDT by SATHEESARAN
Modified: 2016-09-17 08:39 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 00:34:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description SATHEESARAN 2015-08-26 09:53:56 EDT
Description of problem:
-----------------------
With quota enabled, when files are created and deleted immediately from mountpoint,
error messages are seen in brick logs

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
glusterfs-3.7.1-12.el7rhgs

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. Create a plain distribute volume and start it
2. Enable quota on the volume
3. Mount the volume
4. Continuously create and delete files on the mount point

Actual results:
---------------
Error messages are seen in brick logs as follows,

<snip>

[2015-08-26 19:06:37.813341] E [MSGID: 113001] [posix.c:4645:posix_removexattr] 0-dvol-posix: removexattr on /rhs/brick1/b1/.glusterfs/5b/5a/5b5a9ceb-2c51-4bbe-94d7-07242dc3c5d9 (for trusted.glusterfs.quota.00000000-0000-0000-0000-000000000001.contri) [No such file or directory]

</snip>

Expected results:
-----------------
There shouldn't be any error messages

Additional info:
----------------
Error messages are occuring continuously

<snip>

[2015-08-26 19:06:37.819673] E [MSGID: 113001] [posix.c:4645:posix_removexattr] 0-dvol-posix: removexattr on /rhs/brick1/b1/.glusterfs/ae/20/ae207bdd-3167-44dc-ba16-6960dca078d9 (for trusted.glusterfs.quota.00000000-0000-0000-0000-000000000001.contri) [No such file or directory]
[2015-08-26 19:06:37.825462] E [MSGID: 113001] [posix.c:4645:posix_removexattr] 0-dvol-posix: removexattr on /rhs/brick1/b1/.glusterfs/0f/ad/0fadd0ed-4c4d-4ee7-b5a9-42ebad44e9d4 (for trusted.glusterfs.quota.00000000-0000-0000-0000-000000000001.contri) [No such file or directory]
[2015-08-26 19:06:37.831519] E [MSGID: 113001] [posix.c:4645:posix_removexattr] 0-dvol-posix: removexattr on /rhs/brick1/b1/.glusterfs/4b/64/4b64ef87-eab4-4f14-9a3b-6264426063c2 (for trusted.glusterfs.quota.00000000-0000-0000-0000-000000000001.contri) [No such file or directory]
[2015-08-26 19:06:37.838156] E [MSGID: 113001] [posix.c:4645:posix_removexattr] 0-dvol-posix: removexattr on /rhs/brick1/b1/.glusterfs/f8/63/f8635b37-32c6-499e-8302-d833268152fc (for trusted.glusterfs.quota.00000000-0000-0000-0000-000000000001.contri) [No such file or directory]
[2015-08-26 19:06:37.843775] E [MSGID: 113001] [posix.c:4645:posix_removexattr] 0-dvol-posix: removexattr on /rhs/brick1/b1/.glusterfs/c3/c1/c3c1393c-1bc6-45cd-8999-0c10af1f6e1e (for trusted.glusterfs.quota.00000000-0000-0000-0000-000000000001.contri) [No such file or directory]
[2015-08-26 19:06:37.848696] E [MSGID: 113001] [posix.c:4645:posix_removexattr] 0-dvol-posix: removexattr on /rhs/brick1/b1/.glusterfs/d0/84/d08498bd-cab6-4df4-8bf8-eff567512fae (for trusted.glusterfs.quota.00000000-0000-0000-0000-000000000001.contri) [No such file or directory]

</snip>
Comment 2 Vijaikumar Mallikarjuna 2015-09-01 05:09:00 EDT
Patch submitted upstream: http://review.gluster.org/#/c/12033/
Comment 5 Vijaikumar Mallikarjuna 2015-10-19 04:31:41 EDT
Upstream patch: http://review.gluster.org/#/c/12033/
Comment 6 Vijaikumar Mallikarjuna 2015-11-09 03:23:18 EST
upstream patch: http://review.gluster.org/#/c/12033/
release-3.7 patch: http://review.gluster.org/#/c/12549/
downstream patch: https://code.engineering.redhat.com/gerrit/61041
Comment 7 Anil Shah 2015-11-12 11:00:14 EST
Bugs verified on build glusterfs-3.7.5-6.el7rhgs.x86_64
Comment 9 errata-xmlrpc 2016-03-01 00:34:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.