Bug 1257694 - quota: removexattr on /d/backends/patchy/.glusterfs/79/99/799929ec-f546-4bbf-8549-801b79623262 (for trusted.glusterfs.quota.add7e3f8-833b-48ec-8a03-f7cd09925468.contri) [No such file or directory]
quota: removexattr on /d/backends/patchy/.glusterfs/79/99/799929ec-f546-4bbf-...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Manikandan
:
Depends On:
Blocks: 1257209 1279331
  Show dependency treegraph
 
Reported: 2015-08-27 12:59 EDT by Vijaikumar Mallikarjuna
Modified: 2016-06-16 09:33 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1279331 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:33:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaikumar Mallikarjuna 2015-08-27 12:59:43 EDT
When quota is enabled, below error message seen in brick log with rmdir, unlink and rename operations

[2015-08-27 16:07:49.347682] E [MSGID: 113001] [posix.c:4666:posix_removexattr] 0-patchy-posix: removexattr on /d/backends/patchy/.glusterfs/15/f2/15f21cb3-ef79-4e40-81b3-2a36a9ff1240 (for trusted.glusterfs.quota.934efbbf-20c0-4d6f-afcb-dba832cfa1f0.contri) [No such file or directory]
Comment 1 Anand Avati 2015-08-27 13:04:42 EDT
REVIEW: http://review.gluster.org/12033 (marker: do remove xattr only for last link) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Anand Avati 2015-08-30 23:38:19 EDT
REVIEW: http://review.gluster.org/12033 (marker: do remove xattr only for last link) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 3 Vijay Bellur 2015-11-02 05:30:28 EST
REVIEW: http://review.gluster.org/12033 (marker: do remove xattr only for last link) posted (#4) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 4 Vijay Bellur 2015-11-02 22:15:03 EST
REVIEW: http://review.gluster.org/12033 (marker: do remove xattr only for last link) posted (#5) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 5 Vijay Bellur 2015-11-16 05:27:21 EST
REVIEW: http://review.gluster.org/12584 (marker : handle variable `ret` properly in marker_unlink_cbk) posted (#1) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 6 Vijay Bellur 2015-11-16 08:09:05 EST
REVIEW: http://review.gluster.org/12584 (marker : handle variable `ret` properly in marker_unlink_cbk) posted (#2) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 7 Vijay Bellur 2015-11-17 05:08:04 EST
COMMIT: http://review.gluster.org/12584 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit eada31c88f929768df5fa337137b2ffcd57f2e73
Author: jiffin tony thottan <jthottan@redhat.com>
Date:   Mon Nov 16 15:51:01 2015 +0530

    marker : handle variable `ret` properly in marker_unlink_cbk
    
    While compiling new source, the following issue got hit :
    marker.c: In function 'marker_unlink_cbk':
    marker.c:994:29: warning: variable 'ret' set but not used
             int32_t             ret     = 0;
    This patch will fix the same.
    
    Change-Id: I0de60bed3351b3aa1cc80f52d178e447826210e7
    BUG: 1257694
    Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    Reviewed-on: http://review.gluster.org/12584
    Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 10 Niels de Vos 2016-06-16 09:33:45 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.