Bug 1279331 - quota: removexattr on /d/backends/patchy/.glusterfs/79/99/799929ec-f546-4bbf-8549-801b79623262 (for trusted.glusterfs.quota.add7e3f8-833b-48ec-8a03-f7cd09925468.contri) [No such file or directory]
quota: removexattr on /d/backends/patchy/.glusterfs/79/99/799929ec-f546-4bbf-...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
3.7.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vijaikumar Mallikarjuna
:
Depends On: 1257694
Blocks: 1257209
  Show dependency treegraph
 
Reported: 2015-11-09 03:17 EST by Vijaikumar Mallikarjuna
Modified: 2016-05-11 18:47 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1257694
Environment:
Last Closed: 2016-04-19 03:41:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaikumar Mallikarjuna 2015-11-09 03:17:45 EST
+++ This bug was initially created as a clone of Bug #1257694 +++

When quota is enabled, below error message seen in brick log with rmdir, unlink and rename operations

[2015-08-27 16:07:49.347682] E [MSGID: 113001] [posix.c:4666:posix_removexattr] 0-patchy-posix: removexattr on /d/backends/patchy/.glusterfs/15/f2/15f21cb3-ef79-4e40-81b3-2a36a9ff1240 (for trusted.glusterfs.quota.934efbbf-20c0-4d6f-afcb-dba832cfa1f0.contri) [No such file or directory]

--- Additional comment from Anand Avati on 2015-08-27 13:04:42 EDT ---

REVIEW: http://review.gluster.org/12033 (marker: do remove xattr only for last link) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Anand Avati on 2015-08-30 23:38:19 EDT ---

REVIEW: http://review.gluster.org/12033 (marker: do remove xattr only for last link) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-02 05:30:28 EST ---

REVIEW: http://review.gluster.org/12033 (marker: do remove xattr only for last link) posted (#4) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-02 22:15:03 EST ---

REVIEW: http://review.gluster.org/12033 (marker: do remove xattr only for last link) posted (#5) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 1 Vijaikumar Mallikarjuna 2015-11-09 03:18:47 EST
Patch submitted: http://review.gluster.org/12549
Comment 2 Vijay Bellur 2015-11-17 05:13:41 EST
REVIEW: http://review.gluster.org/12596 (marker : handle variable `ret` properly in marker_unlink_cbk) posted (#1) for review on release-3.7 by jiffin tony Thottan (jthottan@redhat.com)
Comment 3 Vijay Bellur 2016-02-01 23:59:19 EST
REVIEW: http://review.gluster.org/12596 (marker : handle variable `ret` properly in marker_unlink_cbk) posted (#2) for review on release-3.7 by jiffin tony Thottan (jthottan@redhat.com)
Comment 4 Vijay Bellur 2016-02-03 00:20:14 EST
COMMIT: http://review.gluster.org/12596 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit 8d4c9532086222bfbb7a6d48f9f9c01e58b4dcf3
Author: jiffin tony thottan <jthottan@redhat.com>
Date:   Mon Nov 16 15:51:01 2015 +0530

    marker : handle variable `ret` properly in marker_unlink_cbk
    
    Backport of http://review.gluster.org/#/c/12584/
    
    While compiling new source, the following issue got hit :
    marker.c: In function 'marker_unlink_cbk':
    marker.c:994:29: warning: variable 'ret' set but not used
             int32_t             ret     = 0;
    This patch will fix the same.
    
    Upstream reference :
    cherry picked from commit eada31c88f929768df5fa337137b2ffcd57f2e73
    >Change-Id: I0de60bed3351b3aa1cc80f52d178e447826210e7
    >BUG: 1257694
    >Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    >Reviewed-on: http://review.gluster.org/12584
    >Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    
    Change-Id: Ia8f87131e90599cad018cd31269de68049a2ade9
    BUG: 1279331
    Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    Reviewed-on: http://review.gluster.org/12596
    Reviewed-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 5 Kaushal 2016-04-19 03:41:21 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.8, please open a new bug report.

glusterfs-3.7.8 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 6 Kaushal 2016-04-19 03:47:50 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.