Bug 125745 - freetype 2.1.9 is released
freetype 2.1.9 is released
Product: Fedora
Classification: Fedora
Component: freetype (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
Brock Organ
Depends On:
Blocks: 125755
  Show dependency treegraph
Reported: 2004-06-10 15:41 EDT by Robert Scheck
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-08-04 16:51:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
freetype-2.1.7-ac257.patch (1.10 KB, patch)
2004-06-10 15:42 EDT, Robert Scheck
no flags Details | Diff
freetype-2.1.9-math.patch (705 bytes, patch)
2004-07-13 09:37 EDT, Robert Scheck
no flags Details | Diff

  None (edit)
Description Robert Scheck 2004-06-10 15:41:32 EDT
Description of problem:
freetype 2.1.8 was released at April 20, 2004 and Fedora Development
is hanging around the older 2.1.7. For more information have a look
to the changelog.

Version-Release number of selected component (if applicable):

Actual results:
Here's the diff of that, what I did to make it working for me:

--- snipp ---
--- freetype.spec       2004-04-19 16:59:43.000000000 +0200
+++ freetype.spec.rsc   2004-06-10 21:39:12.000000000 +0200
@@ -10,27 +10,25 @@

 Summary: A free and portable TrueType font rendering engine.
 Name: freetype
-Version: 2.1.7
-Release: 4
+Version: 2.1.8
+Release: 1
 License: BSD/GPL dual license
 Group: System Environment/Libraries
 URL: http://www.freetype.org
-Source:  freetype-%{version}.tar.bz2
-Source1: ftdocs-%{version}.tar.bz2
-Source2: ft2demos-%{version}.tar.bz2
+Source:  http://osdn.dl.sourceforge.net/sourceforge/%{name}/%{name}-%{version}.tar.bz2
+Source1: http://osdn.dl.sourceforge.net/sourceforge/%{name}/ftdocs-%{version}.tar.bz2
+Source2: http://osdn.dl.sourceforge.net/sourceforge/%{name}/ft2demos-%{version}.tar.bz2
 Source3: %{ft1}.tar.bz2

 # Fix build of freetype-1.4 with gcc 3.3
 Patch3: freetype-1.4-ac25.patch
 Patch4: freetype-1.4-gcc33.patch
-# Patch from freetype CVS to fix handling of eexec
-# https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=117743
-Patch5:  freetype-2.1.7-eexec.patch
 Patch20:  freetype-2.1.3-enable-ft2-bci.patch
 Patch21:  freetype-1.4-disable-ft1-bci.patch
+Patch22:  freetype-2.1.7-ac257.patch

 Buildroot: %{_tmppath}/%{name}-%{version}-root
-BuildRequires: automake14 autoconf >= 2.59 libtool symlinks zlib-devel
+BuildRequires: automake autoconf libtool symlinks zlib-devel

 The FreeType engine is a free and portable TrueType font rendering
@@ -103,18 +101,18 @@
 %patch20  -p0 -b .enable-ft2-bci

-%patch5 -p1 -b .eexec
+%patch22 -p1 -b .ac257

 # Need to update libtool to get deplibs right for x86_64
 pushd builds/unix
 libtoolize --force

 pushd %{ft1}
 libtoolize --force

@@ -262,6 +260,10 @@

+* Thu Jun 10 2004 Robert Scheck <redhat@linuxnetz.de> 2.1.8-1
+- Added a patch for using autoconf >= 2.57 and don't use automake14
+- Upgrade to 2.1.8
 * Mon Apr 19 2004 Owen Taylor <otaylor@redhat.com> 2.1.7-4
 - Add patch from freetype CVS to fix problem with eexec (#117743)
 - Add freetype-devel to buildrequires and -devel requires
--- snapp ---

Expected results:
Upgrade to 2.1.8 ;-)

Additional info:
The patch "ac257" is for better compatibility with autoconf < 2.59,
it shouldn't conflict any autoconf version, but gives better backward
support (I still love backward compatibility) ;-)

The second thing is, that the old and obsoleted automake14 isn't 
really needed. So I still didn't test a rebuild using automake-1.8.x 
which is the current Fedora Development status, but automake-1.7.x 
worked very well for a rebuild. So please please test, whether 
rebuilding with automake 1.8.x works, otherwise use 1.7.x (and require it explicit), but please don't use automake14...thank you 
very much :)
Comment 1 Robert Scheck 2004-06-10 15:42:43 EDT
Created attachment 101044 [details]
Comment 2 John Thacker 2004-07-12 14:57:29 EDT
Freetype 2.1.9 was released June 23rd.
Comment 3 Robert Scheck 2004-07-13 09:00:34 EDT
Thank you, John. While the upgrade from 2.1.8 to 2.1.9 worked fine, 
2.1.9 dies at building of ft2demos with "undefined reference to `pow'",
so maybe we should fix that - I'll try to trigger that out, if I've got 
time ;-)

As you can read in changelog of 2.1.8 and 2.1.9 contain bug fixes 
marked as important.
Comment 4 Robert Scheck 2004-07-13 09:37:35 EDT
Created attachment 101860 [details]

Well, this (nasty) patch solved the problem for me ;-)
Comment 5 Owen Taylor 2004-08-04 16:51:35 EDT
Didn't apply the ac257 patch, doesn't make sense to me to do work to 
support intermediately old versions of autoconf.

* Wed Aug  4 2004 Owen Taylor <otaylor@redhat.com> - 2.1.9-1
- Upgrade to 2.1.9
- Since we are just using automake for aclocal, use it unversioned,
  instead of specifying 1.4.

I did the -lm fix for ft2demos a little differently  (patched
GRAPH_LIB in graph/x11/rules.mk) then sent what I did to 

Note You need to log in before you can comment on or make changes to this bug.