Bug 1257637 - Empty f23-branch in Zanata
Summary: Empty f23-branch in Zanata
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Samantha N. Bueno
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
: 1257795 1259894 (view as bug list)
Depends On:
Blocks: F23FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2015-08-27 13:57 UTC by Piotr Drąg
Modified: 2015-09-16 18:36 UTC (History)
12 users (show)

Fixed In Version: 23.19.4-1.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-16 18:36:00 UTC


Attachments (Terms of Use)

Description Piotr Drąg 2015-08-27 13:57:32 UTC
https://fedora.zanata.org/iteration/view/anaconda/f23-branch should have translations migrated from master, so translators don't have to do it by themselves. Now most translations are missing, so almost every Fedora installation is untranslated.

Violates https://fedoraproject.org/wiki/Fedora_23_Final_Release_Criteria#Installer_translations

Comment 1 Samantha N. Bueno 2015-08-27 14:02:26 UTC
Hm, sorry about that. I'll try fixing this before I do a new build today. I haven't been having a pleasant experience using Zanata at all, so I'm not surprised that I messed something up.

Comment 2 David Shea 2015-08-28 13:19:51 UTC
*** Bug 1257795 has been marked as a duplicate of this bug. ***

Comment 3 Samantha N. Bueno 2015-08-28 15:27:50 UTC
Just as an FYI....
When the source file was uploaded, "po/" was specified as the file path, when it should have been empty, as in the other branches. Translations are actually present on the Zanata server itself, but the source file needs to be bumped up one level.

Unfortunately this is not something that I can change in Zanata, but I've contacted someone who works with Zanata to see if they can help.

(And yes, "copy to new version" from master should have been done, but the UI was very non-responsive that day, so I did this partially by way of the command line client, which is why things got a bit messed up. So, apologies for that, and I hope this can be fixed soon.)

Comment 4 Adam Williamson 2015-08-31 16:45:13 UTC
Discussed at 2015-08-31 blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-08-31/f23-blocker-review.2015-08-31-16.01.log.txt . Accepted as a blocker per criterion cited in description.

Comment 5 David Shea 2015-09-03 18:20:53 UTC
*** Bug 1259894 has been marked as a duplicate of this bug. ***

Comment 6 Samantha N. Bueno 2015-09-03 19:36:14 UTC
Note, I still have not been able to fix this and am still discussing it with the Zanata folks. But I believe I've been able to employ a (temporary) workaround that should enable translations to appear. So please let me know if translations are available in the next build of anaconda (anaconda-23.19.2-1).

Update is here, so it should show up in the next compose:
https://bodhi.fedoraproject.org/updates/FEDORA-2015-15030

Comment 7 Piotr Drąg 2015-09-04 00:39:32 UTC
I don't know if it's intentional or not, but translation on https://fedora.zanata.org/iteration/view/anaconda/f23-branch disappeared again.

Comment 8 Samantha N. Bueno 2015-09-04 10:47:05 UTC
(In reply to Piotr Drąg from comment #7)
> I don't know if it's intentional or not, but translation on
> https://fedora.zanata.org/iteration/view/anaconda/f23-branch disappeared
> again.

No that was not intentional, but it doesn't surprise me given the workaround I had to employ. It should be restored now.

Comment 9 Samantha N. Bueno 2015-09-10 20:20:31 UTC
The zanata team has been non-responsive to my missives for help, and so I have no good way to well and truly fix this.

Therefore, I am going to just continue using the workaround like I did for the prior build of anaconda.

I'm going to consider this bug officially closed with the next build of anaconda then. Please contact me/re-open this bug if this becomes a problem again, and when f24 comes around I'll be sure to branch properly so this doesn't happen anymore.

Comment 10 Fedora Update System 2015-09-10 20:27:52 UTC
python-blivet-1.12.3-1.fc23 anaconda-23.19.3-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15562

Comment 11 Fedora Update System 2015-09-11 03:49:15 UTC
anaconda-23.19.3-1.fc23, python-blivet-1.12.3-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update anaconda python-blivet'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15562

Comment 12 Fedora Update System 2015-09-14 17:22:00 UTC
python-blivet-1.12.4-1.fc23 anaconda-23.19.4-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15846

Comment 13 Carlos Munoz 2015-09-14 22:22:04 UTC
Hi Samantha, I've just been CC'd on this bug and will be able to provide some help with your Zanata woes. From what I understand, you simply want to remove the po/ directory in front of your resources for the f23-branch. Would that be correct?

Also, I was wondering what mechanism you used to contact the Zanata team, as it worries me that your calls for help have not been heard, and want to make sure it doesn't happen again.

Comment 14 Samantha N. Bueno 2015-09-15 12:54:07 UTC
(In reply to Carlos Munoz from comment #13)
> Hi Samantha, I've just been CC'd on this bug and will be able to provide
> some help with your Zanata woes. From what I understand, you simply want to
> remove the po/ directory in front of your resources for the f23-branch.
> Would that be correct?

Yes, that's all I want; as long as it is also possible to preserve existing translations for that branch.

> Also, I was wondering what mechanism you used to contact the Zanata team, as
> it worries me that your calls for help have not been heard, and want to make
> sure it doesn't happen again.

I contacted the only person I knew who could help; someone who works in the BNE office on the localization team. She forwarded my email to the zanata-users list. I received one response....I tried their suggestion, which didn't work, so I responded and gave more details about what else I'd tried (various incantations with the python client). I never heard anything after that.

Though, now that I look at the list archives, I see that my response is somehow not there. That probably explains why I never heard anything further, so I apologize for sounding critical earlier. :-/

Comment 15 Fedora Update System 2015-09-15 16:50:51 UTC
anaconda-23.19.4-1.fc23, python-blivet-1.12.4-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update anaconda python-blivet'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15846

Comment 16 Fedora Update System 2015-09-16 18:35:45 UTC
anaconda-23.19.4-1.fc23, python-blivet-1.12.4-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.