Bug 1257679 - Owncloud client segfaults since update to qt5-5.5.0
Owncloud client segfaults since update to qt5-5.5.0
Status: CLOSED DUPLICATE of bug 1255902
Product: Fedora
Classification: Fedora
Component: qt5-qtbase (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-27 12:14 EDT by info@kobaltwit.be
Modified: 2015-09-03 09:11 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-03 09:11:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb backtrace of crash (3.11 KB, text/plain)
2015-08-27 12:14 EDT, info@kobaltwit.be
no flags Details

  None (edit)
Description info@kobaltwit.be 2015-08-27 12:14:34 EDT
Created attachment 1067828 [details]
gdb backtrace of crash

Description of problem:
A couple of days ago an update to qt5 5.5.0 was pushed to the Fedora update repositories. Since I have installed that update owncloud-client segfaults during startup.

Version-Release number of selected component (if applicable):
qt5-qtbase-5.5.0-15.fc22.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install qt5 5.5.0
2. Install owncloud-client from isv:ownCloud:desktop.repo repository 
3. Launch the owncloud-client

Actual results:
Immediate segfault

Expected results:
Client working fine

Additional info:
I am aware that the owncloud-client is not from the Fedora repositories. So I have first reported this bug upstream int the owncloud client's bug tracker [1]. I was asked there to report this in Fedora as well, because OpenSUSE doesn't have this crash even though they also work with qt5-5.5.0.

At the time I updated to qt5 I was still running owncloud-client 1.8.4. Meanwhile version 2.0 has been released. I also tested that version and it also results in the same crash.

I have uploaded my crash report to the ABRT server [2] if that's helpful. Abrt didn't want to create a bug report in bugzilla (likely because oc-client is not a fedora managed package).

I'll also attach the backtrace I got from running the owncloud client under gdb (with debug packages installed).

If you need any more information, please let me know.

[1] https://github.com/owncloud/client/issues/3679
[2] https://github.com/owncloud/client/issues/3679
Comment 1 Fahad Alduraibi 2015-08-28 16:43:38 EDT
I am having the same problem on my two machines, and here is another link to a different bug report with more details:
https://github.com/owncloud/client/issues/3672

I would love to help whoever need more info or test some patches, since I want this fixed fast. I depend on ownCloud to sync my work files between my machines and it has been over a week now since this problem started.
Comment 2 Robert Susmilch 2015-08-29 12:03:57 EDT
I also have this issue, including the latest git 2.0 branch of owncloud with the "potential workaround" for the context menu fix (which did NOT work for me, still segfaulted.)

Upon downgrading qt5-qtbase with --allowerasing, owncloud magically started working again, so it is clearly one of the packages related in the downgrade.

https://bugreports.qt.io/browse/QTBUG-47863
https://github.com/owncloud/client/issues/3656
Comment 3 Andy F 2015-08-31 00:32:24 EDT
Also seeing this exact issue, and downgrading Qt to 5.4.1-15 removes the issue.

Same issue also applies to seafile-qt (third party).
Comment 4 Andy F 2015-09-02 05:47:24 EDT
After installing "vanilla" Qt from http://www.qt.io/download-open-source/

and executing

LD_LIBRARY_PATH=~/Qt/5.5/gcc_64/lib bin/owncloud

there is no crash.

This leads me to believe the problem may be in Fedora tweaks to the standard packaging.
Comment 5 info@kobaltwit.be 2015-09-03 05:22:12 EDT
This may be a duplicate of bug 1255902.

Owncloud client bug 3656 mentioned the same issue as cause earlier today.
Comment 6 Rex Dieter 2015-09-03 08:10:00 EDT
I'll mark it as depending on bug #1255902 for now

Anyone able to test if kf5-frameworkintegration-5.13.0-2.fc22 fixes the issue or not?
Comment 7 info@kobaltwit.be 2015-09-03 08:16:48 EDT
I'm willing to test this. Is there an easy way to get the packages installed straight out of bodhi or koji ?
Comment 8 Rex Dieter 2015-09-03 08:33:23 EDT
Was recently been added to
https://bodhi.fedoraproject.org/updates/FEDORA-2015-14272
but not pushed to -testing repo yet.

Direct koji link,
http://koji.fedoraproject.org/koji/buildinfo?buildID=680287
Comment 9 info@kobaltwit.be 2015-09-03 08:36:24 EDT
I apologize for not making myself clear enough. I did find both links myself. However the bodhi page lists 20+ packages. kf5-frameworkintegration can't be installed on its own, it requires several other packages.

So I was hoping there would be a simple command to install all of them instead of manually composing a
dnf install url1 url2 url3 ...
Comment 10 Rex Dieter 2015-09-03 08:42:32 EDT
dnf --enablerepo=updates-testing kf5-*
should work
Comment 11 Rex Dieter 2015-09-03 08:44:45 EDT
sorry, that's incomplete, once you've done *that*, then you can manually update kf5-frameworkintegration via the koji link
Comment 12 info@kobaltwit.be 2015-09-03 09:00:28 EDT
Thanks.

I have just installed the updates and rebooted and can confirm the owncloud client works fine with the updated kf5-frameworkintegration. No more segfault at startup for me.
Comment 13 Rex Dieter 2015-09-03 09:11:38 EDT
Thanks!

Let's mark it as a dup then

*** This bug has been marked as a duplicate of bug 1255902 ***

Note You need to log in before you can comment on or make changes to this bug.