Bug 1258131 - [abrt] marco: split_edge(): marco killed by SIGABRT
[abrt] marco: split_edge(): marco killed by SIGABRT
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: marco (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Wolfgang Ulbrich
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:4e1d1d579a385d1f05fe3369201...
:
: 1167084 1260804 1270463 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-29 08:25 EDT by Wolfgang Ulbrich
Modified: 2015-11-05 18:24 EST (History)
6 users (show)

See Also:
Fixed In Version: marco-1.10.3-1.fc23 marco-1.10.3-1.fc21 marco-1.10.3-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-31 22:27:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (35.89 KB, text/plain)
2015-08-29 08:25 EDT, Wolfgang Ulbrich
no flags Details
File: cgroup (190 bytes, text/plain)
2015-08-29 08:25 EDT, Wolfgang Ulbrich
no flags Details
File: core_backtrace (5.74 KB, text/plain)
2015-08-29 08:25 EDT, Wolfgang Ulbrich
no flags Details
File: dso_list (9.56 KB, text/plain)
2015-08-29 08:25 EDT, Wolfgang Ulbrich
no flags Details
File: environ (1.26 KB, text/plain)
2015-08-29 08:25 EDT, Wolfgang Ulbrich
no flags Details
File: limits (1.29 KB, text/plain)
2015-08-29 08:25 EDT, Wolfgang Ulbrich
no flags Details
File: maps (48.19 KB, text/plain)
2015-08-29 08:25 EDT, Wolfgang Ulbrich
no flags Details
File: mountinfo (3.21 KB, text/plain)
2015-08-29 08:25 EDT, Wolfgang Ulbrich
no flags Details
File: namespaces (85 bytes, text/plain)
2015-08-29 08:25 EDT, Wolfgang Ulbrich
no flags Details
File: open_fds (764 bytes, text/plain)
2015-08-29 08:25 EDT, Wolfgang Ulbrich
no flags Details
File: proc_pid_status (1002 bytes, text/plain)
2015-08-29 08:25 EDT, Wolfgang Ulbrich
no flags Details
File: var_log_messages (239 bytes, text/plain)
2015-08-29 08:25 EDT, Wolfgang Ulbrich
no flags Details

  None (edit)
Description Wolfgang Ulbrich 2015-08-29 08:25:01 EDT
Description of problem:
Trying to drag/move a window

Version-Release number of selected component:
marco-1.10.2-1.fc23

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        marco
crash_function: split_edge
executable:     /usr/bin/marco
global_pid:     1381
kernel:         4.2.0-0.rc8.git0.1.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #4 split_edge at core/boxes.c:1569
 #5 meta_rectangle_remove_intersections_with_boxes_from_edges at core/boxes.c:1691
 #6 compute_resistance_and_snapping_edges at core/edge-resistance.c:1089
 #7 apply_edge_resistance_to_each_side at core/edge-resistance.c:556
 #8 meta_window_edge_resistance_for_move at core/edge-resistance.c:1172
 #9 update_move at core/window.c:7182
 #10 meta_window_handle_mouse_grab_op_event at core/window.c:7654
 #11 event_callback at core/display.c:2084
 #12 filter_func at ui/ui.c:289
 #13 gdk_event_apply_filters at gdkevents-x11.c:371
Comment 1 Wolfgang Ulbrich 2015-08-29 08:25:04 EDT
Created attachment 1068275 [details]
File: backtrace
Comment 2 Wolfgang Ulbrich 2015-08-29 08:25:06 EDT
Created attachment 1068276 [details]
File: cgroup
Comment 3 Wolfgang Ulbrich 2015-08-29 08:25:07 EDT
Created attachment 1068277 [details]
File: core_backtrace
Comment 4 Wolfgang Ulbrich 2015-08-29 08:25:08 EDT
Created attachment 1068278 [details]
File: dso_list
Comment 5 Wolfgang Ulbrich 2015-08-29 08:25:09 EDT
Created attachment 1068279 [details]
File: environ
Comment 6 Wolfgang Ulbrich 2015-08-29 08:25:10 EDT
Created attachment 1068280 [details]
File: limits
Comment 7 Wolfgang Ulbrich 2015-08-29 08:25:12 EDT
Created attachment 1068281 [details]
File: maps
Comment 8 Wolfgang Ulbrich 2015-08-29 08:25:13 EDT
Created attachment 1068282 [details]
File: mountinfo
Comment 9 Wolfgang Ulbrich 2015-08-29 08:25:14 EDT
Created attachment 1068283 [details]
File: namespaces
Comment 10 Wolfgang Ulbrich 2015-08-29 08:25:16 EDT
Created attachment 1068284 [details]
File: open_fds
Comment 11 Wolfgang Ulbrich 2015-08-29 08:25:17 EDT
Created attachment 1068285 [details]
File: proc_pid_status
Comment 12 Wolfgang Ulbrich 2015-08-29 08:25:18 EDT
Created attachment 1068286 [details]
File: var_log_messages
Comment 13 Jeff Bastian 2015-09-24 14:19:08 EDT
Another user experienced a similar problem:

I just tried to resize my Firefox window and marco crashed.
Also, SELinux blocked abrt from fully working, see bug 1266194.

reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        marco
crash_function: split_edge
executable:     /usr/bin/marco
global_pid:     1885
kernel:         4.2.1-300.fc23.x86_64
package:        marco-1.10.2-1.fc23
reason:         marco killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 14 Wolfgang Ulbrich 2015-10-01 14:22:25 EDT
Another user experienced a similar problem:

try to move a window via drag at titlebar

reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        marco
crash_function: split_edge
executable:     /usr/bin/marco
global_pid:     1776
kernel:         4.2.1-300.fc23.x86_64
package:        marco-1.10.2-1.fc23
reason:         marco killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 15 Wolfgang Ulbrich 2015-10-22 09:20:57 EDT
*** Bug 1270463 has been marked as a duplicate of this bug. ***
Comment 16 Wolfgang Ulbrich 2015-10-23 14:10:37 EDT
*** Bug 1167084 has been marked as a duplicate of this bug. ***
Comment 17 Wolfgang Ulbrich 2015-10-23 14:11:46 EDT
*** Bug 1260804 has been marked as a duplicate of this bug. ***
Comment 18 Fedora Update System 2015-10-23 18:30:28 EDT
marco-1.10.2-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-ad1384765d
Comment 19 Fedora Update System 2015-10-23 18:31:30 EDT
marco-1.10.2-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-939e7a4a3e
Comment 20 Fedora Update System 2015-10-23 18:32:13 EDT
marco-1.10.2-2.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-b6d3911e05
Comment 21 Fedora Update System 2015-10-26 12:05:03 EDT
marco-1.10.3-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-2430b4d082
Comment 22 Fedora Update System 2015-10-26 12:07:23 EDT
marco-1.10.3-1.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-a3e86a546f
Comment 23 Fedora Update System 2015-10-26 12:09:37 EDT
marco-1.10.3-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-aaa54c9f45
Comment 24 Fedora Update System 2015-10-26 22:17:56 EDT
marco-1.10.3-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update marco'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-2430b4d082
Comment 25 Fedora Update System 2015-10-26 22:20:18 EDT
marco-1.10.2-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update marco'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-ad1384765d
Comment 26 Fedora Update System 2015-10-28 14:21:08 EDT
marco-1.10.3-1.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update marco'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-a3e86a546f
Comment 27 Fedora Update System 2015-10-28 14:22:17 EDT
marco-1.10.2-2.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update marco'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-b6d3911e05
Comment 28 Fedora Update System 2015-10-28 16:25:22 EDT
marco-1.10.3-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update marco'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-aaa54c9f45
Comment 29 Fedora Update System 2015-10-28 16:27:14 EDT
marco-1.10.2-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update marco'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-939e7a4a3e
Comment 30 Fedora Update System 2015-10-31 22:27:55 EDT
marco-1.10.3-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 31 Fedora Update System 2015-11-05 16:49:07 EST
marco-1.10.3-1.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.
Comment 32 Fedora Update System 2015-11-05 18:23:54 EST
marco-1.10.3-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.