Bug 1258594 - build: compile error on RHEL5
Summary: build: compile error on RHEL5
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: rpc
Version: 3.7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: manu@netbsd.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1258883 glusterfs-3.7.7 1282701
TreeView+ depends on / blocked
 
Reported: 2015-08-31 18:19 UTC by Kaleb KEITHLEY
Modified: 2016-04-19 07:46 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1258883 1282701 (view as bug list)
Environment:
Last Closed: 2016-04-19 07:46:47 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kaleb KEITHLEY 2015-08-31 18:19:21 UTC
Description of problem:

This change looks rather different from the change it is alleged to be a backport of on the master branch. I.e. #include <openssl/x509v3.h> versus #include <openssl/ecdh.h>


...
Making all in rpc-transport
Making all in socket
Making all in src
  CC     socket.lo
  CC     name.lo
In file included from name.c:23:
socket.h:22:26: error: openssl/ecdh.h: No such file or directory
In file included from socket.c:17:
socket.h:22:26: error: openssl/ecdh.h: No such file or directory
make[5]: *** [name.lo] Error 1
make[5]: *** Waiting for unfinished jobs....
In file included from socket.c:30:
../../../../rpc/xdr/src/glusterfs3-xdr.h:19: warning: ignoring #pragma GCC diagnostic
../../../../rpc/xdr/src/glusterfs3-xdr.h:20: warning: ignoring #pragma GCC diagnostic
socket.c:3990:2: error: #error Old and insecure OpenSSL, use -DUSE_INSECURE_OPENSSL to use it anyway
socket.c: In function 'socket_init':
socket.c:3999: error: 'SSL_OP_NO_TICKET' undeclared (first use in this function)
socket.c:3999: error: (Each undeclared identifier is reported only once
socket.c:3999: error: for each function it appears in.)
socket.c:4000: error: 'SSL_OP_NO_COMPRESSION' undeclared (first use in this function)
socket.c:4036: error: 'EC_KEY' undeclared (first use in this function)
socket.c:4036: error: 'ecdh' undeclared (first use in this function)
socket.c:4042: warning: implicit declaration of function 'EC_KEY_new_by_curve_name'
socket.c:4048: warning: implicit declaration of function 'EC_KEY_free'
make[5]: *** [socket.lo] Error 1
make[4]: *** [all-recursive] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.6603 (%build)

















Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Vijay Bellur 2015-11-17 07:10:53 UTC
REVIEW: http://review.gluster.org/12518 (build: fix ecdh.h and dh.h deps) posted (#3) for review on release-3.7 by Milind Changire (mchangir@redhat.com)

Comment 2 Vijay Bellur 2015-11-17 07:13:10 UTC
REVIEW: http://review.gluster.org/12518 (build: fix ecdh.h and dh.h deps) posted (#4) for review on release-3.7 by Milind Changire (mchangir@redhat.com)

Comment 3 Vijay Bellur 2015-11-17 09:11:44 UTC
REVIEW: http://review.gluster.org/12518 (build: fix ecdh.h and dh.h deps) posted (#5) for review on release-3.7 by Milind Changire (mchangir@redhat.com)

Comment 4 Vijay Bellur 2015-11-20 11:25:32 UTC
COMMIT: http://review.gluster.org/12518 committed in release-3.7 by Niels de Vos (ndevos@redhat.com) 
------
commit 21c7debd3fc2613e10d7ee81543dbd65b2b897fa
Author: Milind Changire <mchangir@redhat.com>
Date:   Thu Nov 5 20:08:33 2015 +0530

    build: fix ecdh.h and dh.h deps
    
    openssl/ecdh.h and openssl/dh.h are not available on all platforms,
    especially rhel-5.
    This patch adds check to autoconf and updates relevant source files.
    
    Added conditional to test for SSL_OP_NO_TICKET and SSL_OP_NO_COMPRESSION
    presence before setting the SSL context options.
    
    Macros UTIME_OMIT and UTIME_NOW picked up from Fedora 22
    /usr/include/bits/stat.h to help rhel-5 build.
    
    Change-Id: I2bdee4fe643f9c1f5fe77cf89bd30946cd6b591a
    Reviewed-on: http://review.gluster.org/#/c/12517/
    BUG: 1258594
    Signed-off-by: Milind Changire <mchangir@redhat.com>
    Reviewed-on: http://review.gluster.org/12518
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 5 Kaushal 2016-04-19 07:46:47 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.