Bug 1282701 - build: compile error on RHEL5
build: compile error on RHEL5
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: releng (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS 3.1.2
Assigned To: Milind Changire
Bhaskarakiran
: Triaged, ZStream
Depends On: 1258594
Blocks: 1258883 1260783
  Show dependency treegraph
 
Reported: 2015-11-17 02:32 EST by Milind Changire
Modified: 2016-11-23 18:12 EST (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1258594
Environment:
Last Closed: 2016-03-01 00:55:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0193 normal SHIPPED_LIVE Red Hat Gluster Storage 3.1 update 2 2016-03-01 05:20:36 EST

  None (edit)
Description Milind Changire 2015-11-17 02:32:54 EST
+++ This bug was initially created as a clone of Bug #1258594 +++

Description of problem:

This change looks rather different from the change it is alleged to be a backport of on the master branch. I.e. #include <openssl/x509v3.h> versus #include <openssl/ecdh.h>


...
Making all in rpc-transport
Making all in socket
Making all in src
  CC     socket.lo
  CC     name.lo
In file included from name.c:23:
socket.h:22:26: error: openssl/ecdh.h: No such file or directory
In file included from socket.c:17:
socket.h:22:26: error: openssl/ecdh.h: No such file or directory
make[5]: *** [name.lo] Error 1
make[5]: *** Waiting for unfinished jobs....
In file included from socket.c:30:
../../../../rpc/xdr/src/glusterfs3-xdr.h:19: warning: ignoring #pragma GCC diagnostic
../../../../rpc/xdr/src/glusterfs3-xdr.h:20: warning: ignoring #pragma GCC diagnostic
socket.c:3990:2: error: #error Old and insecure OpenSSL, use -DUSE_INSECURE_OPENSSL to use it anyway
socket.c: In function 'socket_init':
socket.c:3999: error: 'SSL_OP_NO_TICKET' undeclared (first use in this function)
socket.c:3999: error: (Each undeclared identifier is reported only once
socket.c:3999: error: for each function it appears in.)
socket.c:4000: error: 'SSL_OP_NO_COMPRESSION' undeclared (first use in this function)
socket.c:4036: error: 'EC_KEY' undeclared (first use in this function)
socket.c:4036: error: 'ecdh' undeclared (first use in this function)
socket.c:4042: warning: implicit declaration of function 'EC_KEY_new_by_curve_name'
socket.c:4048: warning: implicit declaration of function 'EC_KEY_free'
make[5]: *** [socket.lo] Error 1
make[4]: *** [all-recursive] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.6603 (%build)

















Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Vijay Bellur on 2015-11-17 02:10:53 EST ---

REVIEW: http://review.gluster.org/12518 (build: fix ecdh.h and dh.h deps) posted (#3) for review on release-3.7 by Milind Changire (mchangir@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-17 02:13:10 EST ---

REVIEW: http://review.gluster.org/12518 (build: fix ecdh.h and dh.h deps) posted (#4) for review on release-3.7 by Milind Changire (mchangir@redhat.com)
Comment 3 Milind Changire 2015-11-20 02:33:55 EST
Patch available at https://code.engineering.redhat.com/gerrit/61655
Comment 4 Bhaskarakiran 2015-11-25 06:24:42 EST
el5 client packages are available. Marking this as fixed.
Comment 6 errata-xmlrpc 2016-03-01 00:55:04 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.