Bug 1258883 - build: compile error on RHEL5
build: compile error on RHEL5
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: rpc (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: manu@netbsd.org
: Triaged
: 1279747 (view as bug list)
Depends On: 1258594 1282701
Blocks: 1279745
  Show dependency treegraph
 
Reported: 2015-09-01 08:59 EDT by Kaleb KEITHLEY
Modified: 2017-06-06 01:17 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1258594
Environment:
Last Closed: 2016-06-16 09:34:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaleb KEITHLEY 2015-09-01 08:59:15 EDT
HEAD of master branch also doesn't compile on RHEL5

...
Making all in rpc-transport
Making all in socket
Making all in src
mkdir .libs
 gcc -DHAVE_CONFIG_H -I. -I. -I../../../.. -I/usr/include/uuid -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -DGF_LINUX_HOST_OS -include ../../../../config.h -I../../../../libglusterfs/src -I../../../../libglusterfs/src -I../../../../rpc/rpc-lib/src/ -I../../../../rpc/xdr/src/ -Wall -g -O2 -g -O2 -MT socket.lo -MD -MP -MF .deps/socket.Tpo -c socket.c  -fPIC -DPIC -o .libs/socket.o
In file included from socket.c:25:
../../../../rpc/xdr/src/glusterfs3-xdr.h:19: warning: ignoring #pragma GCC diagnostic
../../../../rpc/xdr/src/glusterfs3-xdr.h:20: warning: ignoring #pragma GCC diagnostic
socket.c:3985:2: error: #error Old and insecure OpenSSL, use -DUSE_INSECURE_OPENSSL to use it anyway
socket.c: In function 'socket_init':
socket.c:3994: error: 'SSL_OP_NO_TICKET' undeclared (first use in this function)
socket.c:3994: error: (Each undeclared identifier is reported only once
socket.c:3994: error: for each function it appears in.)
socket.c:3995: error: 'SSL_OP_NO_COMPRESSION' undeclared (first use in this function)
socket.c:4031: error: 'EC_KEY' undeclared (first use in this function)
socket.c:4031: error: 'ecdh' undeclared (first use in this function)
socket.c:4037: warning: implicit declaration of function 'EC_KEY_new_by_curve_name'
socket.c:4043: warning: implicit declaration of function 'EC_KEY_free'
make[5]: *** [socket.lo] Error 1
make[4]: *** [all-recursive] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2


+++ This bug was initially created as a clone of Bug #1258594 +++

Description of problem:

This change looks rather different from the change it is alleged to be a backport of on the master branch. I.e. #include <openssl/x509v3.h> versus #include <openssl/ecdh.h>


...
Making all in rpc-transport
Making all in socket
Making all in src
  CC     socket.lo
  CC     name.lo
In file included from name.c:23:
socket.h:22:26: error: openssl/ecdh.h: No such file or directory
In file included from socket.c:17:
socket.h:22:26: error: openssl/ecdh.h: No such file or directory
make[5]: *** [name.lo] Error 1
make[5]: *** Waiting for unfinished jobs....
In file included from socket.c:30:
../../../../rpc/xdr/src/glusterfs3-xdr.h:19: warning: ignoring #pragma GCC diagnostic
../../../../rpc/xdr/src/glusterfs3-xdr.h:20: warning: ignoring #pragma GCC diagnostic
socket.c:3990:2: error: #error Old and insecure OpenSSL, use -DUSE_INSECURE_OPENSSL to use it anyway
socket.c: In function 'socket_init':
socket.c:3999: error: 'SSL_OP_NO_TICKET' undeclared (first use in this function)
socket.c:3999: error: (Each undeclared identifier is reported only once
socket.c:3999: error: for each function it appears in.)
socket.c:4000: error: 'SSL_OP_NO_COMPRESSION' undeclared (first use in this function)
socket.c:4036: error: 'EC_KEY' undeclared (first use in this function)
socket.c:4036: error: 'ecdh' undeclared (first use in this function)
socket.c:4042: warning: implicit declaration of function 'EC_KEY_new_by_curve_name'
socket.c:4048: warning: implicit declaration of function 'EC_KEY_free'
make[5]: *** [socket.lo] Error 1
make[4]: *** [all-recursive] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.6603 (%build)

















Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2015-11-16 10:40:51 EST
COMMIT: http://review.gluster.org/12517 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit caae86e6f8b8150ad8663c3173fcd6df3c2e260a
Author: Milind Changire <mchangir@redhat.com>
Date:   Thu Nov 5 19:57:51 2015 +0530

    build: fix ecdh.h and dh.h deps
    
    openssl.ecdh.h and openssl/dh.h are not available on all platforms.
    This patch adds check to autoconf and updates relevant source files.
    Add missing #include "config.h" to socket.c to make HAVE_OPENSSL_DH_H
    and HAVE_OPENSSL_ECDH_H macros available.
    
    Definitions for UTIME_OMIT and UTIME_NOW in
    contrib/qemu/util/oslib-posix.c have been selected from
    /usr/include/bits/stat.h on Fedora 22
    
    SSL context options SSL_OP_NO_TICKET and SSL_OP_NO_COMPRESSION are now
    conditionally set by testing their presence.
    
    glusterfs.spec.in file now adds CFLAGS=-DUSE_INSECURE_OPENSSL for
    RHEL < 6 in the %build section.
    
    Change-Id: Ie32a950dad77bb0f09b4ba53edb3e1f3147056f3
    BUG: 1258883
    Signed-off-by: Milind Changire <mchangir@redhat.com>
    Reviewed-on: http://review.gluster.org/12517
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 2 Niels de Vos 2016-06-16 09:34:51 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 3 Niels de Vos 2017-06-06 01:17:53 EDT
*** Bug 1279747 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.