Bug 1260069 - exconn socket error connecting to openstack using ssl ... add better logging
exconn socket error connecting to openstack using ssl ... add better logging
Status: CLOSED DUPLICATE of bug 1272041
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.4.0
All All
medium Severity medium
: GA
: 5.5.0
Assigned To: Ladislav Smola
Dave Johnson
: ZStream
Depends On:
Blocks: 1267351
  Show dependency treegraph
 
Reported: 2015-09-04 07:13 EDT by Felix Dewaleyne
Modified: 2015-11-19 05:15 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1267351 (view as bug list)
Environment:
Last Closed: 2015-11-19 05:15:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felix Dewaleyne 2015-09-04 07:13:03 EDT
Description of problem:
exconn socket error connecting to openstack using ssl

Version-Release number of selected component (if applicable):
5.4

How reproducible:
not reproduced

Steps to Reproduce:
this happens when adding one OpenStack (with Nuage version 6) cloud provider

Actual results:
exconn socket errors are raised :

[----] E, [2015-09-01T12:49:12.809744 #5179:66bea8] ERROR -- : excon.error     #<Excon::Errors::SocketError: SSL_connect returned=1 errno=0 state=SSLv2/v3 read server hello A: unknown protocol (OpenSSL::SSL::SSLError)>


Expected results:
connection establishes or a more helpful error message is raised.

Additional info:
research seems to point at this fix  in exconn : https://github.com/excon/excon/commit/57a05453d6cf4dbf1382709ed9d7740a24bf0d4e
Comment 1 Felix Dewaleyne 2015-09-04 07:15:43 EDT
might have opened a clone to https://bugzilla.redhat.com/show_bug.cgi?id=1252413
Comment 5 Greg Blomquist 2015-11-17 09:08:13 EST
Ladas,

Looks like another dup of the SSL bug you're already working on.
Comment 6 Ladislav Smola 2015-11-19 05:15:43 EST

*** This bug has been marked as a duplicate of bug 1272041 ***

Note You need to log in before you can comment on or make changes to this bug.