Bug 1272041 - change OSP provider error message around no ssl available
change OSP provider error message around no ssl available
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Ladislav Smola
Ramesh A
openstack
:
: 1252413 1260069 1272044 1280395 (view as bug list)
Depends On:
Blocks: 1267351 1298970
  Show dependency treegraph
 
Reported: 2015-10-15 06:43 EDT by Ramesh A
Modified: 2016-06-29 11:00 EDT (History)
9 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1298970 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:00:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ramesh A 2015-10-15 06:43:56 EDT
Description of problem:
#<Excon::Errors::SocketError: SSL_connect returned=1 errno=0 state=SSLv2/v3 read server hello A: unknown protocol (OpenSSL::SSL::SSLError)>" error is found in evm.log file after adding RHOS provider

Version-Release number of selected component (if applicable):
5.4.3.0.20151001120745_d11cf59

How reproducible:
100%

Steps to Reproduce:
1. Deploy a new appliance
2. Add RHOS (say RHOS 6) provider
3. Wait for sometime

Actual results:
#<Excon::Errors::SocketError: SSL_connect returned=1 errno=0 state=SSLv2/v3 read server hello A: unknown protocol (OpenSSL::SSL::SSLError)>" error is found in evm.log file

Expected results:
Should not throw any error message

Additional info:
Comment 2 Greg Blomquist 2015-10-15 09:59:08 EDT
This is a known (benign) error that occurs in the logs when you add a non-SSL OSP provider to CloudForms.

The error is logged because of the way that we have to authenticate to OpenStack.  First, we try SSL, if that fails, we try non-SSL.  When SSL fails (because the OSP environment is not using SSL) this error is logged.  Then, the non-SSL connection succeeds.

The best we can probably do here is change the logging .. possibly.  I'm not entirely positive we have control over the Excon logger to change what's being logged here.

Also, I think this *might* be a dup, but I couldn't find it right away.
Comment 3 Dave Johnson 2015-10-26 15:25:02 EDT
*** Bug 1272044 has been marked as a duplicate of this bug. ***
Comment 4 Ladislav Smola 2015-11-03 06:28:03 EST
*** Bug 1252413 has been marked as a duplicate of this bug. ***
Comment 6 Ladislav Smola 2015-11-19 05:15:14 EST
*** Bug 1280395 has been marked as a duplicate of this bug. ***
Comment 7 Ladislav Smola 2015-11-19 05:15:43 EST
*** Bug 1260069 has been marked as a duplicate of this bug. ***
Comment 9 CFME Bot 2015-12-08 17:41:54 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/94ee6616de26ceba490aef77bef4528e6fa3f92f

commit 94ee6616de26ceba490aef77bef4528e6fa3f92f
Author:     Ladislav Smola <lsmola@redhat.com>
AuthorDate: Thu Nov 5 12:49:12 2015 +0100
Commit:     Ladislav Smola <lsmola@redhat.com>
CommitDate: Mon Nov 16 13:16:10 2015 +0100

    Allow to choose security protocol to avoid errors in log
    
    Allow to choose security protocol to avoid errors in log
    
    Fixes BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1272041

 .../ems_common/ems_common_form_controller.js       |  3 ++
 app/controllers/ems_cloud_controller.rb            | 38 +++++++++++++---------
 app/controllers/ems_common.rb                      | 31 +++++++++++++++---
 app/models/ext_management_system.rb                |  4 +++
 .../manageiq/providers/openstack/cloud_manager.rb  |  4 +++
 .../manageiq/providers/openstack/infra_manager.rb  |  4 +++
 .../manageiq/providers/openstack/manager_mixin.rb  |  2 +-
 app/views/ems_infra/_form_fields.html.haml         |  2 +-
 .../views/ems_common/angular/_form.html.haml       | 12 ++++++-
 gems/pending/openstack/openstack_handle/handle.rb  | 38 ++++++++++++++--------
 .../openstack_handle/identity_delegate.rb          |  2 +-
 11 files changed, 102 insertions(+), 38 deletions(-)
Comment 10 Ladislav Smola 2015-12-16 07:24:22 EST
OpenStack Infra form fix https://github.com/ManageIQ/manageiq/pull/5862
Comment 11 CFME Bot 2015-12-16 14:20:33 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/78a0f5a53bef5fb080ae9be87a7f860aa1eb586f

commit 78a0f5a53bef5fb080ae9be87a7f860aa1eb586f
Author:     Ladislav Smola <lsmola@redhat.com>
AuthorDate: Wed Dec 16 13:19:33 2015 +0100
Commit:     Ladislav Smola <lsmola@redhat.com>
CommitDate: Wed Dec 16 13:19:33 2015 +0100

    Openstack Infra correct ssl option when creating provider
    
    Openstack Infra correct ssl option when creating provider
    
    Partially Fixes BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1272041

 app/controllers/ems_common.rb | 7 +++++++
 1 file changed, 7 insertions(+)
Comment 12 CFME Bot 2016-01-12 08:32:09 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=e2c268498af1f13b9fc1e4982bbe55c608f46f6a

commit e2c268498af1f13b9fc1e4982bbe55c608f46f6a
Author:     Ladislav Smola <lsmola@redhat.com>
AuthorDate: Wed Dec 16 13:19:33 2015 +0100
Commit:     Ladislav Smola <lsmola@redhat.com>
CommitDate: Tue Jan 12 11:23:51 2016 +0100

    Openstack Infra correct ssl option when creating provider
    
    Openstack Infra correct ssl option when creating provider
    
    Partially Fixes BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1272041

 app/controllers/ems_common.rb | 7 +++++++
 1 file changed, 7 insertions(+)
Comment 13 CFME Bot 2016-01-12 08:32:15 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=cae64c60c834c9dd56fec7511c9673d657ebc80e

commit cae64c60c834c9dd56fec7511c9673d657ebc80e
Author:     Ladislav Smola <lsmola@redhat.com>
AuthorDate: Thu Nov 5 12:49:12 2015 +0100
Commit:     Ladislav Smola <lsmola@redhat.com>
CommitDate: Tue Jan 12 11:20:24 2016 +0100

    Allow to choose security protocol to avoid errors in log
    
    Allow to choose security protocol to avoid errors in log
    
    Fixes BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1272041
    
    Conflicts:
    	app/views/shared/views/ems_common/angular/_form.html.haml

 .../ems_common/ems_common_form_controller.js       |  3 ++
 app/controllers/ems_cloud_controller.rb            | 38 +++++++++++++---------
 app/controllers/ems_common.rb                      | 31 +++++++++++++++---
 app/models/ext_management_system.rb                |  4 +++
 .../manageiq/providers/openstack/cloud_manager.rb  |  4 +++
 .../manageiq/providers/openstack/infra_manager.rb  |  4 +++
 .../manageiq/providers/openstack/manager_mixin.rb  |  2 +-
 app/views/ems_infra/_form_fields.html.haml         |  2 +-
 .../views/ems_common/angular/_form.html.haml       | 11 +++++++
 gems/pending/openstack/openstack_handle/handle.rb  | 38 ++++++++++++++--------
 .../openstack_handle/identity_delegate.rb          |  2 +-
 11 files changed, 102 insertions(+), 37 deletions(-)
Comment 14 Ramesh A 2016-06-07 08:34:43 EDT
Good to go.  Verified and working fine in 5.6.0.9-rc2.20160531154046_b4e2f6d.

By choosing Security protocol as "Non-SSL" option for non-SSL connection, SSL error message is not reproduced.
Comment 16 errata-xmlrpc 2016-06-29 11:00:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.