Bug 1261335 - [engine-setup][text] The error for a missing update in the sql performing the validation should be fixed.
[engine-setup][text] The error for a missing update in the sql performing the...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Setup.EngineCommon (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity low (vote)
: ovirt-4.0.0-alpha
: 4.0.0
Assigned To: Lev Veyde
Lukas Svaty
: EasyFix
Depends On:
Blocks: 1261336
  Show dependency treegraph
 
Reported: 2015-09-09 03:58 EDT by Ilanit Stein
Modified: 2016-07-05 03:52 EDT (History)
11 users (show)

See Also:
Fixed In Version: ovirt 4.0.0 alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-05 03:52:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
rule-engine: planning_ack+
dfediuck: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47743 master MERGED packaging: Make a DB validation error more clear 2016-02-03 07:40 EST

  None (edit)
Description Ilanit Stein 2015-09-09 03:58:37 EDT
Description of problem:

Bug 1254639 - "engine-setup fails at second run",
Show in the setup log a message that need to be fixed:

===============================================================================
2015-08-24 08:07:04 DEBUG otopi.plugins.ovirt_engine_setup.ovirt_engine.upgrade.dbvalidations plugin.execute:940 execute-output: ['/usr/share/ovirt-engine/setup/dbutils/validatedb.sh', '--user=engine', '--host=localhost', '--port=5432', '--database=engine', '--log=/var/log/ovirt-engine/setup/ovirt-engine-setup-20150824080613-j3lju0.log'] stderr:
ERROR:  relation "group_attributes" does not exist
LINE 1: select  (group_id)  from group_attributes where  (group_id) ...
                                 ^
QUERY:  select  (group_id)  from group_attributes where  (group_id) IS NOT NULL and  (group_id)  not in (select group_id from groups);
CONTEXT:  PL/pgSQL function "fn_db_validate_fks" line 40 at EXECUTE statement
===============================================================================

From bug 1256214 (duplicate of bug 1254639), comment 1:
alonbl: "Sandro, you should probably throw exception that is human readable, this is not a debug, error is probably in stderr, and format should not be list/tuple."

Version-Release number of selected component (if applicable):
3.6.0-10
Comment 1 Red Hat Bugzilla Rules Engine 2015-10-19 06:49:54 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Lukas Svaty 2016-05-13 06:13:14 EDT
sanity only
verified in ovirt-engine-4.0.0-0.6.master.el7ev.noarch
Comment 3 Sandro Bonazzola 2016-07-05 03:52:57 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.