Bug 1261336 - [engine-setup] The error for a missing update in the sql performing the validation should be fixed.
[engine-setup] The error for a missing update in the sql performing the valid...
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity low
: ovirt-3.6.1
: 3.6.1
Assigned To: Sandro Bonazzola
Ilanit Stein
integration
:
Depends On: 1261335
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-09 03:59 EDT by Ilanit Stein
Modified: 2015-10-29 07:03 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-27 08:47:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ilanit Stein 2015-09-09 03:59:21 EDT
Description of problem:

Bug 1254639 - "engine-setup fails at second run",
Show in the setup log a message that need to be fixed:

===============================================================================
2015-08-24 08:07:04 DEBUG otopi.plugins.ovirt_engine_setup.ovirt_engine.upgrade.dbvalidations plugin.execute:940 execute-output: ['/usr/share/ovirt-engine/setup/dbutils/validatedb.sh', '--user=engine', '--host=localhost', '--port=5432', '--database=engine', '--log=/var/log/ovirt-engine/setup/ovirt-engine-setup-20150824080613-j3lju0.log'] stderr:
ERROR:  relation "group_attributes" does not exist
LINE 1: select  (group_id)  from group_attributes where  (group_id) ...
                                 ^
QUERY:  select  (group_id)  from group_attributes where  (group_id) IS NOT NULL and  (group_id)  not in (select group_id from groups);
CONTEXT:  PL/pgSQL function "fn_db_validate_fks" line 40 at EXECUTE statement
===============================================================================

From bug 1256214 (duplicate of bug 1254639), comment 1:
alonbl: "Sandro, you should probably throw exception that is human readable, this is not a debug, error is probably in stderr, and format should not be list/tuple."

Version-Release number of selected component (if applicable):
3.6.0-10

Note You need to log in before you can comment on or make changes to this bug.