Bug 1261757 - Tiering/glusted: volume status failed after detach tier start
Tiering/glusted: volume status failed after detach tier start
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mohammed Rafi KC
bugs@gluster.org
: Triaged
Depends On:
Blocks: 1260923 1261758 1271727
  Show dependency treegraph
 
Reported: 2015-09-10 02:35 EDT by Mohammed Rafi KC
Modified: 2016-06-16 09:36 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1261758 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:36:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohammed Rafi KC 2015-09-10 02:35:22 EDT
Description of problem:

volume status failed with commit error after detach tier start on a tiered volume.

Version-Release number of selected component (if applicable):

mainline

How reproducible:

100%

Steps to Reproduce:
1.create a replica 2 volume with two bricks
2.attach hot tier with only one brick
3.do detach start
4. gluster volume status vol


Actual results:

volume status failed for vol

Expected results:

volume status shoule be successful

Additional info:
Comment 1 Vijay Bellur 2015-09-10 02:56:11 EDT
REVIEW: http://review.gluster.org/12146 (tier/glusterd: volume status failed after detach start) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 2 Vijay Bellur 2015-09-10 05:45:05 EDT
REVIEW: http://review.gluster.org/12146 (tier/glusterd: volume status failed after detach start) posted (#2) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 3 Vijay Bellur 2015-09-12 10:19:18 EDT
REVIEW: http://review.gluster.org/12146 (tier/glusterd: volume status failed after detach start) posted (#3) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 4 Vijay Bellur 2015-09-18 12:56:03 EDT
COMMIT: http://review.gluster.org/12146 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit 51632e1eec3ff88d19867dc8d266068dd7db432a
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Thu Sep 10 11:52:27 2015 +0530

    tier/glusterd: volume status failed after detach start
    
    After triggering detach start on a tiered volume fails.
    This because of brick count was wrongly setting in rebal
    dictionary.
    
    Change-Id: I6a472bf2653a07522416699420161f2fb1746aef
    BUG: 1261757
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/12146
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 5 Niels de Vos 2016-06-16 09:36:20 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.