Bug 1271727 - Tiering/glusted: volume status failed after detach tier start
Tiering/glusted: volume status failed after detach tier start
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: tier (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS 3.1.2
Assigned To: Mohammed Rafi KC
Bhaskarakiran
: Triaged, ZStream
Depends On: 1261757 1261758
Blocks: 1260783 1260923
  Show dependency treegraph
 
Reported: 2015-10-14 10:40 EDT by Mohammed Rafi KC
Modified: 2016-11-23 18:12 EST (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-0.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1261758
Environment:
Last Closed: 2016-03-01 00:39:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohammed Rafi KC 2015-10-14 10:40:48 EDT
+++ This bug was initially created as a clone of Bug #1261758 +++

+++ This bug was initially created as a clone of Bug #1261757 +++

Description of problem:

volume status failed with commit error after detach tier start on a tiered volume.

Version-Release number of selected component (if applicable):

mainline

How reproducible:

100%

Steps to Reproduce:
1.create a replica 2 volume with two bricks
2.attach hot tier with only one brick
3.do detach start
4. gluster volume status vol


Actual results:

volume status failed for vol

Expected results:

volume status shoule be successful

Additional info:
Comment 3 Bhaskarakiran 2015-11-17 07:16:41 EST
verified this on 3.7.5-6. volume status is shown during detach tier.

[root@transformers ~]# gluster v detach-tier vol1 start 
volume detach-tier start: success
ID: 1de78233-df9e-4037-81b0-9d6084d8b570
[root@transformers ~]# gluster v status
Status of volume: vol1
Gluster process                             TCP Port  RDMA Port  Online  Pid
------------------------------------------------------------------------------
Hot Bricks:
Brick interstellar:/rhs/brick11/vol1-tier4  49181     0          Y       26108
Brick transformers:/rhs/brick11/vol1-tier3  49184     0          Y       24527
Brick interstellar:/rhs/brick10/vol1-tier2  49180     0          Y       26090
Brick transformers:/rhs/brick10/vol1-tier1  49183     0          Y       24509
Cold Bricks:
Brick transformers:/rhs/brick1/b1           49175     0          Y       5686 
Brick interstellar:/rhs/brick1/b2           49173     0          Y       8106 
Brick transformers:/rhs/brick2/b3           49176     0          Y       5704 
Brick interstellar:/rhs/brick2/b4           49174     0          Y       8124 
Brick transformers:/rhs/brick3/b5           49177     0          Y       5722 
Brick interstellar:/rhs/brick3/b6           49175     0          Y       8142 
Brick transformers:/rhs/brick4/b7           49178     0          Y       5740 
Brick interstellar:/rhs/brick4/b8           49176     0          Y       8160 
Brick transformers:/rhs/brick5/b9           49179     0          Y       5758 
Brick interstellar:/rhs/brick5/b10          49177     0          Y       8178 
Brick transformers:/rhs/brick7/b11          49182     0          Y       6841 
Brick interstellar:/rhs/brick6/b12          49178     0          Y       8196 
Snapshot Daemon on localhost                49181     0          Y       5797 
NFS Server on localhost                     2049      0          Y       24551
Self-heal Daemon on localhost               N/A       N/A        Y       24562
Quota Daemon on localhost                   N/A       N/A        Y       24570
Snapshot Daemon on vertigo                  49154     0          Y       1966 
NFS Server on vertigo                       2049      0          Y       21505
Self-heal Daemon on vertigo                 N/A       N/A        Y       21513
Quota Daemon on vertigo                     N/A       N/A        Y       21521
Snapshot Daemon on ninja                    49156     0          Y       13540
NFS Server on ninja                         2049      0          Y       5631 
Self-heal Daemon on ninja                   N/A       N/A        Y       5639 
Quota Daemon on ninja                       N/A       N/A        Y       5647 
Snapshot Daemon on interstellar.lab.eng.blr
.redhat.com                                 49179     0          Y       8217 
NFS Server on interstellar.lab.eng.blr.redh
at.com                                      2049      0          Y       26127
Self-heal Daemon on interstellar.lab.eng.bl
r.redhat.com                                N/A       N/A        Y       26135
Quota Daemon on interstellar.lab.eng.blr.re
dhat.com                                    N/A       N/A        Y       26143
 
Task Status of Volume vol1
------------------------------------------------------------------------------
Task                 : Detach tier         
ID                   : 1de78233-df9e-4037-81b0-9d6084d8b570
Status               : in progress         
 
[root@transformers ~]#
Comment 5 errata-xmlrpc 2016-03-01 00:39:36 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.