Bug 1261758 - Tiering/glusted: volume status failed after detach tier start
Tiering/glusted: volume status failed after detach tier start
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mohammed Rafi KC
bugs@gluster.org
: Triaged
Depends On: 1261757
Blocks: 1260923 1271727 glusterfs-3.7.6
  Show dependency treegraph
 
Reported: 2015-09-10 02:36 EDT by Mohammed Rafi KC
Modified: 2015-11-17 00:58 EST (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.7.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1261757
: 1271727 (view as bug list)
Environment:
Last Closed: 2015-11-17 00:58:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohammed Rafi KC 2015-09-10 02:36:20 EDT
+++ This bug was initially created as a clone of Bug #1261757 +++

Description of problem:

volume status failed with commit error after detach tier start on a tiered volume.

Version-Release number of selected component (if applicable):

mainline

How reproducible:

100%

Steps to Reproduce:
1.create a replica 2 volume with two bricks
2.attach hot tier with only one brick
3.do detach start
4. gluster volume status vol


Actual results:

volume status failed for vol

Expected results:

volume status shoule be successful

Additional info:
Comment 1 Raghavendra Talur 2015-11-17 00:58:48 EST
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.6, please open a new bug report.

glusterfs-3.7.6 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-November/024359.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.