This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1261773 - features.sharding is not available in 'gluster volume set help'
features.sharding is not available in 'gluster volume set help'
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: sharding (Show other bugs)
mainline
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Krutika Dhananjay
bugs@gluster.org
: EasyFix, Triaged
Depends On:
Blocks: 1313320 1313339
  Show dependency treegraph
 
Reported: 2015-09-10 03:14 EDT by SATHEESARAN
Modified: 2016-06-16 09:36 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1313320 1313339 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:36:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description SATHEESARAN 2015-09-10 03:14:55 EDT
Description of problem:
-----------------------
There is no description about the volume set option - 'features.shard' - found in the 'gluster volume set help' output

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
mainline
release-3.7.4

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. check for the option - features.shard - in 'gluster volume set help'

Actual results:
---------------
No description was found about 'features.shard' in 'gluster volume set help'

Expected results:
-----------------
Description about 'features.shard' should be available in 'gluster volume set help'

Additional info:
----------------
Consequence of this issue :

oVirt - which manages gluster nodes - uses 'gluster volume set help' to get all the options that are available to be set/unset on the volume and populates them in a dropdown list.

Now there is no way to enable sharding from oVirt
Comment 1 SATHEESARAN 2015-09-10 03:16:02 EDT
[root@ ~]# gluster volume set help | grep -i shard -A3
Option: features.shard-block-size
Default Value: 4MB
Description: The size unit used to break a file into multiple chunks
Comment 2 Vijay Bellur 2016-03-01 07:25:12 EST
REVIEW: http://review.gluster.org/13565 (mgmt/glusterd: Show features.shard option in volume-set-help output) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 3 Vijay Bellur 2016-03-02 01:46:48 EST
REVIEW: http://review.gluster.org/13565 (mgmt/glusterd: Show features.shard option in volume-set-help output) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 4 Vijay Bellur 2016-03-02 11:56:46 EST
COMMIT: http://review.gluster.org/13565 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 14609729da9ed8f76be6ff0ce5d6a6b278af6e8d
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Tue Mar 1 17:31:11 2016 +0530

    mgmt/glusterd: Show features.shard option in volume-set-help output
    
    Change-Id: If9004c4374b92d058cf56add50a91ecad43a2840
    BUG: 1261773
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/13565
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 5 Niels de Vos 2016-06-16 09:36:20 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.