Bug 1313339 - features.sharding is not available in 'gluster volume set help'
features.sharding is not available in 'gluster volume set help'
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: sharding (Show other bugs)
3.7.9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Krutika Dhananjay
bugs@gluster.org
: EasyFix, Triaged
Depends On: 1261773
Blocks: 1313320
  Show dependency treegraph
 
Reported: 2016-03-01 07:32 EST by Krutika Dhananjay
Modified: 2016-04-19 03:22 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1261773
Environment:
Last Closed: 2016-04-19 03:22:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krutika Dhananjay 2016-03-01 07:32:32 EST
+++ This bug was initially created as a clone of Bug #1261773 +++

Description of problem:
-----------------------
There is no description about the volume set option - 'features.shard' - found in the 'gluster volume set help' output

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
mainline
release-3.7.4

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. check for the option - features.shard - in 'gluster volume set help'

Actual results:
---------------
No description was found about 'features.shard' in 'gluster volume set help'

Expected results:
-----------------
Description about 'features.shard' should be available in 'gluster volume set help'

Additional info:
----------------
Consequence of this issue :

oVirt - which manages gluster nodes - uses 'gluster volume set help' to get all the options that are available to be set/unset on the volume and populates them in a dropdown list.

Now there is no way to enable sharding from oVirt

--- Additional comment from SATHEESARAN on 2015-09-10 03:16:02 EDT ---

[root@ ~]# gluster volume set help | grep -i shard -A3
Option: features.shard-block-size
Default Value: 4MB
Description: The size unit used to break a file into multiple chunks

--- Additional comment from Vijay Bellur on 2016-03-01 07:25:12 EST ---

REVIEW: http://review.gluster.org/13565 (mgmt/glusterd: Show features.shard option in volume-set-help output) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 1 Vijay Bellur 2016-03-01 07:33:33 EST
REVIEW: http://review.gluster.org/13566 (mgmt/glusterd: Show features.shard option in volume-set-help output) posted (#1) for review on release-3.7 by Krutika Dhananjay (kdhananj@redhat.com)
Comment 2 Vijay Bellur 2016-03-01 07:39:53 EST
REVIEW: http://review.gluster.org/13566 (mgmt/glusterd: Show features.shard option in volume-set-help output) posted (#2) for review on release-3.7 by Krutika Dhananjay (kdhananj@redhat.com)
Comment 3 Vijay Bellur 2016-03-03 06:47:31 EST
REVIEW: http://review.gluster.org/13566 (mgmt/glusterd: Show features.shard option in volume-set-help output) posted (#3) for review on release-3.7 by Krutika Dhananjay (kdhananj@redhat.com)
Comment 4 Vijay Bellur 2016-03-03 22:45:25 EST
COMMIT: http://review.gluster.org/13566 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 8197b46b37cc573c67ba0c3a44539064345eb926
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Tue Mar 1 17:31:11 2016 +0530

    mgmt/glusterd: Show features.shard option in volume-set-help output
    
            Backport of: http://review.gluster.org/#/c/13565/
    
    Change-Id: Ief6f62c65dd8cc736edc785ac06af6ee7309862c
    BUG: 1313339
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/13566
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 5 Kaushal 2016-04-19 03:22:11 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.