Bug 1313320 - features.sharding is not available in 'gluster volume set help'
features.sharding is not available in 'gluster volume set help'
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: replicate (Show other bugs)
3.1
x86_64 Linux
low Severity medium
: ---
: RHGS 3.1.3
Assigned To: Krutika Dhananjay
SATHEESARAN
: ZStream
Depends On: 1261773 1313339
Blocks: Gluster-HC-1 1299184
  Show dependency treegraph
 
Reported: 2016-03-01 06:43 EST by Sahina Bose
Modified: 2016-09-17 08:13 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1261773
Environment:
Last Closed: 2016-06-23 01:09:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sahina Bose 2016-03-01 06:43:47 EST
+++ This bug was initially created as a clone of Bug #1261773 +++

Description of problem:
-----------------------
There is no description about the volume set option - 'features.shard' - found in the 'gluster volume set help' output

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
mainline
release-3.7.4

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. check for the option - features.shard - in 'gluster volume set help'

Actual results:
---------------
No description was found about 'features.shard' in 'gluster volume set help'

Expected results:
-----------------
Description about 'features.shard' should be available in 'gluster volume set help'

Additional info:
----------------
Consequence of this issue :

oVirt - which manages gluster nodes - uses 'gluster volume set help' to get all the options that are available to be set/unset on the volume and populates them in a dropdown list.

Now there is no way to enable sharding from oVirt

--- Additional comment from SATHEESARAN on 2015-09-10 03:16:02 EDT ---

[root@ ~]# gluster volume set help | grep -i shard -A3
Option: features.shard-block-size
Default Value: 4MB
Description: The size unit used to break a file into multiple chunks
Comment 1 Krutika Dhananjay 2016-03-01 07:43:24 EST
Upstream patches posted at: http://review.gluster.org/#/c/13565/
                            http://review.gluster.org/#/c/13566/
Comment 4 SATHEESARAN 2016-03-29 02:44:31 EDT
Tested with RHGS 3.1.3 nightly build ( glusterfs-3.7.9-1.el7rhgs )

The sharding options are available with 'gluster volume set help'

[root@ ]# gluster volume set help | grep shard -A4
Option: features.shard
Default Value: off
Description: enable/disable sharding translator on the volume.

Option: features.shard-block-size
Default Value: 4MB
Description: The size unit used to break a file into multiple chunks
Comment 6 errata-xmlrpc 2016-06-23 01:09:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1240

Note You need to log in before you can comment on or make changes to this bug.