Bug 1261841 - [HC] Implement fallocate, discard and zerofill with sharding
[HC] Implement fallocate, discard and zerofill with sharding
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: sharding (Show other bugs)
mainline
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Krutika Dhananjay
bugs@gluster.org
: Triaged
Depends On:
Blocks: 1299712 1302688
  Show dependency treegraph
 
Reported: 2015-09-10 05:53 EDT by SATHEESARAN
Modified: 2016-06-16 09:36 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1299712 1302688 (view as bug list)
Environment:
RHEL 7.1 - converged setup of virt & gluster
Last Closed: 2016-06-16 09:36:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description SATHEESARAN 2015-09-10 05:53:46 EDT
Description of problem:
-----------------------
fallocate on the sharded volume fails with "transport endpoint not connected" - ENOTCONN

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
mainline & release-3.7.4

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. Try fallocate command on the sharded gluster volume

Actual results:
---------------
fallocate failed with "Transport endpoint not connected"

Expected results:
-----------------
fallocate should sucessfully create files

Additional info:
----------------
fallocate will be used by qemu for creating preallocated image files
Comment 1 SATHEESARAN 2015-09-10 05:54:34 EDT
[root@ ~]# fallocate -l1MB /rhev/data-center/mnt/glusterSD/rhs-client10.lab.eng.blr.redhat.com\:vmstore/file1
fallocate: /rhev/data-center/mnt/glusterSD/rhs-client10.lab.eng.blr.redhat.com:vmstore/sas1: fallocate failed: Transport endpoint is not connected

I see the following error message in fuse mount logs

"[2015-09-08 16:57:29.796276] I [shard.c:3745:shard_fallocate] 0-vmstore-shard: fallocate called on 10292366-317e-406a-b45f-a49cec061c46. FOP not implemented. Failing with ENOTCONN
[2015-09-08 16:57:29.796311] W [fuse-bridge.c:1271:fuse_err_cbk] 0-glusterfs-fuse: 1012095: FALLOCATE() ERR => -1 (Transport endpoint is not connected)"
Comment 2 Vijay Bellur 2016-01-08 06:00:15 EST
REVIEW: http://review.gluster.org/13196 (features/shard: Implement fallocate FOP) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 3 Vijay Bellur 2016-01-08 06:29:31 EST
REVIEW: http://review.gluster.org/13196 (features/shard: Implement fallocate FOP.) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 4 Vijay Bellur 2016-01-08 06:29:34 EST
REVIEW: http://review.gluster.org/13198 (features/shard: Implement zerofill FOP) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 5 Vijay Bellur 2016-01-13 08:03:15 EST
REVIEW: http://review.gluster.org/13196 (features/shard: Implement fallocate FOP) posted (#3) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 6 Vijay Bellur 2016-01-13 08:03:18 EST
REVIEW: http://review.gluster.org/13234 (features/shard: Implement zerofill FOP) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 7 Vijay Bellur 2016-01-13 08:03:22 EST
REVIEW: http://review.gluster.org/13235 (features/shard: Implement discard FOP) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 8 Vijay Bellur 2016-01-18 06:10:24 EST
REVIEW: http://review.gluster.org/13196 (features/shard: Implement fallocate FOP) posted (#4) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 9 Vijay Bellur 2016-01-18 06:47:44 EST
REVIEW: http://review.gluster.org/13196 (features/shard: Implement fallocate FOP) posted (#5) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 10 Vijay Bellur 2016-01-18 19:18:18 EST
COMMIT: http://review.gluster.org/13196 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit c535059299785f7d050482c257f10389c218048b
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Thu Oct 29 17:04:38 2015 +0530

    features/shard: Implement fallocate FOP
    
    Change-Id: I6f07074e94b115f6c6c2c59a8a1b58ba44b1c12a
    BUG: 1261841
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/13196
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 11 Vijay Bellur 2016-01-19 04:34:50 EST
REVIEW: http://review.gluster.org/13234 (features/shard: Implement zerofill FOP) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 12 Vijay Bellur 2016-01-23 01:02:35 EST
COMMIT: http://review.gluster.org/13234 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit e67712c06b64fb659824b3f79164f2789693acee
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Wed Jan 13 16:19:15 2016 +0530

    features/shard: Implement zerofill FOP
    
    Change-Id: Iabb89a502cc560edd7fe3755623c74a2ccb853d5
    BUG: 1261841
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/13234
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 13 Vijay Bellur 2016-02-09 06:21:43 EST
REVIEW: http://review.gluster.org/13405 (tests, shard: fallocate tests refactor) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 14 Vijay Bellur 2016-02-09 09:18:28 EST
REVIEW: http://review.gluster.org/13405 (tests, shard: fallocate tests refactor) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 15 Vijay Bellur 2016-02-25 08:03:43 EST
REVIEW: http://review.gluster.org/13405 (tests, shard: fallocate tests refactor) posted (#3) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 16 Vijay Bellur 2016-02-25 08:16:28 EST
REVIEW: http://review.gluster.org/13523 (features/shard: Return ENOTSUP for unsupported fallocate flags) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 17 Vijay Bellur 2016-02-29 04:24:07 EST
REVIEW: http://review.gluster.org/13405 (tests, shard: fallocate tests refactor) posted (#4) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 18 Vijay Bellur 2016-03-02 01:46:12 EST
REVIEW: http://review.gluster.org/13405 (tests, shard: fallocate tests refactor) posted (#5) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 19 Vijay Bellur 2016-03-02 19:59:59 EST
REVIEW: http://review.gluster.org/13523 (features/shard: Return ENOTSUP for unsupported fallocate flags) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 20 Vijay Bellur 2016-03-03 03:23:17 EST
REVIEW: http://review.gluster.org/13405 (tests, shard: fallocate tests refactor) posted (#6) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 21 Vijay Bellur 2016-03-04 03:15:40 EST
REVIEW: http://review.gluster.org/13405 (tests, shard: fallocate tests refactor) posted (#7) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 22 Vijay Bellur 2016-03-04 03:17:09 EST
REVIEW: http://review.gluster.org/13523 (features/shard: Return ENOTSUP for unsupported fallocate flags) posted (#3) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 23 Vijay Bellur 2016-03-04 07:24:18 EST
REVIEW: http://review.gluster.org/13523 (features/shard: Return ENOTSUP for unsupported fallocate flags) posted (#4) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 24 Vijay Bellur 2016-03-04 07:46:36 EST
REVIEW: http://review.gluster.org/13405 (tests, shard: fallocate tests refactor) posted (#8) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 25 Vijay Bellur 2016-03-06 23:19:13 EST
REVIEW: http://review.gluster.org/13523 (features/shard: Return ENOTSUP for unsupported fallocate flags) posted (#5) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 26 Vijay Bellur 2016-03-07 06:29:30 EST
REVIEW: http://review.gluster.org/13405 (tests, shard: fallocate tests refactor) posted (#9) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 27 Vijay Bellur 2016-03-08 02:23:57 EST
REVIEW: http://review.gluster.org/13405 (tests, shard: fallocate tests refactor) posted (#10) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 28 Vijay Bellur 2016-03-08 06:25:08 EST
REVIEW: http://review.gluster.org/13405 (tests, shard: fallocate tests refactor) posted (#11) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 29 Vijay Bellur 2016-03-08 10:19:55 EST
REVIEW: http://review.gluster.org/13523 (features/shard: Return ENOTSUP for unsupported fallocate flags) posted (#6) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 30 Vijay Bellur 2016-03-08 21:42:30 EST
COMMIT: http://review.gluster.org/13523 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit c00722ff9d83d131e624f5499da05160d184cfba
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Thu Feb 25 18:27:09 2016 +0530

    features/shard: Return ENOTSUP for unsupported fallocate flags
    
    Basis: http://lists.gnu.org/archive/html/qemu-devel/2016-02/msg05101.html
    
    Change-Id: I5bf80b6e8caed3d7f136fc57e16abfb28869e009
    BUG: 1261841
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/13523
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 31 Vijay Bellur 2016-03-09 02:14:07 EST
REVIEW: http://review.gluster.org/13405 (tests, shard: fallocate tests refactor) posted (#12) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 32 Vijay Bellur 2016-03-09 03:49:50 EST
REVIEW: http://review.gluster.org/13405 (tests, shard: fallocate tests refactor) posted (#13) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 33 Vijay Bellur 2016-03-09 08:16:44 EST
REVIEW: http://review.gluster.org/13405 (tests, shard: fallocate tests refactor) posted (#14) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 34 Vijay Bellur 2016-03-09 08:16:47 EST
REVIEW: http://review.gluster.org/13657 (features/shard: Implement discard fop) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 35 Vijay Bellur 2016-03-09 22:04:09 EST
REVIEW: http://review.gluster.org/13405 (tests, shard: fallocate tests refactor) posted (#15) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 36 Vijay Bellur 2016-03-10 01:53:18 EST
REVIEW: http://review.gluster.org/13405 (tests, shard: fallocate tests refactor) posted (#16) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 37 Vijay Bellur 2016-03-10 06:17:02 EST
COMMIT: http://review.gluster.org/13405 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 6df883cef3e69b37a192aae9e979f95b32f8ad41
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Tue Feb 9 16:40:36 2016 +0530

    tests, shard: fallocate tests refactor
    
    Change-Id: I3f275185f4dcb1939e8074851c8f140c5e40b28d
    BUG: 1261841
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/13405
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
Comment 38 Vijay Bellur 2016-03-10 06:17:09 EST
REVIEW: http://review.gluster.org/13657 (features/shard: Implement discard fop) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 39 Vijay Bellur 2016-03-11 05:26:46 EST
REVIEW: http://review.gluster.org/13657 (features/shard: Implement discard fop) posted (#3) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 40 Vijay Bellur 2016-03-11 14:10:35 EST
COMMIT: http://review.gluster.org/13657 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 0e048b309b64e574039fc1ebedb971791d43b5e1
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Tue Mar 8 15:44:04 2016 +0530

    features/shard: Implement discard fop
    
    Change-Id: Ia5bd8d36b21a586df6556fbec3474892d5871229
    BUG: 1261841
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/13657
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 41 Mike McCune 2016-03-28 18:51:39 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 42 Niels de Vos 2016-06-16 09:36:20 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.