Bug 1302688 - [HC] Implement fallocate, discard and zerofill with sharding
[HC] Implement fallocate, discard and zerofill with sharding
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: replicate (Show other bugs)
3.1
x86_64 Linux
high Severity high
: ---
: RHGS 3.1.3
Assigned To: Krutika Dhananjay
SATHEESARAN
: Triaged, ZStream
Depends On: 1261841
Blocks: Gluster-HC-1 1299184 1299712
  Show dependency treegraph
 
Reported: 2016-01-28 06:44 EST by Krutika Dhananjay
Modified: 2016-09-17 08:11 EDT (History)
11 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1261841
Environment:
RHEL 7.1 - converged setup of virt & gluster
Last Closed: 2016-06-23 01:05:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krutika Dhananjay 2016-01-28 06:44:30 EST
+++ This bug was initially created as a clone of Bug #1261841 +++

Description of problem:
-----------------------
fallocate on the sharded volume fails with "transport endpoint not connected" - ENOTCONN

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
mainline & release-3.7.4

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. Try fallocate command on the sharded gluster volume

Actual results:
---------------
fallocate failed with "Transport endpoint not connected"

Expected results:
-----------------
fallocate should sucessfully create files

Additional info:
----------------
fallocate will be used by qemu for creating preallocated image files

--- Additional comment from SATHEESARAN on 2015-09-10 05:54:34 EDT ---

[root@ ~]# fallocate -l1MB /rhev/data-center/mnt/glusterSD/rhs-client10.lab.eng.blr.redhat.com\:vmstore/file1
fallocate: /rhev/data-center/mnt/glusterSD/rhs-client10.lab.eng.blr.redhat.com:vmstore/sas1: fallocate failed: Transport endpoint is not connected

I see the following error message in fuse mount logs

"[2015-09-08 16:57:29.796276] I [shard.c:3745:shard_fallocate] 0-vmstore-shard: fallocate called on 10292366-317e-406a-b45f-a49cec061c46. FOP not implemented. Failing with ENOTCONN
[2015-09-08 16:57:29.796311] W [fuse-bridge.c:1271:fuse_err_cbk] 0-glusterfs-fuse: 1012095: FALLOCATE() ERR => -1 (Transport endpoint is not connected)"

--- Additional comment from Vijay Bellur on 2016-01-08 06:00:15 EST ---

REVIEW: http://review.gluster.org/13196 (features/shard: Implement fallocate FOP) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-08 06:29:31 EST ---

REVIEW: http://review.gluster.org/13196 (features/shard: Implement fallocate FOP.) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-08 06:29:34 EST ---

REVIEW: http://review.gluster.org/13198 (features/shard: Implement zerofill FOP) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-13 08:03:15 EST ---

REVIEW: http://review.gluster.org/13196 (features/shard: Implement fallocate FOP) posted (#3) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-13 08:03:18 EST ---

REVIEW: http://review.gluster.org/13234 (features/shard: Implement zerofill FOP) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-13 08:03:22 EST ---

REVIEW: http://review.gluster.org/13235 (features/shard: Implement discard FOP) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-18 06:10:24 EST ---

REVIEW: http://review.gluster.org/13196 (features/shard: Implement fallocate FOP) posted (#4) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-18 06:47:44 EST ---

REVIEW: http://review.gluster.org/13196 (features/shard: Implement fallocate FOP) posted (#5) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-18 19:18:18 EST ---

COMMIT: http://review.gluster.org/13196 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit c535059299785f7d050482c257f10389c218048b
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Thu Oct 29 17:04:38 2015 +0530

    features/shard: Implement fallocate FOP
    
    Change-Id: I6f07074e94b115f6c6c2c59a8a1b58ba44b1c12a
    BUG: 1261841
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/13196
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>

--- Additional comment from Vijay Bellur on 2016-01-19 04:34:50 EST ---

REVIEW: http://review.gluster.org/13234 (features/shard: Implement zerofill FOP) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-23 01:02:35 EST ---

COMMIT: http://review.gluster.org/13234 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit e67712c06b64fb659824b3f79164f2789693acee
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Wed Jan 13 16:19:15 2016 +0530

    features/shard: Implement zerofill FOP
    
    Change-Id: Iabb89a502cc560edd7fe3755623c74a2ccb853d5
    BUG: 1261841
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/13234
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 4 Mike McCune 2016-03-28 18:51:39 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 6 SATHEESARAN 2016-06-06 10:49:26 EDT
Fallocate on the sharded volume works good.
# fallocate -l2G file1
# ls -lsah file1
2.0G -rw-r--r--. 1 root root 2.0G Jun  6 10:40 file1

discard & zerofill are also implemented and verified with glfs_discard() & glfs_zerofill()
Comment 8 errata-xmlrpc 2016-06-23 01:05:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1240

Note You need to log in before you can comment on or make changes to this bug.