Bug 1299712 - [HC] Implement fallocate, discard and zerofill with sharding
[HC] Implement fallocate, discard and zerofill with sharding
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: sharding (Show other bugs)
3.7.7
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Krutika Dhananjay
bugs@gluster.org
: Triaged
Depends On: 1261841 1302688
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-19 00:46 EST by Krutika Dhananjay
Modified: 2016-04-19 03:52 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1261841
Environment:
RHEL 7.1 - converged setup of virt & gluster
Last Closed: 2016-04-19 02:58:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krutika Dhananjay 2016-01-19 00:46:52 EST
+++ This bug was initially created as a clone of Bug #1261841 +++

Description of problem:
-----------------------
fallocate on the sharded volume fails with "transport endpoint not connected" - ENOTCONN

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
mainline & release-3.7.4

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. Try fallocate command on the sharded gluster volume

Actual results:
---------------
fallocate failed with "Transport endpoint not connected"

Expected results:
-----------------
fallocate should sucessfully create files

Additional info:
----------------
fallocate will be used by qemu for creating preallocated image files

--- Additional comment from SATHEESARAN on 2015-09-10 05:54:34 EDT ---

[root@ ~]# fallocate -l1MB /rhev/data-center/mnt/glusterSD/rhs-client10.lab.eng.blr.redhat.com\:vmstore/file1
fallocate: /rhev/data-center/mnt/glusterSD/rhs-client10.lab.eng.blr.redhat.com:vmstore/sas1: fallocate failed: Transport endpoint is not connected

I see the following error message in fuse mount logs

"[2015-09-08 16:57:29.796276] I [shard.c:3745:shard_fallocate] 0-vmstore-shard: fallocate called on 10292366-317e-406a-b45f-a49cec061c46. FOP not implemented. Failing with ENOTCONN
[2015-09-08 16:57:29.796311] W [fuse-bridge.c:1271:fuse_err_cbk] 0-glusterfs-fuse: 1012095: FALLOCATE() ERR => -1 (Transport endpoint is not connected)"

--- Additional comment from Vijay Bellur on 2016-01-08 06:00:15 EST ---

REVIEW: http://review.gluster.org/13196 (features/shard: Implement fallocate FOP) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-08 06:29:31 EST ---

REVIEW: http://review.gluster.org/13196 (features/shard: Implement fallocate FOP.) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-08 06:29:34 EST ---

REVIEW: http://review.gluster.org/13198 (features/shard: Implement zerofill FOP) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-13 08:03:15 EST ---

REVIEW: http://review.gluster.org/13196 (features/shard: Implement fallocate FOP) posted (#3) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-13 08:03:18 EST ---

REVIEW: http://review.gluster.org/13234 (features/shard: Implement zerofill FOP) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-13 08:03:22 EST ---

REVIEW: http://review.gluster.org/13235 (features/shard: Implement discard FOP) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-18 06:10:24 EST ---

REVIEW: http://review.gluster.org/13196 (features/shard: Implement fallocate FOP) posted (#4) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-18 06:47:44 EST ---

REVIEW: http://review.gluster.org/13196 (features/shard: Implement fallocate FOP) posted (#5) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-18 19:18:18 EST ---

COMMIT: http://review.gluster.org/13196 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit c535059299785f7d050482c257f10389c218048b
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Thu Oct 29 17:04:38 2015 +0530

    features/shard: Implement fallocate FOP
    
    Change-Id: I6f07074e94b115f6c6c2c59a8a1b58ba44b1c12a
    BUG: 1261841
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/13196
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 1 Vijay Bellur 2016-01-19 00:48:55 EST
REVIEW: http://review.gluster.org/13259 (features/shard: Implement fallocate FOP) posted (#1) for review on release-3.7 by Krutika Dhananjay (kdhananj@redhat.com)
Comment 2 Vijay Bellur 2016-01-20 05:29:19 EST
REVIEW: http://review.gluster.org/13259 (features/shard: Implement fallocate FOP) posted (#2) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 3 Vijay Bellur 2016-01-22 00:32:02 EST
COMMIT: http://review.gluster.org/13259 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 424825a649ea0cd9bd4955fbfe9d5ba472e6bc38
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Thu Oct 29 17:04:38 2015 +0530

    features/shard: Implement fallocate FOP
    
            Backport of: http://review.gluster.org/13196
    
    
    Change-Id: Iab0c41319af42210c871a3ed6cf52a987c5d88d7
    BUG: 1299712
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/13259
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 4 Vijay Bellur 2016-01-25 00:26:50 EST
REVIEW: http://review.gluster.org/13287 (features/shard: Implement zerofill FOP) posted (#1) for review on release-3.7 by Krutika Dhananjay (kdhananj@redhat.com)
Comment 5 Vijay Bellur 2016-01-27 04:16:23 EST
REVIEW: http://review.gluster.org/13287 (features/shard: Implement zerofill FOP) posted (#2) for review on release-3.7 by Krutika Dhananjay (kdhananj@redhat.com)
Comment 6 Vijay Bellur 2016-02-11 00:59:27 EST
COMMIT: http://review.gluster.org/13287 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 3f5783a76196852f671d5d3a570420e712f31e28
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Wed Jan 13 16:19:15 2016 +0530

    features/shard: Implement zerofill FOP
    
            Backport of: http://review.gluster.org/13234
    
    Change-Id: I5ef61285dbe3ff218e50b8a272c88227c30c35c6
    BUG: 1299712
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/13287
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
Comment 7 Vijay Bellur 2016-03-08 23:49:03 EST
REVIEW: http://review.gluster.org/13652 (features/shard: Return ENOTSUP for unsupported fallocate flags) posted (#1) for review on release-3.7 by Krutika Dhananjay (kdhananj@redhat.com)
Comment 8 Vijay Bellur 2016-03-09 07:05:14 EST
COMMIT: http://review.gluster.org/13652 committed in release-3.7 by Vijay Bellur (vbellur@redhat.com) 
------
commit dc57965cca4c6820f65e69b1b9c9bf94a38218e6
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Thu Feb 25 18:27:09 2016 +0530

    features/shard: Return ENOTSUP for unsupported fallocate flags
    
            Backport of: http://review.gluster.org/13523
    
    Basis: http://lists.gnu.org/archive/html/qemu-devel/2016-02/msg05101.html
    
    Change-Id: I681eb4d0c43c635cf96a2deab0996dec7a255fe5
    BUG: 1299712
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/13652
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 9 Vijay Bellur 2016-03-10 06:27:42 EST
REVIEW: http://review.gluster.org/13670 (tests, shard: fallocate tests refactor) posted (#1) for review on release-3.7 by Krutika Dhananjay (kdhananj@redhat.com)
Comment 10 Vijay Bellur 2016-03-18 05:50:09 EDT
COMMIT: http://review.gluster.org/13670 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit ec89ddc8471d438f9ea45f9a4a779cd87c98666a
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Tue Feb 9 16:40:36 2016 +0530

    tests, shard: fallocate tests refactor
    
            Backport of: http://review.gluster.org/13405
    
    
    Change-Id: Ic6f9d2412303474e6b7948d2dd1475b14da29508
    BUG: 1299712
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/13670
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anuradha Talur <atalur@redhat.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 11 Vijay Bellur 2016-03-18 05:52:48 EDT
REVIEW: http://review.gluster.org/13774 (features/shard: Implement discard fop) posted (#1) for review on release-3.7 by Krutika Dhananjay (kdhananj@redhat.com)
Comment 12 Vijay Bellur 2016-03-23 07:23:26 EDT
REVIEW: http://review.gluster.org/13774 (features/shard: Implement discard fop) posted (#2) for review on release-3.7 by Krutika Dhananjay (kdhananj@redhat.com)
Comment 13 Vijay Bellur 2016-03-24 20:50:03 EDT
COMMIT: http://review.gluster.org/13774 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 7e5531eb957cb181d6bbf0978be120a064df262b
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Tue Mar 8 15:44:04 2016 +0530

    features/shard: Implement discard fop
    
            Backport of: http://review.gluster.org/13657
    
    Change-Id: I1b5163ca1ceee846963f6b7d8df62dbb348afbbc
    BUG: 1299712
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/13774
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 14 Mike McCune 2016-03-28 18:51:39 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 15 Kaushal 2016-04-19 02:58:43 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.10, please open a new bug report.

glusterfs-3.7.10 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-April/026164.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 16 Kaushal 2016-04-19 03:20:46 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 17 Kaushal 2016-04-19 03:25:49 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 18 Kaushal 2016-04-19 03:52:59 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.